Forum darktable FR

Version complète : version master cassée pour moi [gnome coupable avec fc39]
Vous consultez actuellement la version basse qualité d’un document. Voir la version complète avec le bon formatage.
Pages : 1 2 3 4
bonjour,

darktable 4.5.0+1424~g522e45d874

j'ai mis à jour et recompilé le 9/12 apres avoir mis à jour fedora (fc39)

quand je veux creer un style les cases à cocher, la zone texte pour taper son nom, ne fonctionnent pas, avez vous ce soucis ?

merci

EDIT: j'ai redemarré avec -d all pour voir, ensuite je fais import, cancel, et create, a ce moment la je peux decocher/cocher, taper
mais ca n'a fonctionné qu'une fois. Completement incoherent.
EDIT2: selective copie ne fonctionne pas non plus, je n'ai reussi qu'une seule fois je ne trouve pas comment

Fabien Baï
Peut-être penser à supprimer le répertoire build avant de lancer la compilation ?
(13-12-23, 10:49)jpverrue a écrit : [ -> ]Peut-être penser à supprimer le répertoire build avant de lancer la compilation ?

oui, ca c'est obligatoire, sinon ca compile meme pas :-)

la suite, je suis preplexe,
les traces du mode -d all, sont identiques que ca fonctionne, ou pas, j'essayais de voir ce que je faisais avant.
mais ca ne change rien, si je fais N fois clicker sur create (style), cancel, au bout de 4 a X fois, ca marche.
Des fois je m'en lasse le X pouvant etre grand. On dirait que le focus ne se fait pas toujours.
Ca va pas etre pratique.
Version 4.5.0+1438 sur Opensuse Tumbleweed. Aucun problème d'interface...
(13-12-23, 11:34)jpverrue a écrit : [ -> ]Version 4.5.0+1438 sur Opensuse Tumbleweed. Aucun problème d'interface...

en faisant pull, je tombe sur 1439, toujours le meme probleme. La je dois bosser, je re-essaie plus tard, ensuite je reprendrai le package distribué par fedora.

A suivre
Ah non, je suis dans la grotte, je ne peux pas revenir en arriere de version il me dit que la base est "too new"
Je viens de compiler la 4.5.0+1439 sous OpenSuse Tumbelweed. Je ne constate pas de problèmes avec style pour les créer.
(13-12-23, 15:37)jpg54 a écrit : [ -> ]Je viens de compiler la 4.5.0+1439 sous OpenSuse Tumbelweed. Je ne constate pas de problèmes avec style pour les créer.

en allant sur github pour voir si quelqu'un a le meme souci, je suis tombé sur un utilisateur qui utilise
aussi fc39, et a le meme souci, c'est tout ce qui est checkbox et selection.
https://github.com/darktable-org/darktable/issues/15831
Je n'arrive pas à trouver:
- si darktable utilise qt ? (sans doute pas finalement, mon appli qt fonctionne tres bien)
- la liste des packages/requirements
c'est gtk pour la gui, il me semble, pas qt
Sinon dans la trace de la compile on doit voir les versions des librairies utilisées.
Il y aussi "apt-cache depends darktable" pour voir les dépendances.
Si ça peut aider?
cdlt
(13-12-23, 18:39)Cobert a écrit : [ -> ]c'est gtk pour la gui, il me semble, pas qt
Sinon dans la trace de la compile on doit voir les versions des librairies utilisées.
Il y aussi "apt-cache depends darktable" pour voir les dépendances.
Si ça peut aider?
cdlt

exact en tapant ldd sur l'executable, je vois libgtk-3.so.0, et toi ?
(dnf repoquery --requires darktable sur fedora)
même chose pour ldd, dans la compile j'ai "GTK3 (required version >= 3.24.15)"
Pages : 1 2 3 4