Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Ouvrir le dossier d'origine de l'image à partir de DT ?
#21
Merci à toi ! Smile
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#22
Apparemment avec la 2.4 on perd le raccourci. D'ailleurs je ne trouve plus les options LUA dans préférences > raccourcis...
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#23
Étrange. Je viens d'installer la 2.4.0 et chez moi ça fonctionne très bien. Tu as peut être un problème LUA dans ton package ? Sinon, quelle lettre de raccourci utilises-tu ? Je me souviens avoir dû changer avec la 2.2 à cause d'un conflit. Maintenant j'utilise CTRL-W que je trouve assez logique (W --> window...)
Mes photos : jpverrue.fr
Répondre
#24
Je n'ai pas les options Lua avec la version 2.4 ?
Répondre
#25
(27-12-17, 16:23)jpverrue a écrit : Étrange. Je viens d'installer la 2.4.0 et chez moi ça fonctionne très bien. Tu as peut être un problème LUA dans ton package ? Sinon, quelle lettre de raccourci utilises-tu ? Je me souviens avoir dû changer avec la 2.2 à cause d'un conflit. Maintenant j'utilise CTRL-W que je trouve assez logique (W --> window...)

Le raccourci est F9 de mon côté.

Tu as toujours les options LUA dans les préférences > raccourcis ?

J'utilise le packaging de Pascal de Bruijn (à qui j'ai demandé pourquoi il bindait toujours lensfun 0.2.8 en passant) :


Code :
Package: darktable
Priority: optional
Section: graphics
Installed-Size: 15738
Maintainer: Pascal de Bruijn <pmjdebruijn@pcode.nl>
Architecture: amd64
Version: 1:2.4.0-0pmjdebruijn1~xenial
Recommends: darktable-dbg, gvfs
Depends: libc6 (>= 2.15), libcairo2 (>= 1.14.0), libcolord-gtk1 (>= 0.1.20), libcolord2 (>= 0.1.34), libcups2 (>= 1.7.0), libcurl3-g
nutls (>= 7.16.2), libexiv2-14 (>= 0.25), libflickcurl0, libgcc1 (>= 1:3.0), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.39.4
), libgomp1 (>= 4.9), libgphoto2-6 (>= 2.5.9), libgphoto2-port12 (>= 2.5.9), libgraphicsmagick-q16-3 (>= 1.3.5), libgtk-3-0 (>= 3.11
.7), libilmbase12 (>= 2.2.0), libjpeg8 (>= 8c), libjson-glib-1.0-0 (>= 0.13.2), liblcms2-2 (>= 2.2+git20110628), liblensfun0 (>= 0.2
.8), liblua5.3-0, libopenexr22 (>= 2.2.0), libopenjp2-7 (>= 2.0.0), libosmgpsmap-1.0-1 (>= 1.1.0), libpango-1.0-0 (>= 1.14.0), libpa
ngocairo-1.0-0 (>= 1.14.0), libpng12-0 (>= 1.2.13-4), libpugixml1v5 (>= 1.6), librsvg2-2 (>= 2.14.4), libsecret-1-0 (>= 0.7), libsou
p2.4-1 (>= 2.47.4), libsqlite3-0 (>= 3.5.9), libstdc++6 (>= 5.2), libtiff5 (>= 4.0.3), libwebp5 (>= 0.4.3), libx11-6, libxml2 (>= 2.
7.4), libxrandr2 (>= 2:1.2.99.3), zlib1g (>= 1:1.2.0)
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#26
Oui, j'ai bien les options LUA.
Pas de messages en console ?
Mes photos : jpverrue.fr
Répondre
#27
Oui, Pascal m'a aidé pour les problèmes avec Lua, j'ai une ancienne version des scripts Lua et il faut les mettre à jour :
https://github.com/darktable-org/lua-scripts
Au fait Jean-Pierre que dis Pascal De BRUIJN pour LensFun ?
Je vais voir aussi pour les scripts comme enfuse_pro et pano_pro.
Répondre
#28
Certes, mais le script dont on parle ici fonctionne en 2.4 chez moi.
@manu as-tu essayé $ darktable --version ?
Mes photos : jpverrue.fr
Répondre
#29
(27-12-17, 17:13)jpverrue a écrit : Oui, j'ai bien les options LUA.
Pas de messages en console ?

Si...
Plein d'erreurs de LUA dont le changelog nous indique que c'est la version 5.3 utilisée.
Code :
LUA ERROR : /home/manu/.config/darktable/luarc:5: module 'darktable/external/pygy_require/require' not found:
    no file '/usr/local/share/lua/5.3/darktable/external/pygy_require/require.lua'
    no file '/usr/local/share/lua/5.3/darktable/external/pygy_require/require/init.lua'
    no file '/usr/local/lib/lua/5.3/darktable/external/pygy_require/require.lua'
    no file '/usr/local/lib/lua/5.3/darktable/external/pygy_require/require/init.lua'
    no file '/usr/share/lua/5.3/darktable/external/pygy_require/require.lua'
    no file '/usr/share/lua/5.3/darktable/external/pygy_require/require/init.lua'
    no file './darktable/external/pygy_require/require.lua'
    no file './darktable/external/pygy_require/require/init.lua'
    no file '/usr/share/darktable/lua/darktable/external/pygy_require/require.lua'
    no file '/home/manu/.config/darktable/lua/darktable/external/pygy_require/require.lua'
    no file '/usr/local/lib/lua/5.3/darktable/external/pygy_require/require.so'
    no file '/usr/lib/x86_64-linux-gnu/lua/5.3/darktable/external/pygy_require/require.so'
    no file '/usr/lib/lua/5.3/darktable/external/pygy_require/require.so'
    no file '/usr/local/lib/lua/5.3/loadall.so'

En la matière, à ce point j'ai :
Code :
$ sudo dpkg -L lua5.3
/.
/usr
/usr/bin
/usr/bin/lua5.3
/usr/bin/luac5.3
/usr/share
/usr/share/doc
/usr/share/doc/lua5.3
/usr/share/doc/lua5.3/copyright
/usr/share/doc/lua5.3/changelog.Debian.gz
/usr/share/man
/usr/share/man/man1
/usr/share/man/man1/luac5.3.1.gz
/usr/share/man/man1/lua5.3.1.gz

Bref, y'a bien un problème de LUA sur cette installation à partir du ppa de Pascal de Bruijn...

(27-12-17, 17:30)jpverrue a écrit : Certes, mais le script dont on parle ici fonctionne en 2.4 chez moi.
@manu as-tu essayé $ darktable --version ?


Code :
$ darktable --version
this is darktable 2.4.0
copyright (c) 2009-2017 johannes hanika
darktable-dev@lists.darktable.org

compile options:
  bit depth is 64 bit
  normal build
  SSE2 optimized codepath enabled
  OpenMP support enabled
  OpenCL support enabled
  Lua support enabled, API version 5.0.0
  Colord support enabled
  gPhoto2 support enabled
  GraphicsMagick support enabled
  OpenEXR support enabled

Je vais jeter un œil au github passé à par @jpg54
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#30
(27-12-17, 17:26)jpg54 a écrit : Au fait Jean-Pierre que dis Pascal De BRUIJN pour LensFun ?
Je n'en sais fichtre rien. J'utilise opensuse, alors le packaging de Pascal De BRUIJN ne me concerne pas. ;-)
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)