Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Curseur invisible
#1
Bonjour,
J'utilise la version 3.0 sous windows 10 et depuis l'installation de cette version je remarque que, dans les zones de saisie de texte de la table lumineuse (donner un titre à une image, rentrer un mot clé par exemple) ou de la chambre noire (chercher module) le curseur (pipe, tube) n'apparaît pas quand je clique dans la zone. Par contre quand j'ai cliqué dans une zone , si je tape du texte il est bien pris en compte et c'est l'essentiel ! Ai je loupé quelque chose ?
J'en profite pour remercier tous ceux qui contribuent à cet outil que je recommande et présente dans mon club photo !
Répondre
#2
(04-02-20, 14:07)MGJLOT a écrit : Bonjour,
J'utilise la version 3.0 sous windows 10 et depuis l'installation de cette version je remarque que, dans les zones de saisie de texte de la table lumineuse (donner un titre à une image, rentrer un mot clé par exemple) ou de la chambre noire (chercher module) le curseur (pipe, tube) n'apparaît pas quand je clique dans la zone. Par contre quand j'ai cliqué dans une zone , si je tape du texte il est bien pris en compte et c'est l'essentiel ! Ai je loupé quelque chose ?
J'en profite pour remercier tous ceux qui contribuent à cet outil que je recommande et présente dans mon club photo !

+1 en version 3.4.0 (Windows 10)
Répondre
#3
Pour l'instant la dernière version est la 3.2.1.1 pour Windows et il reste peu d'utilisateurs de la 3.0.
Répondre
#4
Bonjour,
@jpg54, je suppose que tu as voulu dire 3.4.1.1  Big Grin
Répondre
#5
Oups, voui ! Rolleyes
Répondre
#6
Ce problème est connu et spécifique à Windows. On ne peut rien y faire puisque ce n'est pas un bug darktable mais un bug lié à une librairie, qui s'appelle Pango, qui gère les polices de caractères et leur affichage pour Gtk, la librairie graphique utilisée pour l'interface darktable. Normalement, ça a été corrigé il y a quelques semaines sur cette librairie, dans son code source. Après, je ne saurais pas te dire comment ça se passe pour sa mise à jour sur Windows (ça dépend peut-être même de Microsoft mais là je n'en sais rien, je n'utilise pas Windows).

Pour plus d'infos, un rapport de bug et les réponses de l'équipe (incluant la mienne) à ce sujet en début d'année : https://github.com/darktable-org/darktable/issues/7615 (c'est en anglais, si besoin, Deepl est votre ami pour la traduction). Mais aussi ici, publié en juin dernier : https://github.com/darktable-org/darktable/issues/3940

Ca n'empêche pas de mettre à jour en 3.4.1.1, qui est certainement la version la plus stable et la plus avancée de darktable sur Windows.

J'avais proposé aussi un contournement possible dans darktable pour afficher ce curseur (ça reste un contournement, un patch quoi, pas un correctif durable). Pour ceux que ça intéresse, copier/coller le code suivant dans l'éditeur CSS de l'onglet Général des préférences de darktable, sauvegarder et appliquer :

Code :
entry
{
  font-family: sans;
}
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#7
Aucun souci pour ma part sous les dernières versions, mais il me semble bien l'avoir déjà constaté.
Cordialement
François


EOS 1Ds, 7D, #M42, FujiX20, W10 64 fam

Flickr

[Image: 3411.jpg]



Répondre
#8
(04-03-21, 07:24)FrançoisH a écrit : Aucun souci pour ma part sous les dernières versions, mais il me semble bien l'avoir déjà constaté.

François, ça n'est pas lié à darktable, donc peu importe ta version. Ca dépend d'une librairie externe qu'utilise darktable pour afficher les caractères via l'utilisation des polices, et surtout la gestion des polices définies en cascade. Si tu ne rencontres plus le problème, c'est peut-être que tu as la dernière version de Pango (la librairie qui gère). Maintenant comment elle se met à jour et pourquoi tu n'aurais pas ça si d'autres l'ont, je ne saurais pas dire (ça dépend en plus aussi du thème utilisé dans darktable et donc de la police utilisée derrière.

Pour essayer de faire simple (en réalité ça ne l'est pas puisque c'est un effet en chaîne de plusieurs choses), le problème vient de l'application correcte des polices de caractère définies et en particulier du fait que les polices de caractères sont bien supportées par Pango (avant le correctif) si elles sont sans serif alors qu'on part de base sur du serif (non la solution n'est pas de partir de base du sans serif, ça n'est pas aussi simple ; je simplifie ici). D'où mon "patch" qui force juste pour les champs d'entrée de texte, une version sans serif de la police de caractère.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#9
(04-03-21, 19:09)nicoauffray a écrit :
(04-03-21, 07:24)FrançoisH a écrit : Aucun souci pour ma part sous les dernières versions, mais il me semble bien l'avoir déjà constaté.

François, ça n'est pas lié à darktable, donc peu importe ta version. Ca dépend d'une librairie externe qu'utilise darktable pour afficher les caractères via l'utilisation des polices, et surtout la gestion des polices définies en cascade. Si tu ne rencontres plus le problème, c'est peut-être que tu as la dernière version de Pango (la librairie qui gère). Maintenant comment elle se met à jour et pourquoi tu n'aurais pas ça si d'autres l'ont, je ne saurais pas dire (ça dépend en plus aussi du thème utilisé dans darktable et donc de la police utilisée derrière.

Pour essayer de faire simple (en réalité ça ne l'est pas puisque c'est un effet en chaîne de plusieurs choses), le problème vient de l'application correcte des polices de caractère définies et en particulier du fait que les polices de caractères sont bien supportées par Pango (avant le correctif) si elles sont sans serif alors qu'on part de base sur du serif (non la solution n'est pas de partir de base du sans serif, ça n'est pas aussi simple ; je simplifie ici). D'où mon "patch" qui force juste pour les champs d'entrée de texte, une version sans serif de la police de caractère.

Bonjour Nicoauffray,

j'utilise la police roboto sur le thème darkelegant grey, comme il l'a été recommandé il y a plusieurs mois, quant à Pango, je ne savais même pas qu'elle était à bord du pc  Rolleyes 


[Image: pango.png]

 
Cordialement
François


EOS 1Ds, 7D, #M42, FujiX20, W10 64 fam

Flickr

[Image: 3411.jpg]



Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)