Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: JeanLucLacroixCompilation sous Debian buster
#1
Bonjour à tous,

À toutes fins utiles...

Je viens de faire une nouvelle installation d'une Debian 10 (buster) avec Gnome. La version de DT du dépôt est la 2.6.0-1 avec un bug ennuyeux que j'ai posté en décembre 2018 sur redmine (Bug #12502), bug rapidement corrigé par Pascal.

J'ai donc compilé la dernière stable 2.6.2, mais trouver les paquets pré-requis pour une compilation sans erreurs ou avertissements a pris un peu de temps. Voici la liste des paquets permettant une compilation avec toutes les options:


Code :
gcc cmake llvm clan libxml2-utils exiv2 tiff gphoto2 dbus-glib fop openexr intltool libpugixml-dev libjpeg-dev zlib1g-dev  libglib2.0-dev gtk+3.0 libgtk-3-dev libxml2-dev liblensfun-bin liblensfun-dev libgphoto2-dev libopenexr-dev libwebp-dev librsvg2-dev libsqlite3-dev libcurl-dev libcurl4-gnutls-dev libtiff5-dev liblcms2-dev libjson-glib-dev libexiv2-dev libopenjpeg-dev libopenjpeg openjpeg libopenjp2-7-dev GraphicsMagick libgraphicsmagick1-dev libflickcurl-dev libsecret-1-dev libcolord-dev libcolord libcolord-gtk-dev libosmgpsmap-1.0-dev xsltproc python3-jsonschema 

Par ailleurs, le cmake rouspette sur ma version de lua (5.3) et j'ai dû faire un cmake avec l'option du support Lua interne à DT.


Code :
cmake -DDONT_USE_INTERNAL_LUA=Off -DCMAKE_BUILD_TYPE=Release ..
Répondre


Messages dans ce sujet
Compilation sous Debian buster - par JeanLucLacroix - 12-09-19, 06:23

Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)