Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Darktable 4.4.2
#11
Bonjour,
Je viens de mettre à jour vers la version 4.4.1 avec le dépôt Opensuse sur Ubuntu 22.04 LTS.
C'est un grand pas, merci aux contributeurs. Bientôt la 4.4.2 ?
Répondre
#12
(29-07-23, 09:17)Balistic a écrit : Bonjour,

Je poste ici car ça ne sert à rien que j'ouvre un nouveau sujet juste pour ça :
la description française des curseurs de vitesse du module Diffusion et netteté est à corriger :
quand on passe la souris sur les 4 curseurs, ils indiquent tous les 4 que ce sont des basses fréquences. Alors que la doc dit que les Vitesses 1 et 2 influent sur les basses fréquences, et les vitesses 3 et 4 sur les hautes fréquences.

Merci d'avance

Bonjour Balistic,

Merci pour le signalement. Je viens de proposer la correction de cette erreur. Pascal devrait rapidement l'intégrer à la master (la prochaine version sera ok sur ce point). Voir : https://github.com/darktable-org/darktable/pull/14981
Aussi appelé Nilvus !
Debian Sid - darktable master
Répondre
#13
(23-07-23, 17:29)Primus a écrit : J'utilise le PPA ubuntuhandbook1.

Pour qui chercherait ce dont Primus parlait, ça se passe ici des paquets d'ubuntuhandbook1 par Panda Jim.
Et on y trouve la 4.4.2 pour jammy (22.04) et lunar (23.04), ce qui n'est pas si mal. Il fonctionneront a priori sur les dérivés (Mint, ...) basés sur ces versions d'Ubuntu.

D'aucun prétend qu'il y a des problèmes (et on ne sait pas lesquels) avec ce packaging.
Cependant, il n'y a pratiquement aucun bug déclaré sur son launchpad. Un dysfonctionnement non remonté aux concerné⋅es n'existe pas, c'est tout.
Dans le monde du libre (et ailleurs) quand il y a un problème il est dans l'ordre des choses de le faire savoir aux 1er⋅es intéressé⋅es. Et si cela pose des problèmes soit d'identification de l'origine du problème (le packaging ? le logiciel lui-même ?), on peut tenter l'un ou l'autre, il y aura bien quelqu'un pour préciser l'origine, soit de langue, il y a deepl.com qui traduit excellemment bien en anglais.

Pour venir de passer deux ou trois jours à construire un paquet deb pour la 4.4.2 (et une AppImage) pour tenter de nous rendre un peu plus autonome par rapport à OBS, je préconise pour le moment d'utiliser soit la version d'OBS quand elle disponible, soit celle d'ubuntuhandbook1.

Alors OK, il faut dans ce cas jouer un peu des PPA, ça n'est pas la mer à boire non plus et en définitive pas si mal puisque ça fait rentrer un peu dans la philosophie des dépôts pour éventuellement mieux comprendre comment ça marche.
dt stable / Ubuntu 22.04
Répondre
#14
L'AppImage de Manu' semble fonctionner correctement sous OpenSuse Tulbleweed à part quelques warning au démarrage concernant GTK.

L'AppImage fait quand même ~100 Mo. C'est beaucoup plus que celle dans un dépôt.
Répondre
#15
N'allons pas trop vite en besogne, dt fonctionne mais certaines fonctions s'appuyant sur des librairies externes, par exemple lensfun, ne sont pas disponibles. Ce qui est plus que gênant pour la correction des objectifs.

On y bosse toujours pour le moment. :-)
dt stable / Ubuntu 22.04
Répondre
#16
(25-08-23, 13:16)manu a écrit :
(23-07-23, 17:29)Primus a écrit : J'utilise le PPA ubuntuhandbook1.

Pour qui chercherait ce dont Primus parlait, ça se passe ici des paquets d'ubuntuhandbook1 par Panda Jim.
Et on y trouve la 4.4.2 pour jammy (22.04) et lunar (23.04), ce qui n'est pas si mal. Il fonctionneront a priori sur les dérivés (Mint, ...) basés sur ces versions d'Ubuntu.

D'aucun prétend qu'il y a des problèmes (et on ne sait pas lesquels) avec ce packaging.
Cependant, il n'y a pratiquement aucun bug déclaré sur son launchpad. Un dysfonctionnement non remonté aux concerné⋅es n'existe pas, c'est tout.
Dans le monde du libre (et ailleurs) quand il y a un problème il est dans l'ordre des choses de le faire savoir aux 1er⋅es intéressé⋅es. Et si cela pose des problèmes soit d'identification de l'origine du problème (le packaging ? le logiciel lui-même ?), on peut tenter l'un ou l'autre, il y aura bien quelqu'un pour préciser l'origine, soit de langue, il y a deepl.com qui traduit excellemment bien en anglais.

Pour venir de passer deux ou trois jours à construire un paquet deb pour la 4.4.2 (et une AppImage) pour tenter de nous rendre un peu plus autonome par rapport à OBS, je préconise pour le moment d'utiliser soit la version d'OBS quand elle disponible, soit celle d'ubuntuhandbook1.

Alors OK, il faut dans ce cas jouer un peu des PPA, ça n'est pas la mer à boire non plus et en définitive pas si mal puisque ça fait rentrer un peu dans la philosophie des dépôts pour éventuellement mieux comprendre comment ça marche.

Bonjour,

Merci à manu pour tous ses efforts.
Je viens d'installer la 4.4.2 avec ubuntuhandbook.
Je constate les 2 mêmes soucis que j'avais avec la 4.4.1.
Le raccourci f dans la table lumineuse n'est pas assigné.
Et dans la chambre noire, j'ai 2 modules qui gardent 2 instances actives en permanence : filigrane et réduction du bruit (profil).
Le problème persiste même avec de nouvelles images jamais développées.
François-Marie
Répondre
#17
Pour moi, la correction d'objectifs fonctionne :
[Image: image.png]
Répondre
#18
(25-08-23, 15:29)zakfm a écrit : Le raccourci f dans la table lumineuse n'est pas assigné.
Et dans la chambre noire, j'ai 2 modules qui gardent 2 instances actives en permanence : filigrane et réduction du bruit (profil).
Le problème persiste même avec de nouvelles images jamais développées.

Pour le raccourci  f dans la table lumineuse, il fonctionne sur toutes les versions de 4.4.2 dont je dispose maintenant, j'imagine que tu as vérifié dans les Préférences > Raccourcis > Vues > Table lumineuse qu'il est bien sur Vues/Table lumineuse/Aperçu | Normal | Basculer ?

Pour les 2 instances actives en permanence dans la chambre noire, qu'entends-tu exactement ? 

(25-08-23, 18:49)jpg54 a écrit : Pour moi, la correction d'objectifs fonctionne :
[Image: image.png]

Tu as la correction d'objectif parce que la librairie liblensfun est installé sur ta machine.
Mais pour qui n'a pas cette librairie installée sur sa machine, la correction d'objectif n'est pas effective dans dt. Idem pour les cartes/maps et midi.

Il y a un paradoxe avec les AppImages qui sont supposées pouvoir fonctionner sur pratiquement toutes les distros Linux pas trop anciennes, c'est qu'elles utilisent néanmoins des librairies de la machine sur laquelle elle tourne (pas si que ça autonome l'AppImage !), et que si la machine ne l'a pas, ça marche pas... alors que la librairie est bien dans l'AppImage mais qu'elle est infoutue de la trouver !
dt stable / Ubuntu 22.04
Répondre
#19
(25-08-23, 19:12)manu a écrit :
(25-08-23, 15:29)zakfm a écrit : Le raccourci f dans la table lumineuse n'est pas assigné.
Et dans la chambre noire, j'ai 2 modules qui gardent 2 instances actives en permanence : filigrane et réduction du bruit (profil).
Le problème persiste même avec de nouvelles images jamais développées.

Pour le raccourci  f dans la table lumineuse, il fonctionne sur toutes les versions de 4.4.2 dont je dispose maintenant, j'imagine que tu as vérifié dans les Préférences > Raccourcis > Vues > Table lumineuse qu'il est bien sur Vues/Table lumineuse/Aperçu | Normal | Basculer ?

Pour les 2 instances actives en permanence dans la chambre noire, qu'entends-tu exactement ? 

Merci pour le f que j'ai pu trouver grâce à ton cheminement et que j'ai basculé sur activé. Ça marche.
J'ai 2 instances de filigrane actives par défaut (deux signatures différentes qui se chevauchent)
Et 2 instances de réduction bruit (profil) actives aussi par défaut.
J'ai essayé de bidouiller dans Gérer les préréglages, en vain.
Il doit peut-être falloir aller dans les fichiers de configuration...
À force d'installer et de désinstaller différentes versions peut-être.
Dans le snap, c'est nickel, vu qu'il est indépendant avec son "bac à sable".
Mais j'aimerais mieux le ppa.

(25-08-23, 18:49)jpg54 a écrit : Pour moi, la correction d'objectifs fonctionne :
[Image: image.png]

Tu as la correction d'objectif parce que la librairie liblensfun est installé sur ta machine.
Mais pour qui n'a pas cette librairie installée sur sa machine, la correction d'objectif n'est pas effective dans dt. Idem pour les cartes/maps et midi.

Il y a un paradoxe avec les AppImages qui sont supposées pouvoir fonctionner sur pratiquement toutes les distros Linux pas trop anciennes, c'est qu'elles utilisent néanmoins des librairies de la machine sur laquelle elle tourne (pas si que ça autonome l'AppImage !), et que si la machine ne l'a pas, ça marche pas... alors que la librairie est bien dans l'AppImage mais qu'elle est infoutue de la trouver !
François-Marie
Répondre
#20
Ceci dit, les librairies manquantes pour l'AppImage sont des dépendances de dt, autrement dit des prérequis pour dt et elles sont automatiquement installées quand on installe dt via un paquet .deb (ou .rpm)... 

Donc pour le dire autrement, pour qui veut faire tourner dt sur sa machine avec toutes les fonctionnalités, il leur faut ces librairies (que l'AppImage devrait fournir, on est d'accord) et, en attendant mieux, il est tout à fait possible d'installer ces librairies à la main.

Ce sera pour liblensfun (les corrections d'objectifs), libosmgpsmap (les localisations et la carte), libportmidi (interface midi) et libdsl2 (gamepad), pour qui a une machine Debian, *Ubuntu, Mint et autres dérivés :
Code :
sudo apt install -y liblensfun1 libosmgpsmap-1* libportmidi0 libsdl2-2.0-0

Les autres (OpenSUSE, Fedora et compères) trouveront comment s'y prendre.

Il faut aussi tenir compte qu'ayant créé cette AppImage sur Ubuntu 22.04, elle n'est pas susceptible de marcher sur une version antérieure à ce qui correspond à cette version. Pour *Ubuntu, c'est facile : ≥22.04.
Pour les Mint et autres dérivées il faut se référer aux Wikis correspondants si on sait pas quelle version d'Ubuntu est "sous" la version de sa distribution.

Et bien sûr penser à rendre exécutable l'AppImage après l'avoir téléchargée.

J'oubliais !

La version AppImage ne supporte pas le format JPEG XL.
La version deb actuellement disponible sur le PPA ubuntuhandbook1 non plus.

Pas d'jaloux ! Big Grin

(25-08-23, 19:43)zakfm a écrit : J'ai 2 instances de filigrane actives par défaut (deux signatures différentes qui se chevauchent)
Et 2 instances de réduction bruit (profil) actives aussi par défaut.
J'ai essayé de bidouiller dans Gérer les préréglages, en vain.
Il doit peut-être falloir aller dans les fichiers de configuration...
À force d'installer et de désinstaller différentes versions peut-être.
Dans le snap, c'est nickel, vu qu'il est indépendant avec son "bac à sable".
Mais j'aimerais mieux le ppa.

Les 2 instances de filigrane, tu les as pour "ombrer" ta signatures ? Utilise plutôt "simple-test-ombré" comme "fichier" dans le module, ça marche bien.

Sinon, désolé je vois pas pour cette affaire de deux instances toujours actives...
dt stable / Ubuntu 22.04
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 12 visiteur(s)