Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: lionelExifs de l'objectif non reconnu
#31
Si je comprends bien, tu réponds non au point 1 de mon exposé. Pour quel objectif ? le zoom Tamron, le 150 Sigma ou le 50 Sigma ?

Vérifie ce que te donne la ligne avec l'utilitaire exiv2 (à installer éventuellement) sur un des fichiers qui te posent problème.

Code :
exiv2 pr -g 'Lens' <ton_fichier_raw>

Cette commande me donne par exemple :
Code :
JPV_0281.NEF          Exif.Nikon3.LensType                         Byte        1  D G VR
JPV_0281.NEF          Exif.Nikon3.Lens                             Rational    4  70-200mm F2.8
JPV_0281.NEF          Exif.Nikon3.LensFStops                       Undefined   4  6
JPV_0281.NEF          Exif.NikonLd3.LensIDNumber                   Byte        1  Nikon AF-S VR Zoom-Nikkor 70-200mm f/2.8G IF-ED
JPV_0281.NEF          Exif.NikonLd3.LensFStops                     Byte        1  F6.0

Tu peux lire toutes les explications sur l'utilisation de l'utilitaire ICI.

Si tu n'a pas ce genre d'informations concernant ton objectif, mais seulement un chiffre à la place de son nom. Il faut, comme je le disais mettre à jour exiv2 en espérant que ton objectif aie été pris en charge par cette MàJ. Et Sinon, faire une demande d'ajout sur le site d'Exiv2
Quelle est ta distribution ?
Mes photos : jpverrue.fr
Répondre
#32
lionel, si je reprends ton premier message et que j'essaie de bien le comprendre:

"Bonjour,
Citation :<div>

Pas sur que je sois dans la bonne section, désolé si c’est pas le cas.

J’ utilise un Nikon D610 et comme objectifs le tamron 70-200, le sigma 150 macro et le sigma 50mm

Dans digikam, le type d’ objectif n’est pas reconnu, à la place je me retrouve avec des chiffres genre 153 pour le sigma 150.

Je ne peux changer dans la liste déroulante, du coup la correction d’ objectif n’est pas possible boitier/objectif non reconnu.

Le boitier lui est bien reconnu


</div>

<div>

Avec un canon 60d , pas de soucis."


</div>
 

Premièrement ce sont bien tous les objectifs cités qui ne sont pas pris en compte, avec le D610 ?

Deuxièmement tu parles du 60D où il n'y a pas de souci, je suppose que tu n'utilises pas les mêmes objectifs. Est ce que tous les objectifs montés avec ton D610 ont le même problème ?

Enfin tu parles de Digikam, erreur de frappe ou tu utilises uniquement Digikam, as tu essayer avec Darktable? peu de chance que ce soit différent.

 

désolé pour les questions, mais je voulais juste bien comprendre le problème, car si j'ai bien cerné, ce n'est pas un problème avec ton 150 sigma mais bien l'ensemble de tes objectifs associés au D610.

 

Si je suis à la ramasse, milles pardons, et oublie.
David - Région Hauts-de-France

Debian stable - darktable git/master
Répondre
#33
à jpv,

si je comprends bien, il me suffit de remplacer <ton_fichier_raw>par le nom de mon fichier qui est dans mon cas DSC_4529.jpg dans ton code:

Code :
exiv2 pr -g ‘Lens’ <ton_fichier_raw>

Si c'est ça, j'ai fichier introuvable.

Le lien que tu me mets m' envoie vers une page de présentation de exiv2, et je comprends pas ton histoire de mise à jour, mes objectifs sont dans les fichiers de Darktable, que changerais une mise à jour:

Code :
<lens>
<maker>Sigma</maker>
<model>SIGMA 150mm F2.8 MACRO HSM</model>
<focal value="150" />
<aperture min="2.8" max="22" />
<mount>4/3 System</mount>
<cropfactor>2</cropfactor>
<calibration>
<distortion focal="150" model="ptlens" a="-0.00472839" b="0.0149475" c="-0.0142996" />
<tca model="poly3" focal="150" br="-0.0000907" vr="1.0002304" bb="-0.0000342" vb="0.9999827" />
<vignetting model="pa" focal="150" aperture="2.8" distance="0.38" k1="-0.0056" k2="-0.1198" k3="0.0358" />
<vignetting model="pa" focal="150" aperture="2.8" distance="0.7" k1="-0.1310" k2="-0.1905" k3="0.1496" />

....

 

à Riomatdav,

oui désolé j'ai du mal avec Digikam et Darktable, mais c'est bien de Darktable que je parle.

Mes essais avec le d60 était bien entendu avec d' autres objectifs dédiés au Canon.

Enfin, ce sont bien tout mes objectifs qui sont concernés, comme vous pouvez le voir dans mes filtres de collection paramétré sur "objectifs"

[Image: 243087capture6.png]

 

 

 

 
Répondre
#34
J'ai pas trouvé le bouton edit...

Juste pour répondre que ma distribution est Kubuntu question à laquelle j'avais oublié de répondre
Répondre
#35
lionel, c'est lensfun qui gère les corrections d'objectifs.

Mais jpv, à raison, te parle bien d'exiv2 qui lui, va permettre de chercher dans les exifs de la photo quel objectif est utilisé afin de pouvoir faire le lien avec lensfun. (je vais vite mais tu comprends le principe).

Kubuntu récente ?

Peux tu, stp, sous darktable ouvrir une photo dans la chambre noir et dérouler l'outil correction des objectifs une fois activé, et poster une capture d'écran ?
David - Région Hauts-de-France

Debian stable - darktable git/master
Répondre
#36
Citation :si je comprends bien, il me suffit de remplacer <ton_fichier_raw>par le nom de mon fichier qui est dans mon cas DSC_4529.jpg dans ton code:

Code :
exiv2 pr -g ‘Lens’ <ton_fichier_raw>

Si c’est ça, j’ai fichier introuvable.

Concernant la syntaxe, oui, c'est bien le nom de ton fichier. Si tu as "fichier introuvable" c'est que tu ne t'es pas positionné dans le bon répertoire pour passer la commande. Tu peux essayer, soit de te placer dans le bon répertoire avec la commande 'cd', soit de donner le nom complet du fichier en incluant le répertoire.

Exemple :
Code :
exiv2 pr -g 'Lens' /home/<mon répertoire de login>/<Mon répertoire de photos>/<mon_fichier_raw>
Mes photos : jpverrue.fr
Répondre
#37
Suite...
Si tu as le même problème avec tout tes objectifs et que ceux-ci existent bien dans la base Lensfun, tu as très certainement un problème d'installation avec le paquetage Exiv2.
Mes photos : jpverrue.fr
Répondre
#38
Re,

Code :
le résultat de:

Code :
exiv2 pr -g 'Lens' /home/<mon répertoire de login>/<Mon répertoire de photos>/<mon_fichier_raw>

me donne:

lionel@lionel-W65-67SC:~$ exiv2 pr -g 'Lens' /home/lionel/images/DSC_4500.NEF
/home/lionel/images/DSC_4500.NEF: Échec de l'ouverture du fichier

 

[quote quote=2297]Suite… Si tu as le même problème avec tout tes objectifs et que ceux-ci existent bien dans la base Lensfun, tu as très certainement un problème d’installation avec le paquetage Exiv2. [/quote]

et pour le réinstaller proprement comment faudrait t-il que je fasse?
Répondre
#39
Avec ton gestionnaire de paquet préféré muon je pense sur kubuntu ou synaptic tu cherche le paquet exiv2. Tu supprimes complétement le paquet exiv2 puis même opération pour l'installer cette fois.

Sinon en console avec sudo et apt-get remove --purge exiv2

puis apt-get install exiv2

Avant toute opération recharge tes sources par un apt-get update.
David - Région Hauts-de-France

Debian stable - darktable git/master
Répondre
#40
@Riomatdav : Merci pour le coup de main, car je ne connais que très peu les distrib Ubuntu et dérivées ;-)
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)