Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: lionelExifs de l'objectif non reconnu
#61
On obtient la liste des fichiers installés en saisissant :

Code :
sudo dpkg -L liblensfun-data

Dans une configuration nominale, tout est là...

En revanche, je pense que ce n'est pas le nom de fichier .xml qui importe mais son contenu. Et je suggérerais de non pas le renommer, ou alors en .NOxml, mais plutôt le déplacer (en lieu sûr pour pouvoir le remettre au besoin).

Sinon, voir sur le salon d'entraide DT sur irc.freenode.net, channel #darktable
Ubuntu 18.04 + dt 2.6 & Pentax K5 & K3-II + cailloux Pentax et Sigma

Répondre
#62
Merci pour ces précisions, de mon côté j'ai continué mes investigations et résolu le problème :

DT utilise la version de "Lensfun" installée dans le système Ubuntu et implantée dans :

Code :
/usr/share/lensfun

Il y avait donc 2 problèmes à résoudre :
  • Manque les références de mes deux objectifs dans la liste du choix manuel (menu Tamron)
  • Pas de détection automatique de mes deux objectifs
Le premier problème a été résolu par la mise à jour, dans l'ordre, de DT (2.0.5) et de Lensfun (0.2.8-3) :

1°) Ajout des ppa pour passage à DT 2.05

Code :
sudo add-apt-repository -y ppa:pmjdebruijn/darktable-release
sudo apt-get update
sudo apt-get install darktable

2°)  À l'aide de "Synaptic" (gestionnaire de paquet Ubuntu) rechercher les paquets "Lensfun" et demander la mise à jour des deux paquets :

Code :
liblensfun-data
liblensfun0

En relançant DT, mes objectifs ne sont pas reconnus automatiquement, mais ils apparaissent dans le choix manuel du menu "tamron" (premier problème résolu)

Le deuxième problème (pas de détection automatique) vient de la différence d'encodage du nom de l'objectif par rapport au nom qu'il porte dans la description du fichier de "Lensfun". Pour obtenir une détection automatique, il faut que les deux noms soient rigoureusement identiques :


1°) Détermination du nom de l'objectif encodé dans les exifs de la photo :

À l'aide la commande "exiv2" (ajouter le paquet si cette commande n'est pas disponible) :

Code :
exiv2 -pt DSC_0022.NEF | grep -ai lens

Code :
...
Exif.NikonLd3.LensIDNumber Byte 1 [b]Tamron SP 90mm F/2.8 Di VC USD MACRO 1:1[/b]
...

2°) Modifier le fichier de définition "slr-tamron.xml" pour mettre le nom en gras dans la description de l'objectif :

Code :
sudo vi /usr/share/lensfun/slr-tamron.xml

Modifier la ligne décrivant le modèle en langue anglaise pour y mettre la chaîne de caractères en gras  (Attention de bien respecter les espaces et les majuscules/minuscules) :

Code :
<lens>
<maker>Tamron</maker>
<model>Tamron SP AF 90mm f/2.8 Di Macro 1:1</model>
<model lang="en">[b]Tamron SP 90mm F/2.8 Di VC USD MACRO 1:1[/b]</model>
...

On relance DT, et voilà, çà marche !  l'objectif est reconnu automatiquement  ;-)

ATTENTION : de tout ce que j'ai pu lire, il ressort que DT 2.0.5, N'EST PAS COMPATIBLE avec les dernières version de Lensfun (0.3.0.x) il faut donc utiliser les versions les "moins anciennes" de Lensfun (0.2.8-x)

Deux pointeurs :
https://www.darktable.org/2015/02/on-len...orrection/
http://photo.stackexchange.com/questions/61791/how-do-i-add-lens-correction-for-my-modellens-to-lensfun-in-darktable?lq=1

 

 
Répondre
#63
Sur le site Lensfun, le Tamron 16-300 figure bien dans la liste des objectifs supportés

Dans les dernières versions de Lensfun - au moins chez moi, avec mon opensuse -, les fichiers xml ne sont plus tout à fait à la même place :

Avant : /usr/share/lensfun.
Maintenant : /usr/share/lensfun/version_1.

Peut-être est-ce là qu'est ton problème ?
Mes photos : jpverrue.fr
Répondre
#64
Oops, j'avais pas vu la dernière page du fil avant de répondre. Content que tu aies pu résoudre ton problème.

Je crois que ce que tu rapportes à propos de la compatibilité DT 2.0 et Lensfun est erroné. Sur les deux listes de diffusions : darktable-devel et darktable-users, chaque fois qu'un problème de reconnaissance d'objectif est rapporté, la première recommandation est la mise à jour de lensfun en version 0.3.2.

J'ai moi-même eu des problèmes de plantage systématique de DT (1.6.9 à l'époque, il me semble), avec blocage de l'interface graphique, que j'ai résolu simplement en passant de lensfun 0.2.8 à lensfun 0.3.2...
Mes photos : jpverrue.fr
Répondre
#65
Effectivement jpv, j'ai bien remarqué cette différence d'implantation de Lensfun 0.3.2 (/usr/share/lensfun/version_1) mais même en déplaçant l'installation dans "/usr/share/lensfun" (ou en faisant un lien), rien n'y fait, pas de liste déroulante pour le choix manuel de l'objectif.
La seule solution a été de revenir à une version "0.2.8-3" (mai 2016) de Lensfun qui, pour le moment, fonctionne sans plantage chez moi (attendre un peu pour voir ;-)) avec DT 2.0.5.

Merci à tous pour vos différentes interventions sur le sujet.
Répondre
#66
Attention, si tu veux faire le changement, il de faut mettre à jour dans l'ordre : le package librairie et ensuite la dernière version de la base donnée.
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)