Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Ouvrir le dossier d'origine de l'image à partir de DT ?
#31
(27-12-17, 17:26)jpg54 a écrit : Au fait Jean-Pierre que dis Pascal De BRUIJN pour LensFun ?

Pour l'instant aucune réponse...

Mais dans la PPA description (https://launchpad.net/~pmjdebruijn/+arch...le-release), il indique :

Do not install a more recent version of Lensfun using another PPA as it will likely cause issues due the API changes. The lensfun package for Xenial on this PPA already has new lenses patched in.
Ubuntu 20.04 + dt "master"
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#32
C'est quoi "pygy" ? J'ai pas ça chez moi
Mes photos : jpverrue.fr
Répondre
#33
Je viens de télécharger Lua : https://github.com/darktable-org/lua-scripts et Lua fonctionne.
Répondre
#34
(27-12-17, 17:48)jpverrue a écrit : C'est quoi "pygy" ? J'ai pas ça chez moi

Je ne sais pas... Big Grin 

Dans luarc j'avais :

Code :
-- default  lua require can't handle yielding across "require" calls
-- This version is implemented in pure-lua and avoids the problem
-- override the require function for everybody

require = require "darktable/external/pygy_require/require".require

require "fichiers"
require "yield"
require "gimp"

Je viens de virer la ligne avec pygy_require et LUA ne m'insulte plus autant.

Juste :

Code :
LUA ERROR : ./gimp.lua:51: Module gimp is not compatible with API 5.0.0


Ce qui, je me doute, me posera un problème quand je voudrai exporter direct dans GIMP, ce que je ne fais jamais en fait...

Merci ! Wink
Ubuntu 20.04 + dt "master"
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#35
Voilà où ça coince avec le fichier file.lua :
[Image: Capture_du_2017_12_27_20_17_11.png]
image uploader
Je suppose que tu dois aussi faire la modif comme à gauche qui est le fichier qui fonctionne avec l'Api 5.0.0.
Répondre
#36
(27-12-17, 17:42)manu a écrit :
(27-12-17, 17:26)jpg54 a écrit : Au fait Jean-Pierre que dis Pascal De BRUIJN pour LensFun ?

Pour l'instant aucune réponse...

Mais dans la PPA description (https://launchpad.net/~pmjdebruijn/+arch...le-release), il indique :

Do not install a more recent version of Lensfun using another PPA as it will likely cause issues due the API changes. The lensfun package for Xenial on this PPA already has new lenses patched in.

Voilà la réponse de Pascal de Bruijn concernant le lensfun 0.2.8 qu'il fournit :
Citation :My lensfun 0.2.8 package already has it's lens database far far ahead of lensfun 0.3.2:

$ zcat  /usr/share/doc/liblensfun0/changelog.Debian.gz | head
lensfun (0.2.8-3pmjdebruijn3~xenial) xenial; urgency=low

  * debian/patches/lens_db_20171104.diff:
    - Update lens database

En français :
Citation :Mon paquet lensfun 0.2.8 a déjà sa base de données d'objectifs bien plus avancée que lensfun 0.3.2
Ubuntu 20.04 + dt "master"
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#37
(03-01-18, 13:39)manu a écrit :
(27-12-17, 17:42)manu a écrit :
(27-12-17, 17:26)jpg54 a écrit : Au fait Jean-Pierre que dis Pascal De BRUIJN pour LensFun ?

Pour l'instant aucune réponse...

Mais dans la PPA description (https://launchpad.net/~pmjdebruijn/+arch...le-release), il indique :

Do not install a more recent version of Lensfun using another PPA as it will likely cause issues due the API changes. The lensfun package for Xenial on this PPA already has new lenses patched in.

Voilà la réponse de Pascal de Bruijn concernant le lensfun 0.2.8 qu'il fournit :
Citation :My lensfun 0.2.8 package already has it's lens database far far ahead of lensfun 0.3.2:

$ zcat  /usr/share/doc/liblensfun0/changelog.Debian.gz | head
lensfun (0.2.8-3pmjdebruijn3~xenial) xenial; urgency=low

  * debian/patches/lens_db_20171104.diff:
    - Update lens database

En français :
Citation :Mon paquet lensfun 0.2.8 a déjà sa base de données d'objectifs bien plus avancée que lensfun 0.3.2
Bonjour. Comment fait-on pour connaître la version de Lensfun qui est installée? J'ai essayé d'installer la 0.3.2 mais je ne sais pas si j'ai réussi. Oui, j'avoue, je suis une quiche Dodgy
Répondre
#38
Comment as-tu installé la 0.3.2?

Si c'est depuis les paquets, alors un :
Code :
apt-cache policy liblensfun1

te donnera la version.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#39
(14-01-18, 09:55)pascal a écrit : Comment as-tu installé la 0.3.2?

Si c'est depuis les paquets, alors un :
Code :
apt-cache policy liblensfun1

te donnera la version.

Très bonne question: je ne sais plus! J'ai téléchargé une archive tar depuis le site de lenfun si je me rappelle bien puis installé avec un terminal en suivant les instructions.
C'est bien la 0.3.2 qui est installée. C'est sans doute pour ça que je n'ai pas toutes les corrections d'objectifs disponibles: je ne trouve pas celle pour le Nikkor Afs 35mm 1,8 G ED qui est présente dans Darktable version Windows (ce n'est peut-être pas le même "fournisseur" non plus?)
J'imagine qu'il faut désinstaller cette version de Lensfun et reprendre le dépôt de Debrujn?
Répondre
#40
Ou la la... installé depuis un tar Sad Tu as probablement mis le souk sur ta machine et récupérer peut être assez difficile Sad

Avec un peu de change l'installation est dans /usr/local/ ... mais bon!

Pour compléter ma réponse : toujours utiliser les paquets des mainteneurs de ta distribution, toujours, sans exception.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)