Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: bilebokeh[résolu] Problème avec 2.2.3 sur Ubuntu 16.10.1 (ppa gnome3-staging)
#1
Bonjour,

Fraîchement installé la 2.2.3 sur Ubuntu 16.10 amd64 tout frais aussi avec Gnome 3, je rencontre un gros pépin (pareil avec Unity).
Darktable se lance mais dispose d'un affichage très grossier (grosse typo, grosses icônes) et le pire, une épaisse bordure rouge sur tous les contours des panneaux de la fenêtre du logiciel. En gros : inutilisable (cf. screenshot ci-dessous)

Quelqu'un saurait quoi faire pour retrouver un affichage potable avec des panneaux fins et précis ?

[Image: Capture_du_2017_02_02_17_44_22.png]

------------ edit ----------

Je continue l'enquête...
J'ai supprimé le dossier .gconf/apps/darktable et réinstallé les apps.
J'ai lancé "darktable -d all". Des problèmes au démarage.
Code :
** (darktable:10807): WARNING **: Couldn't register with accessibility bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:23:18: not a number

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:23:18: Expected a string.

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:832:10: not a number

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:832:24: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1985:14: not a number

(darktable:10807): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1985:14: Expected a string.

(darktable:10807): Gtk-WARNING **: Theme parsing error: nautilus.css:55:71: Using one color stop with linear-gradient() is deprecated.

(darktable:10807): Gtk-WARNING **: Theme parsing error: nautilus.css:56:71: Using one color stop with linear-gradient() is deprecated.
[fswatch_new] fswatch not supported on your platform
Répondre
#2
Un problème de CSS, ta version de Gtk n'est pas compatible avec la 2.2.3. Est-ce que la 2.2.2 marchait?
Répondre
#3
Tu as installé darktable comment ?

Quand on compile dt, normalement il s'adapte à la version de gtk et utilise le bon fichier CSS pour paramétrer l'interface graphique. Quand le moteur n'arrive pas à lire le CSS, ça donne l'affichage que tu as. Je soupçonne un darktable compilé par quelqu'un qui n'a pas la même version de gtk que toi (je ne sais pas exactement ce qu'il se passe dans ces cas là) et si c'est le cas recompiler dt résoudrait sans doute le problème.
Répondre
#4
J'ai fait comme ce que j'avais fait sous Ubuntu 16.04 32b (je crois que c'était la version que j'avais sur mon ancien PC) :

Code :
deb http://ppa.launchpad.net/pmjdebruijn/darktable-release/ubuntu yakkety main

Code :
$ apt-cache show darktable
Package: darktable
Priority: optional
Section: graphics
Installed-Size: 14653
Maintainer: Pascal de Bruijn <pmjdebruijn@pcode.nl>
Architecture: amd64
Version: 1:2.2.3-0pmjdebruijn1~yakkety

Pour info :
libgtk-3-0 : 3.22.7-1ubuntu1~ubuntu16.10.1
libgtk2.0-0 : 2.24.30-4ubuntu3

J'ai désinstallé la version du lauchpad pour installer la version officielle de la distro. Même topo avec la 2.0.5-2build1.

Je viens de relever ce rapport de bug : https://redmine.darktable.org/issues/11185
ça semble coller avec ce qui se passe chez moi...

J'oubliais aussi, le topic de ce forum que je viens de lire : https://darktable-fr.tuxfamily.org/forum...p?tid=1488 Same again...

Du coup, j'ai tenté la compilation avec l'aide du wiki. La même en couleur...
Code :
/opt/darktable/bin$ darktable -d all
[memory] at startup
[memory] max address space (vmpeak):      327156 kB
[memory] cur address space (vmsize):      327156 kB
[memory] max used memory   (vmhwm ):       19704 kB
[memory] cur used memory   (vmrss ):       19704 kB

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:23:18: not a number

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:23:18: Expected a string.

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:832:10: not a number

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:832:24: Using Pango syntax for the font: style property is deprecated; please use CSS syntax

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1985:14: not a number

(darktable:22592): Gtk-WARNING **: Theme parsing error: gtk-widgets.css:1985:14: Expected a string.

(darktable:22592): Gtk-WARNING **: Theme parsing error: nautilus.css:55:71: Using one color stop with linear-gradient() is deprecated.

(darktable:22592): Gtk-WARNING **: Theme parsing error: nautilus.css:56:71: Using one color stop with linear-gradient() is deprecated.
[fswatch_new] fswatch not supported on your platform
Répondre
#5
(02-02-17, 22:56)bilebokeh a écrit : Pour info :
libgtk-3-0 : 3.22.7-1ubuntu1~ubuntu16.10.1
libgtk2.0-0 : 2.24.30-4ubuntu3

C'est bizarre que tu aies une version 3.22 de gtk3. A priori tu devrais avoir une 3.20 : http://packages.ubuntu.com/yakkety/libgtk-3-0

Je pense que tu as installé un gtk non-standard, et c'est possiblement l'origine de tes problèmes. Que dit
Code :
apt-cache policy libgtk-3-0

?
Répondre
#6
Bonjour,

Ah oui, bien vu ! C'est les librairies du dépot gnome3-staging. J'avais omis ce gros point noir au milieu de la figure.

Code :
libgtk-3-0:
  Installé : 3.22.7-1ubuntu1~ubuntu16.10.1
  Candidat : 3.22.7-1ubuntu1~ubuntu16.10.1
Table de version :
*** 3.22.7-1ubuntu1~ubuntu16.10.1 500
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu yakkety/main amd64 Packages
        100 /var/lib/dpkg/status
     3.20.9-1ubuntu2 500
        500 http://fr.archive.ubuntu.com/ubuntu yakkety/main amd64 Packages

Une purge de ce PPA et ça fonctionne bien mieux !

Je vais enfin pouvoir me replonger dans l'étude de ce monstrueux darktable. J'ai changé de PC rien que pour ça ! ;-)

Bonne journée.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)