Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: kohlerggps4cam et linux
#1
bonjour,

j'utilise Gps4cam pour géolocaliser mes photos depuis longtemps , d'abord avec l'Iphone puis sous Android

le problème était que j'étais obligé de passer par une émulation Wondows pour tager mes photos.
Grace à https://blog.andi95.de/2014/10/gps4cam-and-linux/ (merci à lui)

je peux maintenant me passer de Windows.

voici ma manip :

télécharger gps4cam_V7.2.zip depuis le site de Gps4cam http://diguet.fr/gps4cam_EN/gps4cam/Down...m_V7.2.zip


installer si ce n'est pas fait : dcraw et exiftool
extraire le fichier gps4cam.exe del'archive
créer un répertoire /usr/share/gps4cam
placer gps4cam.exe dedans
créer un script exécutable dans /usr/bin : gps4cam.sh


Code :
#! /bin/bash
java -jar /usr/share/gps4cam/gps4cam.exe

vérifier toutes les permissions et les droits d'éxécution

installer une entrée dans le menu de KDE ou Gnome ou  autre ...
on trouve l'icone de gps4cam dans le zip

on lance gps4cam et dans les préférences on inscrit la localisation d'exiftool et de dcraw (pour ma part : /usr/bin/exiftool et /usr/bin/dcraw)

et voila ça marche !
Répondre
#2
Tout cela m'a l'air bien compliqué ou alors je loupe une marche? De mon coté, j'utilise GPSLogger (simple te pas trop gourmand en batterie) sur Android que je lance lorsque je fais une virée photo. A la maison je récupère le .gpx généré par GPSLogger que j'applique directement dans notre logiciel favori darktable. Et voilà, mes photos sont géolocalisées sur le module carte.
Répondre
#3
(21-02-17, 18:49)pobry a écrit : Tout cela m'a l'air bien compliqué ou alors je loupe une marche? De mon coté, j'utilise GPSLogger (simple te pas trop gourmand en batterie) sur Android que je lance lorsque je fais une virée photo. A la maison je récupère le .gpx généré par GPSLogger que j'applique directement dans notre logiciel favori darktable. Et voilà, mes photos sont géolocalisées sur le module carte.
En lisant le mail de Pascal Obry, j'ai voulu utilisé GPSLogger. L'application que je ne connaissais pas semble effectivement simple et fonctionnelle. Mais j'ai un pb de décalage d'une heure. Je m'explique: mon téléphone est bon horaire, lorsque je lance GPSLogger avec l'affichage du journal, les horaires sont les bons. Je génère mon fichier gpx, je l'applique dans Darktable mais ma localisation n'est pas appliquée aux images. En ouvrant le fichier gpx je me suis aperçu que la date est la bonne mais que l'heure est avancée d'1 heure. J'ai essayé de modifier mes paramètres horaires sur mon téléphone (heure et fuseau horaire par le réseau ou non) mais rien ne change. Si je mets la bonne heure dans le fichier gpx, alors Darktable applique bien la localisation.
As tu une idée?
Répondre
#4
(23-02-17, 14:00)marc a écrit : Je m'explique: mon téléphone est bon horaire, lorsque je lance GPSLogger avec l'affichage du journal, les horaires sont les bons. Je génère mon fichier gpx, je l'applique dans Darktable mais ma localisation n'est pas appliquée aux images.

Ne serait-ce pas un problème heure d'été/hiver? Sur ton téléphone tout est ok, si le GPX ne semble pas à l'heure c'est je pense parce que l'heure est enregistré en UTC. Et ton appareil est-il à l'heure? Et si oui as-tu bien sélectionné le mode heure d'hiver?

Maintenant c'est récupérable, dans darktable tu peux appliquer un décalage horaire depuis l'interface.
Répondre
#5
(23-02-17, 21:23)pobry a écrit :
(23-02-17, 14:00)marc a écrit : Je m'explique: mon téléphone est bon horaire, lorsque je lance GPSLogger avec l'affichage du journal, les horaires sont les bons. Je génère mon fichier gpx, je l'applique dans Darktable mais ma localisation n'est pas appliquée aux images.

Ne serait-ce pas un problème heure d'été/hiver? Sur ton téléphone tout est ok, si le GPX ne semble pas à l'heure c'est je pense parce que l'heure est enregistré en UTC. Et ton appareil est-il à l'heure? Et si oui as-tu bien sélectionné le mode heure d'hiver?

Maintenant c'est récupérable, dans darktable tu peux appliquer un décalage horaire depuis l'interface.

Ça ressemble effectivement à un problème heure d'été / heure d'hiver. Pourtant je ne trouve pas ce paramètre sur mon téléphone (LG G3 Android), les seuls paramètres sont date / heure fournie par le réseau et fuseau horaire fourni par le réseau. J'ai réussi à contourner le pb en me mettant en GMT+0 et en mettant l'heure manuellement. Dans ce cas là tout fonctionne.
Mais je vais quand même revenir en mode automatique pour l'heure et le fuseau et appliquer le décalage horaire depuis Darktable. Je n'avais pas vu cette option.
Merci pour ta réponse
Répondre
#6
Le problème n'est pas ton téléphone qui lui gère bien cela et tout seul c'est ton appareil photo. Tu dois y mettre le paramètre heure été / hiver correctement.
Répondre
#7
Salut , quel gps logger utilisez vous y en a plusieurs ?
Répondre
#8
l’intérêt qu j'ai pour gps4cam est qu'il inscrit les coordonnées gps dans le fichier raw, donc la localisation de la photo est connue quelque soit le logiciel de traitement d'image

bon la manip que j'ai présenté n'est utile qu'à ceux qui travaillent avec gps4cam pour leur permettre de s'affranchir de windows ou mac

cette manip n'est pas vraiment compliquée pour qui utilise Linux, mais effectivement elle demande un petit effort pour qui veut comprendre comment fonctionne le système.
beaucoup de logiciels windows sont en fait des programme java qui peuvent être utilisés sous Linux sans modification.
Répondre
#9
@marc, juste pour être certain que l'on se comprend bien. je pense que le problème ne vient pas de ton téléphone. ton gpx a une heure de décalage car l'heure est UTC. Le problème est donc plus vraisemblablement sur ton boîtier qui même si il est à l'heure n'est peut être pas configuré en heure d'hiver actuellement. Donc tu dois sélectionner l'heure d'hiver, mettre la bonne heure sur ton boîtier ensuite et tout devrait rentrer dans l'ordre.
Répondre
#10
(25-02-17, 18:32)pobry a écrit : @marc, juste pour être certain que l'on se comprend bien. je pense que le problème ne vient pas de ton téléphone. ton gpx a une heure de décalage car l'heure est UTC. Le problème est donc plus vraisemblablement sur ton boîtier qui même si il est à l'heure n'est peut être pas configuré en heure d'hiver actuellement. Donc tu dois sélectionner l'heure d'hiver, mettre la bonne heure sur ton boîtier ensuite et tout devrait rentrer dans l'ordre.
Non malheureusement, je viens de vérifier mon boîtier (Nikon D750). L'heure d'été est OFF et le fuseau horaire sur UTC+1 Paris.
Je viens de refaire un essai à 18h54 et voici mon fichier gpx

<?xml version="1.0" encoding="UTF-8" ?><gpx version="1.0" creator="GPSLogger 86 - http://gpslogger.mendhak.com/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns="http://www.topografix.com/GPX/1/0" xsiConfusedchemaLocation="http://www.topografix.com/GPX/1/0 http://www.topografix.com/GPX/1/0/gpx.xsd"><time>2017-02-25T17:54:04.660Z</time><trk><trkseg><trkpt lat="48.8475321" lon="2.4320966"><time>2017-02-25T17:54:04.660Z</time><src>network</src></trkpt>

</trkseg></trk></gpx>


Mon tel est configuré en fuseau et heure par le réseau, il affiche 18h54.

Je ne comprend pas mais hier j'ai bien tout récupéré en décalant d'une heure sur Darktable
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)