Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Darktable-master
#1
Photo 
Bonjour à tous,


J'ai trouvé à cette adresse  le fichier darktable-master, c'est un module proposé par un développeur pou DT  à cette adresse
https://github.com/rabauke/darktable/

Première question comment font-ils pour installer ces modules ? "Darktable-master"
J'ai cru noter qu'il était possible d'installer des scripts, quels sont ces sripts ? Et comment faire pour les installer ?

Je me suis abonné récemment à la mailing list DT des développeurs juste par curiosité, pouvez-vous m'expliquer.
Est-il possible de temps en temps de faire un sujet sur ce qui se passe sur ce forum, enfin décrypter pour le Béotien que je suis.
Et du coup nous faire partager ce qui se grenouille gentiment....
[Image: view?usp=sharing]

Merci pour vos infos, @plus
Répondre
#2
Ce n'est pas des modules. C'est les sources master qui sont à compiler pour avoir la dernière version en développement. Je l'ai compilée ce matin : 2.3.0+372~gb2b2179.
Répondre
#3
Wink 
(23-02-17, 13:00)jpg54 a écrit : Ce n'est pas des modules. C'est les sources master qui sont à compiler pour avoir la dernière version en développement. Je l'ai compilée ce matin : 2.3.0+372~gb2b2179.

Ok en tout cas merci pour l'info, en gros c'est pour Upgrader sur une pré version...

Bon en ce qui concerne les scripts qui permettent d'automatiser des actions par exemple vers Gimp ou autre Késako ?

Comment ça fonctionne et quels ont ces scripts et pourquoi faire ?
Merci à vous
@plus
Répondre
#4
(23-02-17, 13:40)PSIFWI a écrit : Bon en ce qui concerne les scripts qui permettent d'automatiser des actions par exemple vers Gimp ou autre Késako ?

Comment ça fonctionne et quels ont ces scripts et pourquoi faire ?

Les LUA scripts sont un moyen de coder des extensions à DT, donc sans modifier à proprement parler DT.

Il existe déjà un certain nombre de LUA scripts, certains facilitent la vie par exemple en lançant GIMP et en y chargeant le JPG généré par DT pour le retravailler dans GIMP et retour auto dans DT en quittant GIMP (je n'utilise pas, mais ça doit être à peu près ça).

J'utilise par exemple un LUA script qui ouvre le dossier dans lequel se trouve la photo que je travaille dans DT, avec l'explorateur de fichier de mon ordi (nautilus sur Ubuntu). C'est parfois utile d'accéder directement au contenu ce dossier sans devoir cliquer N fois.

Un LUA script se présente comme un fichier texte avec du code, qu'on stocke généralement sans $CONFIGDIR/lua (à créer éventuellement), par exemple /home/manu/.config/darktable/lua chez moi.
Ce LUA script, mettons fichiers.lua, doit être référencé dans un autre fichier $CONFIGDIR/luarc qui va ressembler par exemple à :
Code :
-- default  lua require can't handle yielding across "require" calls
-- This version is implemented in pure-lua and avoids the problem
-- override the require function for everybody

require = require "darktable/external/pygy_require/require".require

require "fichiers"
require "yield"

-- vim: shiftwidth=2 expandtab tabstop=2 cindent syntax=lua

Après, l'utilisation dans DT est fonction de ce qui a été codé dans le LUA script.
Ça peut être une nouvelle option de "exporter sélection" mais, toujours dans mon exemple, j'ai associé l'activation du LUA script à F9 (une réminiscence d'un raccourci clavier utilisé dans ASP).

En bref, c'est bien pratique et plutôt bien vu, mais pas super accessible : il faut quand même quelques capacités de codage ! Smile
dt stable / Ubuntu 20.04
Répondre
#5
(23-02-17, 16:24)manu a écrit : [...]
J'utilise par exemple un LUA script qui ouvre le dossier dans lequel se trouve la photo que je travaille dans DT, avec l'explorateur de fichier de mon ordi (nautilus sur Ubuntu). C'est parfois utile d'accéder directement au contenu ce dossier sans devoir cliquer N fois.
[...]

Un peu hors sujet : Au passage vers la version 2.2.x j'ai du modifier le script car il y a un changement dans l'API. As-tu fait la modification toi-même ? Ou bien as-tu besoin du fichier ?
Mes photos : jpverrue.fr
Répondre
#6
(28-02-17, 18:52)jpverrue a écrit : Un peu hors sujet : Au passage vers la version 2.2.x j'ai du modifier le script car il y a un changement dans l'API. As-tu fait la modification toi-même ? Ou bien as-tu besoin du fichier ?

Un peu hors sujet toujours Wink , non j'ai rien changé et ça marche toujours (DT 2.2.3)... Mais je prends quand même !
Encore merci JPV !
dt stable / Ubuntu 20.04
Répondre
#7
Je mets la version corrigée dans le fil d'origine : ICI
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)