Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: OrianneTV[BUG]Aberration chromatique [non résolu]
#1
Bonjour,
J'en reviens toujours à ce problème de bug avec le module aberration chromatique.

Le module après activation semble en rajouter en plus d'un rajout de frange violette. Mais ce n'est pas fixe du tout au zoom ou au déplacement dans l'image :/ (soit il y en a plus soit il n'y en a plus) ce qui me fait dire qu'il y a un souci au niveau de l'affichage. Au développement cela ressort et de plus avant dev. je ne peux même pas me faire une idée réelle du travail à effectuer sur mes images

C'est indépendant de la distribution utilisé (Xubuntu 17.10, debian9 ..idem), l'installation est faite sur un Mac Book Pro mi-2013 donc carte graphique intégrée intel.
 

A qui dois-je faire remonter? quelles infos donner en plus?

Merci
Location possible sonde Xrite i1 display Pro proche Bordeaux . Si PC portable calibration offerte en venant à mon domicile
Répondre
#2
Ben, tu peux mettre un Raw en téléchargement et aussi des exports pour que l'on voit s'il faut faire une demande sur Redmine.
Répondre
#3
Ce n'est pas forcément un bug.

L'aberration chromatique, c'est quand les canaux R, G et B sont décalé. Le module aberration chromatique essaie de les realigner. Je ne connais pas les détails du fonctionnement mais vu qu'on ne lui fourni aucun paramètre, le mieux qu'il puisse faire est "deviner". Mais il y a aussi un autre module "correction des objectifs" qui réaligne les canaux, et lui le fait en connaissant les défauts de l'objectif (donc mieux). Vu que le module "aberration chromatique" arrive avant l'autre dans le pipeline, si on active les deux on peut s'attendre à une double correction, donc nettement pire qu'avec un seul module.

Par contre, le module suppression des franges ne fonctionne pas pareil : il repère les franges colorées et les de-sature (i.e.supprime la couleur). Lui, vient après correction des objectifs et permet donc de compléter le fonctionnement de ce module.

En bref, la combo gagnante est "correction des objectifs" + "suppression des franges" si besoin. Le module "aberration chromatique" ne sert à rien si on a un objectif reconnu par lensfun donc par "correction des objectifs".

Autre chose : il y a plusieurs formes d'aberrations chromatique. Celle corrigée par darktable se manifeste plutôt avec des franges rouges et bleues.
Répondre
#4
a vrai dire ça me fait ça sur tous mes raws.

Qu'il y ait une différence avec un agrandissement de l'image (et après actualisation je précise) je pense que c'est un bug. Je peux faire aussi une capture vidéo pour meilleure compréhension. Pour les RAWs, dès que j'ai du temps libre c'est sans souci.
Location possible sonde Xrite i1 display Pro proche Bordeaux . Si PC portable calibration offerte en venant à mon domicile
Répondre
#5
(22-11-17, 15:24)OrianneTV a écrit : a vrai dire ça me fait ça sur tous mes raws.

Qu'il y ait une différence avec un agrandissement de l'image (et après actualisation je précise) je pense que c'est un bug. Je peux faire aussi une capture vidéo pour meilleure compréhension. Pour les RAWs, dès que j'ai du temps libre c'est sans souci.

je voudrais bien un exemple de raw à télécharger pour voir si le problème est que chez toi, si c'est un problème optiques que DT n'arrive pas à corriger voir si ce n'est qu'un problème d'affichage.

J'ai des optiques qui ont peu d'aberration chromatique, mais le peu que j'ai est très bien corrigé et cela automatiquement.
Luc Viatour Photographe 
Website
Répondre
#6
BUG corrigé simplement en enlevant le dossier de configuration de DT....
Location possible sonde Xrite i1 display Pro proche Bordeaux . Si PC portable calibration offerte en venant à mon domicile
Répondre
#7
Je viens de mettre ton fil [résolu].
Répondre
#8
(11-12-17, 00:33)OrianneTV a écrit : BUG corrigé simplement en enlevant le dossier de configuration de DT....

Donc ce n'est pas corrigé. J'ai aussi ce problème parfois, avec un appareil photo sur trois, celui à 36 Mpix, et à certains niveaux de zoom.

Ça ressemble à un souci de mise à l'échelle et d'interpolation dans la chambre noire.
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Répondre
#9
Donc, ce n'est pas résolu ?
Répondre
#10
(11-12-17, 08:53)aurelienpierre a écrit :
(11-12-17, 00:33)OrianneTV a écrit : BUG corrigé simplement en enlevant le dossier de configuration de DT....

Donc ce n'est pas corrigé. J'ai aussi ce problème parfois, avec un appareil photo sur trois, celui à 36 Mpix, et à certains niveaux de zoom.

Ça ressemble à un souci de mise à l'échelle et d'interpolation dans la chambre noire.

Oui c'est tout à fait ça!

J'ai d'autres soucis dès que je touche aux paramètres DT aussi... Il faudrait une capture vidéo pour ben les faire comprendre. Par exemple hier j'ai perdu la section tag avec un paramètre qui n'avait pourtant aucun rapport de près ou de loin avec cette fonction.
Idem des soucis avec les "têtes de mort" malgré que les fichiers soient présent sur le DD... donc obligé de réimporter (ce qui est lourd dans les collections qui se multiplient), nettoyer la bd ce qui en calme le pbm que quelques jours... ==> ré-enlever le fichier conf. de DT a été la seule alternative à ce souci

On en revient toujours aux paramètres donc....

C'est ennuyant car je fais avec les réglages de base même s'ils ne me conviennent pas. J'ose plus y toucher, lol.
Location possible sonde Xrite i1 display Pro proche Bordeaux . Si PC portable calibration offerte en venant à mon domicile
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)