Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: NostronemoTraitement d'images : Extrême lenteur
#1
Bonsoir,

Je suis un nouvel utilisateur de Darktable, que j'ai installé sur mon MacBook Pro 15" de 2016. Celui-ci est équipé de 2 cartes graphiques

Intel HD Graphics 530 intégrée
AMD Radeon Pro 460 en PCi

Bien qu'avec OpenCL activé, Darktable est horriblement lent dans le traitement des images. Certains traitement prennent plusieurs dizaines de secondes pour voir leur résultat affiché.

Sauriez-vous d'où vient ce phénomène, qui rend pour le moment Darktable tout simplement inutilisable.

En vous remerciant pour votre aide.

Meilleures salutations de Suisse

Greg
Répondre
#2
Essaye de lancer darktable avec l'option "-d perf", et regarde les messages qui s'affichent quand tu traites une image.
Répondre
#3
> Bien qu'avec OpenCL activé

Et si tu désactive OpenCL? La carte n'est pas super puissante. En plus j'espère que l'OpenCL pour ton intel n'est pas activé car cela serait une deuxième sources de lenteur.

Ensuite il faudrait savoir combien de RAW as-tu sur ton ordi? Quel processeur? Quelle fréquence?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#4
(06-03-18, 10:20)pascal a écrit : > Bien qu'avec OpenCL activé

Et si tu désactive OpenCL? La carte n'est pas super puissante. En plus j'espère que l'OpenCL pour ton intel n'est pas activé car cela serait une deuxième sources de lenteur.

Ensuite il faudrait savoir combien de RAW as-tu sur ton ordi? Quel processeur? Quelle fréquence?

Je ne vois aucune différence si je désactive l'OpenCL. via DT. Par contre, de ce que je sais, il n'est pas possible de désactiver OpenCL sur OSX.

Concernant ta deuxième question, j'ai 700 RAW gérés par DT. Proc: Core i7 2.6 GHz.

Est-ce que ces quelques précisions te sont utiles?

(05-03-18, 22:56)mmoy a écrit : Essaye de lancer darktable avec l'option "-d perf", et regarde les messages qui s'affichent quand tu traites une image.

Je ne pense pas que perf soit présent sur OS X. Mais c'est peut-être une erreur. J'ai donc tenté de monitorer l'activité via "Top" mais je ne vois rien d'anormal
Répondre
#5
> Par contre, de ce que je sais, il n'est pas possible de désactiver OpenCL sur OSX.

Ben si, depuis dt... tu peux dire à dt de ne PAS utiliser OpenCL.

> Je ne pense pas que perf soit présent sur OS X.

Faut essayer Smile Ce n'est pas du MacOS mais une option de dt qui affiche des données de performance. Donc au minimum tenter les conseils des autres serait bien Smile

> Proc: Core i7 2.6 GHz.

Ça devrait être rapide avec un proc comme celui-ci.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#6
(06-03-18, 19:45)pascal a écrit : > Par contre, de ce que je sais, il n'est pas possible de désactiver OpenCL sur OSX.

Ben si, depuis dt... tu peux dire à dt de ne PAS utiliser OpenCL.

> Je ne pense pas que perf soit présent sur OS X.

Faut essayer Smile Ce n'est pas du MacOS mais une option de dt qui affiche des données de performance. Donc au minimum tenter les conseils des autres serait bien Smile

> Proc: Core i7 2.6 GHz.

Ça devrait être rapide avec un proc comme celui-ci.

Merci pour ta réponse, et surtout détrompes-toi. J'ai essayé ton conseil et même chercher des détails sur OpenCL.  Wink je n'aurais par contre pas dû dire, selon ce que je sais... navré... 

Et j'y retourne donc... et te donne des nouvelles

(06-03-18, 19:45)pascal a écrit : > Par contre, de ce que je sais, il n'est pas possible de désactiver OpenCL sur OSX.

Ben si, depuis dt... tu peux dire à dt de ne PAS utiliser OpenCL.

> Je ne pense pas que perf soit présent sur OS X.

Faut essayer Smile Ce n'est pas du MacOS mais une option de dt qui affiche des données de performance. Donc au minimum tenter les conseils des autres serait bien Smile

> Proc: Core i7 2.6 GHz.

Ça devrait être rapide avec un proc comme celui-ci.

En fait, mes réponse se sont croisées...  Smile je t'avais répondu sur la désactivation de l'OpenCL. Quant à perf... après essai et recherche, je ne trouve pas... navré
Répondre
#7
(06-03-18, 19:48)Nostronemo a écrit :
(06-03-18, 19:45)pascal a écrit : > Par contre, de ce que je sais, il n'est pas possible de désactiver OpenCL sur OSX.

Ben si, depuis dt... tu peux dire à dt de ne PAS utiliser OpenCL.

> Je ne pense pas que perf soit présent sur OS X.

Faut essayer Smile Ce n'est pas du MacOS mais une option de dt qui affiche des données de performance. Donc au minimum tenter les conseils des autres serait bien Smile

> Proc: Core i7 2.6 GHz.

Ça devrait être rapide avec un proc comme celui-ci.

Merci pour ta réponse, et surtout détrompes-toi. J'ai essayé ton conseil et même chercher des détails sur OpenCL.  Wink je n'aurais par contre pas dû dire, selon ce que je sais... navré... 

Et j'y retourne donc... et te donne des nouvelles
Pour préciser : ce que je te conseille, c'est d'ouvrir un terminal, puis de taper la commande suivante dedans :

darktable -d perf

Ensuite, regarder ce qui s'affiche sur le terminal.

Envoyé de mon HUAWEI VNS-L31 en utilisant Tapatalk
Répondre
#8
J'ai eu les mêmes problèmes de lenteur sur mon Imac de 2017 avec un Intel I7 et 256gb de RAM. Je n'ai pas trouvé comment améliorer les performances, la lenteur est insupportable, un simple déplacement de curseur = quelques secondes d'attente.
J'ai donc installé une machine virtuelle Linux Ubuntu sous parallel qui utilise mon arborescence de fichier mac et là c'est hyper performant, plus aucun temps d'attente.
Par exemple l'utilisation du preset denoise d'Aurelien sur Mac plus de 1 minute d'attente sur Linux instantané
Répondre
#9
> 256gb de RAM

Sérieux?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#10
Autant pour moi je viens de vérifier c'est le SSD de 256gb et la RAM de 32gb
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)