Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: valmydarktable, Scripts Lua et Lua5.2
#1
j'ai changé Debian pour Solus 3. J'avais déjà testé.
Juste pour vous dire que j'ai réinstallé les scripts dans .config/darktable/lua et créer mon fichier texte luarc contenant require "include_all" SANS activer lua5.2, pour voir ....
J'ai bien mes scripts, Edit with Gimp fonctionne, mon image fait bien l'aller/retour darktable-gimp.
Donc, il ne serait pas nécessaire d'installer lua5.2 ou lua5.3.
Peut-être que l'installer serait un plus ... A voir.
Lille. Hauts de France
Distribution Linux : https://getsol.us/home/
Site web : http://www.philippedeletree.fr
Youtube : Darktable


Répondre
#2
Je n'arrive pas à faire fonctionner "include_all" sous Linux Mint 18.3 alors que "gimp", enfuse_pro" et "contact_print" fonctionne parfaitement ?
Répondre
#3
Concernant la version de Lua, j'ai creusé un peu la question hier. Voici ce que j'ai constaté :
  • Comme je l'ai déjà relaté dans un autre sujet, sur mon opensuse, j'ai deux versions de Lua installées : la 5.1 et la 5.2.
  • J'ai appliqué la proposition de Jurande pour connaître la version utilisée par DT et j'obtiens 5.3 !!! Comment est-ce possible puisque cette version n'est pas utilisée ?
  • Du coup, j'ai essayé de voir quelle librairie Lua est utilisée par l'exécutable darktable avec la commande ldd. Là c'est encore plus fort, aucune librairie n'est utilisée !
  • Je me suis dit, alors que darktable fait appel à l'exécutable Lua et non à la libraire. J'ai donc lancé darktable avec un terminal, puis j'ai essayé de trouver un exécutable Lua tournant sur mon système avec ps... Je vous le donne en mille, je n'en ai pas trouvé !
  • J'ai aussi regardé avec lsof pour voir si darktable avait ouvert je ne sais quel fichier pourtant un nom apparenté à Lua : rien !
  • Il ne me reste qu'une chose à faire c'est de regarder dans les sources et en particulier dans le fichier make, pour tenter de comprendre comment tout ça est articulé...
Mais pour l'instant, c'est un grand mystère pour moi...
Mes photos : jpverrue.fr
Répondre
#4
(29-03-18, 13:57)jpg54 a écrit : Je n'arrive pas à faire fonctionner "include_all" sous Linux Mint 18.3 alors que "gimp", enfuse_pro" et "contact_print" fonctionne parfaitement ?

Je suppose que tu as bien mis " require " avant include_all.
C'est curieux Mint c'est famille debian, ça devrait fonctionner.

Normalement le fichier luarc contient seulement : require "include_all"
il ne faut pas ajouter autre chose comme : contrib/gimp
Lille. Hauts de France
Distribution Linux : https://getsol.us/home/
Site web : http://www.philippedeletree.fr
Youtube : Darktable


Répondre
#5
Oui, bien sûr, j'ai bien fait une ligne :  require "include_all" dans le fichier luarc et "include_all" est bien dans le répertoire lua
J'arrive à faire fonctionner les autres scripts sans problème et depuis longtemps.
Voilà les copies d'écran :
[Image: Capture_du_2018_03_29_21_22_42.png]

[Image: Capture_du_2018_03_29_21_23_23.png]

[Image: Capture_du_2018_03_29_21_24_26.png]
Alors qu'avec le luarc que j'utilise depuis lontemps :
[Image: Capture_du_2018_03_29_21_30_53.png]

[Image: Capture_du_2018_03_29_21_31_30.png]
Je mets : -- devant certains require pour les mette en commentaires et éviter qu'ils s'exécutent ou si la version ne fonctionnent pas en attendant une mise à jour à tester.
Sur mon second portable sous Antergos, "include_all"  fonctionne parfaitement;
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)