Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: pixtoleroPrise en charge des nouveaux boîtiers
#21
La définition du Nikon Z6 est bien dans rawspeed de la version 2.6.2 :
Code :
    </Camera>
    <Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-compressed">
        <ID make="Nikon" model="Z 6">Nikon Z 6</ID>
        <CFA width="2" height="2">
            <Color x="0" y="0">RED</Color>
            <Color x="1" y="0">GREEN</Color>
            <Color x="0" y="1">GREEN</Color>
            <Color x="1" y="1">BLUE</Color>
        </CFA>
        <Crop x="0" y="0" width="0" height="0"/>
        <Sensor black="1008" white="15520"/>
    </Camera>
    <Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-uncompressed">
        <ID make="Nikon" model="Z 6">Nikon Z 6</ID>
        <CFA width="2" height="2">
            <Color x="0" y="0">RED</Color>
            <Color x="1" y="0">GREEN</Color>
            <Color x="0" y="1">GREEN</Color>
            <Color x="1" y="1">BLUE</Color>
        </CFA>
        <Crop x="0" y="0" width="0" height="0"/>
        <Sensor black="1008" white="15520"/>
        <Hints>
            <Hint name="msb_override" value=""/>
        </Hints>
    </Camera>
    <Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-compressed">
        <ID make="Nikon" model="Z 6">Nikon Z 6</ID>
        <CFA width="2" height="2">
            <Color x="0" y="0">RED</Color>
            <Color x="1" y="0">GREEN</Color>
            <Color x="0" y="1">GREEN</Color>
            <Color x="1" y="1">BLUE</Color>
        </CFA>
        <Crop x="0" y="0" width="0" height="0"/>
        <Sensor black="251" white="3880"/>
    </Camera>
    <Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-uncompressed">
        <ID make="Nikon" model="Z 6">Nikon Z 6</ID>
        <CFA width="2" height="2">
            <Color x="0" y="0">RED</Color>
            <Color x="1" y="0">GREEN</Color>
            <Color x="0" y="1">GREEN</Color>
            <Color x="1" y="1">BLUE</Color>
        </CFA>
        <Crop x="0" y="0" width="0" height="0"/>
        <Sensor black="251" white="3880"/>
        <Hints>
            <Hint name="msb_override" value=""/>
        </Hints>
    </Camera>
Il me semble que notre ami avait signalé que cet APN était reconnu dans les informations d'image.
Répondre
#22
(03-10-19, 20:58)jpg54 a écrit : La définition du Nikon Z6 est bien dans rawspeed de la version 2.6.2 :

Il me semble que notre ami avait signalé que cet APN était reconnu dans les informations d'image.

Alors dans ce cas les release notes ne sont pas bonnes ou le support n'est que partiel (peut-être une piste là sur le problème avec la 2.6.2). Le support complet est annoncé dans la release notes de la 3.0 (comparé par rapport à la 2.6.0) et en regardant les release notes 2.6.1 et 2.6.2 je n'ai vu qu'un support du bruit introduit (bon dans l'absolu un support de bruit sans le support du RAW, c'est bizarre). C'est ma seule source, je n'ai pas de Nikon et mes réponses sont basées sur ces release notes et mes souvenirs de PR sur Github cette année pour apporter le support des Nikon (et de mémoire fléchées 2.8 ; donc future 3.0). Après si le support est déjà dans la 2.6.2, là ça change un peu la donne (mais pas le fond du lien Lensfun/rawspeed, etc.) sur ce qui est à faire, donc agir sur Lensfun.

En tout cas, les Z6 et Z7 s'affichent bien avec une mise à jour Lensfun du printemps dernier et la version master de darktable. Ca reste une piste pour résoudre son problème.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#23
Bonjour,

J'ai progressé avec la remarque de jpg54, en corrigeant le 2 par un 1 dans l'entête de mil-nikon.xml.
Pour répondre à nicoauffray, j'avais trouvé dans la liste des boitiers (camera.xml) que le Z6 et le Z7 étaient bien présents, mais pour autant, ils n'apparaissaient pas dans la liste déroulante avant cette correction. J'ai la version "standard" de DT en 2.6.2

Sur le mac, les fichiers se trouvent dans l'application, et pour y accéder il faut faire un clic droit et faire "Afficher le contenu du paquet". On obtient le fichier camera.xml:
Dans Ressources/Share/Darktable/rawspeed où il y a bien le fichier cameras.xml:
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-compressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="1008" white="15520"/>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-uncompressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="1008" white="15520"/>
<Hints>
<Hint name="msb_override" value=""/>
</Hints>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-compressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="251" white="3880"/>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-uncompressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="251" white="3880"/>
<Hints>
<Hint name="msb_override" value=""/>
</Hints>
</Camera>

Mais le boitier Nikon Z6 (et Z7) n’apparaît dans la liste que depuis que le 2 est transformé en 1 dans la ligne <lensdatabase version="2">

Maintenant, lorsque j’ouvre DT, il me reconnait la plupart du temps un D750 avec le bon objectif, ou un Z6 sans objectif.
Est-ce parce que j'utilise un adaptateur Nikon FTZ (adapte les objectifs à monture F sur les boitiers à monture Z) ?
Merci pour toutes vos infos, ça avance petit à petit.
Avez-vous une idée de la date de sortie des prochaines versions de DT ?

Bonne journée
[Image: liste-d-roulante.jpg]
Répondre
#24
La prochaine version - version 3.0 -, devrait sortir en décembre, en principe, à noël.
Mes photos : jpverrue.fr
Répondre
#25
OK, merci
Répondre
#26
Je crois que l'on a fait le tour que ce que l'on pouvait faire sur la 2.6.2.
Répondre
#27
(04-10-19, 14:37)Aquecoucou31 a écrit : Bonjour,

J'ai progressé avec la remarque de jpg54, en corrigeant le 2 par un 1 dans l'entête de mil-nikon.xml.
Pour répondre à nicoauffray, j'avais trouvé dans la liste des boitiers (camera.xml) que le Z6 et le Z7 étaient bien présents, mais pour autant, ils n'apparaissaient pas dans la liste déroulante avant cette correction. J'ai la version "standard" de DT en 2.6.2

Sur le mac, les fichiers se trouvent dans l'application, et pour y accéder il faut faire un clic droit et faire "Afficher le contenu du paquet". On obtient le fichier camera.xml:
Dans Ressources/Share/Darktable/rawspeed où il y a bien le fichier cameras.xml:
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-compressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="1008" white="15520"/>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="14bit-uncompressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="1008" white="15520"/>
<Hints>
<Hint name="msb_override" value=""/>
</Hints>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-compressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="251" white="3880"/>
</Camera>
<Camera make="NIKON CORPORATION" model="NIKON Z 6" mode="12bit-uncompressed">
<ID make="Nikon" model="Z 6">Nikon Z 6</ID>
<CFA width="2" height="2">
<Color x="0" y="0">RED</Color>
<Color x="1" y="0">GREEN</Color>
<Color x="0" y="1">GREEN</Color>
<Color x="1" y="1">BLUE</Color>
</CFA>
<Crop x="0" y="0" width="0" height="0"/>
<Sensor black="251" white="3880"/>
<Hints>
<Hint name="msb_override" value=""/>
</Hints>
</Camera>

Mais le boitier Nikon Z6 (et Z7) n’apparaît dans la liste que depuis que le 2 est transformé en 1 dans la ligne <lensdatabase version="2">

Maintenant, lorsque j’ouvre DT, il me reconnait la plupart du temps un D750 avec le bon objectif, ou un Z6 sans objectif.
Est-ce parce que j'utilise un adaptateur Nikon FTZ (adapte les objectifs à monture F sur les boitiers à monture Z) ?
Merci pour toutes vos infos, ça avance petit à petit.
Avez-vous une idée de la date de sortie des prochaines versions de DT ?

Bonne journée
[Image: liste-d-roulante.jpg]

Je suis en version 2.7 de DT. Le Z7 et Z6 sont bien reconnus, idem pour le 24-70mm F4 en monture Z. Par contre aucun lien entre le Z7 et les optiques avec la monture FTZ.....

C'est con car les corrections pour les optiques montée sur la bagues FTZ sont dans la DB avec les bonne correction. 
Je choisi manuellement un D850 et l'optique et les corrections sont bonnes.
Luc Viatour Photographe 
Website
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)