Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: patapix[résolu] OpenCL + Carte NVidia.
#1
A priori, ça a tout pour fonctionner, mais lorsque je souhaite "activer le support d'openCL", je peux lire "non disponible".
J'ai tenté de lancer
Code :
darktable -d opencl

et j'obtiens la sortie suivante :


Code :
0.046456 [opencl_init] opencl related configuration options:
0.046466 [opencl_init]
0.046467 [opencl_init] opencl: 1
0.046469 [opencl_init] opencl_library: ''
0.046471 [opencl_init] opencl_memory_requirement: 768
0.046472 [opencl_init] opencl_memory_headroom: 300
0.046474 [opencl_init] opencl_device_priority: '*/!0,*/*/*'
0.046475 [opencl_init] opencl_mandatory_timeout: 200
0.046477 [opencl_init] opencl_size_roundup: 16
0.046478 [opencl_init] opencl_async_pixelpipe: 0
0.046480 [opencl_init] opencl_synch_cache: 0
0.046481 [opencl_init] opencl_number_event_handles: 25
0.046483 [opencl_init] opencl_micro_nap: 1000
0.046484 [opencl_init] opencl_use_pinned_memory: 0
0.046485 [opencl_init] opencl_use_cpu_devices: 0
0.046487 [opencl_init] opencl_avoid_atomics: 0
0.046488 [opencl_init]
0.046594 [opencl_init] found opencl runtime library 'libOpenCL'
0.046610 [opencl_init] opencl library 'libOpenCL' found on your system and loaded
0.207253 [opencl_init] could not get platforms: -1001
0.207264 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
0.207265 [opencl_init] initial status of opencl enabled flag is OFF.


Je suis sous Antergos (un dérivé de Arch).
Le driver proprio est installé, le paquet "opencl-nvidia" également.

En fait si on s'en réfère à la sortie citée ci-dessus, il a l'air de trouver et il y a un truc qui déconne à la fin.

Je soumets ce problème à votre sagacité. En attendant, c'est mon CPU qui va bosser Smile
Répondre
#2
Il semble qu'il ne détecte pas ta carte : 'could not get platforms: -1001'.

Voici ce que j'ai sur ma machine pour la même partie du log :

Code :
0.476068 [opencl_init] found opencl runtime library 'libOpenCL'
0.476099 [opencl_init] opencl library 'libOpenCL' found on your system and loaded
0.507346 [opencl_init] found 1 platform
0.507385 [opencl_init] found 1 device
0.507628 [opencl_init] device 0 `GeForce GTX 1060 3GB' has sm_20 support.
0.507770 [opencl_init] device 0 `GeForce GTX 1060 3GB' supports image sizes of 16384 x 32768
0.507778 [opencl_init] device 0 `GeForce GTX 1060 3GB' allows GPU memory allocations of up to 751MB
[opencl_init] device 0: GeForce GTX 1060 3GB
    GLOBAL_MEM_SIZE:          3005MB
    MAX_WORK_GROUP_SIZE:      1024
    MAX_WORK_ITEM_DIMENSIONS: 3
    MAX_WORK_ITEM_SIZES:      [ 1024 1024 64 ]
    DRIVER_VERSION:           390.59
    DEVICE_VERSION:           OpenCL 1.2 CUDA
Mes photos : jpverrue.fr
Répondre
#3
Une question de nvidia-modprobe ? Installé ?
Ubuntu 18.04 + dt 2.6 & Pentax K5 & K3-II + cailloux Pentax et Sigma

Répondre
#4
Effectivement ça devait être un problème d'installation des drivers, alors voici la solution pour les utilisateurs d'Antergos :

Cette distribution propose dans ses dépôts un paquet nommé 'nvidia-installer' qui fait tout le travail pour vous, ainsi que les modprobes qui vont bien je présume. Depuis que je l'ai installé, tout roule du tonnerre.

Marche à suivre :


Code :
sudo pacman -Sy nvidia-installer

puis :

Code :
sudo nvidia-installer
Suivi d'un petit redémarrage de la machine.

Enjoy.
Répondre
#5
(05-06-18, 18:13)manu a écrit : Une question de nvidia-modprobe ? Installé ?

nvidia-modprobe n'est plus nécessaire depuis un bout de temps, nvidia-365 au moins. Ou alors c'est juste sous Ubuntu ?
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Spécialiste calcul et traitement de signal pour la photographie.
Répondre
#6
Bonjour.  Nvidia vient de faire le ménage dans ses cartes et ses drivers : certaines cartes doivent revenir à un driver plus ancien. Je suppose que Antergos est comme Arch une rolling release et donc il faut revenir à la main sur l'ancien driver (340 ?).
A priori tu as trouvé une solution en utilisant un programme Nvidia qui a du sélectionner automatiquement le driver adapté.
Est ce la raison pour laquelle Apple ne supporte plus opencl ???
Il doit y avoir plus d'infos sur les sites de Nvidia et de Arch.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)