Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: LucasConfiguration d'OpenCl
#1
Bonjour à tous,

J'essaie de configurer manuellement OpenCl sans pour autant réussir à voir des changements...

Je suis sur Windows 10 1803 64 bits avec Darktable 2.4.4. Et pour la partie matériel j'ai un Intel i5 6300-HQ et un GPU Nvidia 950M.

Malgré la documentation pour définir les paramètres d'OpenCl en manuel mon PC continue toujours d'utiliser presque uniquement le CPU. Pourtant lorsque je démarre Darktable j'ai bien mon GPU Nvidia qui se met en marche sans être utilisé !

Je me demande donc si je fais des erreurs lors de la configuration ou bien que Darktable juge mon CPU plus rapide que le GPU.

Merci d'avance à tous ceux qui essayeront de m'aider Big Grin
Répondre
#2
Je n'utilise pas Windows, mais je sais que tous les modules n'utilisent pas OpenCL.

Lorsque tu lances darktable depuis une ligne de commande avec l'option "-d opencl" as tu bien des kernels OpenCL compilés et chargés?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#3
L'option est indisponible sur Windows.

Une autre commande possible est "darktable-cltest". Elle me ressort aucune erreur, tous les modules se chargent correctement et ma configuration de priorité des cartes est elle aussi reconnu.
Répondre
#4
Et bien tout va bien alors! Qu'est-ce qui te fait dire qu'OpenCL n'est pas utilisé?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#5
Eh bien soit il n'est pas utilisé ou soit pas très bien utilisé : en chargeant pleins de modules demandant des ressources pour faire des tests, je m'aperçois que c'est presque toujours le processeur qui est utilisé, le GPU intégré est un peu demandé et le GPU Nvidia n'est pratiquement pas utilisé. De plus, activer ou désactiver OpenCl dans les réglages ne change pas la durée des temps de traitement.

Après, est-ce qu'en activant OpenCl on remarque un réel gain sur les temps de calculs ou bien cela reste assez négligeable ?
Répondre
#6
(07-06-18, 16:10)Lucas a écrit : Eh bien soit il n'est pas utilisé ou soit pas très bien utilisé : en chargeant pleins de modules demandant des ressources pour faire des tests, je m'aperçois que c'est presque toujours le processeur qui est utilisé, le GPU intégré est un peu demandé et le GPU Nvidia n'est pratiquement pas utilisé. De plus, activer ou désactiver OpenCl dans les réglages ne change pas la durée des temps de traitement.

Après, est-ce qu'en activant OpenCl on remarque un réel gain sur les temps de calculs ou bien cela reste assez négligeable ?

ton processeur a 4 cœurs. Ta carte graphique en a 640. Techniquement ça devrait diviser le temps de traitement par au moins 2.

Il se peut qu'une mauvaise config de l'OpenCL (notamment l'utilisation de la mémoire) entraîne une exécution par défaut sur le CPU (quelque chose du genre "fallback on CPU" dans la sortie de debug).
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Spécialiste calcul et traitement de signal pour la photographie.
Répondre
#7
J'ai pourtant essayé de faire attention à toutes les options de configuration et il ne devrait pas y avoir de problème.

Pour faire un essai j'ai installé Ubuntu 18.04 sur mon PC, configurer tout ce qu'il fallait pour OpenCl et encore une fois pas de gain de temps entre OpenCl activé ou non. J'avais lancé darktable avec l'option -d opencl et aucun problème n'était à constater, la carte graphique était bien choisie par darktable.

Je commence à me demander si le fait d'avoir une carte graphique pour PC portable (donc moins puissante) fait qu'il n'y a pas de différence entre utiliser OpenCl ou seulement utiliser le CPU.
Répondre
#8
Peux-tu poster ton fichier darktable.rc ? Et la sortie de darktable -d opencl ? Parce que typiquement, on attend une amélioration de 2 à 5 fois suivant les config. J'ai déjà eu ce type de problème, et j'y ai passé un temps infini, mais c'était les réglages qui posaient problème. Ce qui est long, c'est de tester chaque changement pour comprendre ce qui se passe.

En gros, ce que je soupçonne, c'est que dt demande plus de mémoire que ton GPU n'en dispose, et que du coup la charge de calcul passe sur le CPU. Mais c'est juste une intuition.
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Spécialiste calcul et traitement de signal pour la photographie.
Répondre
#9
> Après, est-ce qu'en activant OpenCl on remarque un réel gain sur les temps de calculs ou bien cela reste assez négligeable ?

C'est le jour et la nuit pour moi avec mes RAW de 36Mpix.

Une possibilité, as-tu installé Beignet? Si oui, supprime pour n'utiliser que OpenCL sur Nvidia.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#10
Peut-être des informations sur : https://www.phoronix.com/scan.php?page=home ou https://discuss.pixls.us/t/darktable-and...dated/6117
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)