Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: valmyopencl et nvidia sur Manjaro
#1
Comment activer l'opencl sur manjaro 17
J'ai installé manjaro avec l'option "non-free" et le driver Nvidia est bien installé sur mon portable.
Je n'ai pas l'opencl.
J'ai donc chargé les fichiers opencl-headers et opencl-nvidia.
J'ai rebooté, Pas d'erreurs, au démarrage de darktable, l'opencl n'est pas actif.
J'ai alors voulu chargé opencl-nvidia-340 qui est ce qu'il faut pour ma carte geforce 740M et l'installateur me dit que c'est déjà configuré alors que la case à cocher d'installation n'est pas "verte".
(voir : https://www.dropbox.com/s/hr8umvkjqy1qm ... .png?dl=0 )
Si vous avez une idée pour activer l'opencl sur manjaro j'en serais heureux.

A tout hasard. J'ai aussi posté sur le forum manjaro.
Si quelqu'un utilise manjaro et a l'opencl d'activé ...
Une aide ne serait pas de refus ...
Lille. Hauts de France
Linux : Distribution Solus
http://www.philippedeletree.fr
Répondre
#2
Désolé, je ne peux pas t'aider, Manjaro m'a lâchement lâché. Sad Wink
Répondre
#3
Que donne la commande darktable-cltest ?
Répondre
#4
Bonjour mmoy. Le résultat de la commande darktable-cltest:
Code :
[philippe@philippe-pc ~]$ darktable-cltest
0.209928 [opencl_init] opencl related configuration options:
0.209949 [opencl_init]
0.209952 [opencl_init] opencl: 1
0.209956 [opencl_init] opencl_library: ''
0.209967 [opencl_init] opencl_memory_requirement: 768
0.209972 [opencl_init] opencl_memory_headroom: 300
0.209974 [opencl_init] opencl_device_priority: '*/!0,*/*/*'
0.209977 [opencl_init] opencl_mandatory_timeout: 200
0.209980 [opencl_init] opencl_size_roundup: 16
0.209986 [opencl_init] opencl_async_pixelpipe: 0
0.209998 [opencl_init] opencl_synch_cache: 0
0.210005 [opencl_init] opencl_number_event_handles: 25
0.210010 [opencl_init] opencl_micro_nap: 1000
0.210016 [opencl_init] opencl_use_pinned_memory: 0
0.210020 [opencl_init] opencl_use_cpu_devices: 0
0.210024 [opencl_init] opencl_avoid_atomics: 0
0.210027 [opencl_init]
0.210209 [opencl_init] could not find opencl runtime library 'libOpenCL'
0.210322 [opencl_init] could not find opencl runtime library 'libOpenCL.so'
0.210419 [opencl_init] could not find opencl runtime library 'libOpenCL.so.1'
0.210429 [opencl_init] no working opencl library found. Continue with opencl disabled
0.210432 [opencl_init] FINALLY: opencl is NOT AVAILABLE on this system.
0.210434 [opencl_init] initial status of opencl enabled flag is OFF.
[philippe@philippe-pc ~]$

le fil de discussion sur manjaro.fr : https://www.manjaro.fr/forum/viewtopic.php?f=17&t=10285
Lille. Hauts de France
Linux : Distribution Solus
http://www.philippedeletree.fr
Répondre
#5
Je viens de regarder le résultat de la commande que tu as mise sur manjaro.fr :

Code :
Graphics:  Card-1: Intel 3rd Gen Core processor Graphics driver: i915 v: kernel bus ID: 00:02.0
         chip ID: 8086:0166
         Card-2: NVIDIA GK107M [GeForce GT 740M] driver: N/A bus ID: 01:00.0 chip ID: 10de:0fdf
         Display: x11 server: N/A driver: intel resolution: <xdpyinfo missing>
         OpenGL: renderer: Mesa DRI Intel Ivybridge Mobile v: 4.2 Mesa 18.1.1 compat-v: 3.0
         direct render: Yes


Je crois que le problème est avec cette carte mixte. Il y a une méthode pour activer la seconde carte. CaraFife m'a expliqué comment faire mais j'ai oublié car je n'en ai pas eu l'utilité.
Répondre
#6
Je ne connais pas ta distrib, mais tu dois installer un paquet nommé nvidia-opencl-icd sous Debian. As-tu cela d'installé de ton coté?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#7
Je n'ai pas la même carte que toi, mais j'ai ça d'installé : (sauf que moi c'est pas 340)
mhwd-nvidia-340xx
opencl-nvidia-340
libvdpau
nvidia-340-utils
Dans le menu config tu devrais trouver un programme "nvidia x-server settings" dans lequel tu actives opengl.
Répondre
#8
Claudius84 : j'ai installé libvdpau. le reste il ne le veut pas, les paquets sont en conflit.

Pascal : quand je recherche sur manjaro: nvidia-opencl-icd  la réponse est claire : aucun paquet trouvé.

Merci à vous tous pour votre aide.

Je vais attendre la version 18 de manjaro qui devrait arriver à l'automne

https://www.youtube.com/watch?v=GlopRXI2-I8
Lille. Hauts de France
Linux : Distribution Solus
http://www.philippedeletree.fr
Répondre
#9
Salut Valmy,

Comme Pascal je suis sur Debian Sid. Mais en jetant un oeil sur les paquets manjaro, il me semble qu'il faut installer le paquet ocl-icd (c'est lui qui contient libOpenCL.so). En espérant que ce soit compatible avec les pilotes Nvidia.
Répondre
#10
as-tu regardé dans AUR?
"Donne un poisson à un homme, tu le nourris pour un jour. Apprends-lui à pêcher, tu le nourris pour toujours."
Pop Os! 64 Bits Gnome 3.32 Sony A7 et quelques vieux cailloux...
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)