Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: manutrouver la localisation ?
#1
Bonjour,

En lisant le précédent sujet de @LyllyMo, je me suis un peu intéressé à la question de la géolocalisation des photos qui ne le sont pas par mon boîtier, et la fonction "trouver la localisation" semble servir à ça, la doc en dit :

Citation :Pour l’utiliser, entrez un emplacement ou une adresse, pressez Entrée et une liste de résultats sera affichée. Cliquez sur l’un d’entre-eux et un zoom sera effectué sur la carte vers cet endroit. De plus, un contour couvrant cet emplacement ou une épingle indiquant l'emplacement sera affiché. Glissez maintenant des images depuis le bandeau en bas de l’écran vers leur emplacement sur la carte. La localisation GPS sera incorporée à l’image.

Sauf qu'avec ma 2.4.4 / Ubuntu, il ne se passe rien quand j'essaie de localiser un lieu.

Et le debug dans un terminal affiche juste :


Citation :location search: Erreur à la ligne 9, caractère 8 : L’élément « body » a été fermé, mais l’élément actuellement ouvert est « hr »
Ubuntu 18.04 + dt "master"
Pentax K3-II + cailloux Pentax et Sigma

Répondre
#2
Oui Manu dans le module dédié de l'onglet "carte" hors Lilly est sous w$ et cet onglet n'est pas dispo sur ce système je crois ;-)

Je reproduis d'ailleurs la même chose chez moi
"Donne un poisson à un homme, tu le nourris pour un jour. Apprends-lui à pêcher, tu le nourris pour toujours."
Pop Os! 64 Bits Gnome 3.32 Sony A7 et quelques vieux cailloux...
Répondre
#3
Si l'onglet carte est disponible sous Windows ... mais j'ai le même comportement que vous : le module "trouver la localisation" ne rend aucun résultat. Cela dit le système que j'ai décrit au post précédent ne fonctionne pas mal. Avec les boitiers Panasonic, le système est aussi disponible sur l'appli qu'ils proposent en complément de leurs boitiers.
Répondre
#4
Merci pour vos réponses. Smile

Le propos n'est pas trop dt/windows vs dt/linux, mais "trouver la localisation" ne donne rien.

Ce qui m'intrigue d'autant plus c'est l'erreur "L’élément « body » a été fermé, mais l’élément actuellement ouvert est « hr »".

Parce qu'une balise hr est toujours ouvrante et il n'y a pas de balise hr fermante...
Ubuntu 18.04 + dt "master"
Pentax K3-II + cailloux Pentax et Sigma

Répondre
#5
J'ai du confondre avec un autre onglet.

Du coup , pourquoi Lilly ne taggue pas pas glisser déposer!? Je vais lui en glisser un mot.
"Donne un poisson à un homme, tu le nourris pour un jour. Apprends-lui à pêcher, tu le nourris pour toujours."
Pop Os! 64 Bits Gnome 3.32 Sony A7 et quelques vieux cailloux...
Répondre
#6
(29-08-18, 17:08)Carafife a écrit : J'ai du confondre avec un autre onglet.

Du coup , pourquoi Lilly ne taggue pas pas glisser déposer!? Je vais lui en glisser un mot.

Bonjour,

J'ai eu le même problème : le site openstreetmap exige maintenant une connexion en https  (DT utilise http) :

curl http://nominatim.openstreetmap.org/searc...gon_text=1
$ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://nominatim.openstreetmap.org/search/paris?format=xml">here</a>.</p>;;
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at nominatim.openstreetmap.org Port 80</address>
</body></html>


Si je patch src/libs/location.c pour utiliser https au lieu de http, cela fonctionne à nouveau. (Je pense qu'il devrait également être possible d'avoir une redirection prise en compte par curl)

Note : j'ai essayé d'envoyer un message sur la liste de dev DT mais refusé ...


Cordialement,

Jean-Luc
Répondre
#7
@jluc ton message sur la liste de dev a bien été transmis, je suis sur la liste et je l'ai reçu Wink
Répondre
#8
(31-08-18, 13:25)jluc a écrit :
(29-08-18, 17:08)Carafife a écrit : J'ai du confondre avec un autre onglet.

Du coup , pourquoi Lilly ne taggue pas pas glisser déposer!? Je vais lui en glisser un mot.

Bonjour,

J'ai eu le même problème : le site openstreetmap exige maintenant une connexion en https  (DT utilise http) :

curl http://nominatim.openstreetmap.org/searc...gon_text=1
$ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://nominatim.openstreetmap.org/search/paris?format=xml">here</a>.</p>;;
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at nominatim.openstreetmap.org Port 80</address>
</body></html>


Si je patch src/libs/location.c pour utiliser https au lieu de http, cela fonctionne à nouveau. (Je pense qu'il devrait également être possible d'avoir une redirection prise en compte par curl)

Note : j'ai essayé d'envoyer un message sur la liste de dev DT mais refusé ...


Cordialement,

Jean-Luc


Message envoyé sur la liste DT dev  : je n'utilisai pas ma bonne @ mail (j'en ai plusieurs)
Répondre
#9
(31-08-18, 13:50)jluc a écrit :
(31-08-18, 13:25)jluc a écrit :
(29-08-18, 17:08)Carafife a écrit : J'ai du confondre avec un autre onglet.

Du coup , pourquoi Lilly ne taggue pas pas glisser déposer!? Je vais lui en glisser un mot.

Bonjour,

J'ai eu le même problème : le site openstreetmap exige maintenant une connexion en https  (DT utilise http) :

curl http://nominatim.openstreetmap.org/searc...gon_text=1
$ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://nominatim.openstreetmap.org/search/paris?format=xml">here</a>.</p>;;
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at nominatim.openstreetmap.org Port 80</address>
</body></html>


Si je patch src/libs/location.c pour utiliser https au lieu de http, cela fonctionne à nouveau. (Je pense qu'il devrait également être possible d'avoir une redirection prise en compte par curl)

Note : j'ai essayé d'envoyer un message sur la liste de dev DT mais refusé ...


Cordialement,

Jean-Luc


Message envoyé sur la liste DT dev  : je n'utilisai pas ma bonne @ mail (j'en ai plusieurs)
Pas certain de comprendre...

Le dysfonctionnement que j'évoquais au début de ce sujet et l'erreur affichée au terminal seraient dus à http plutôt que https ?
Ubuntu 18.04 + dt "master"
Pentax K3-II + cailloux Pentax et Sigma

Répondre
#10
(31-08-18, 16:03)manu a écrit :
(31-08-18, 13:50)jluc a écrit :
(31-08-18, 13:25)jluc a écrit :
(29-08-18, 17:08)Carafife a écrit : J'ai du confondre avec un autre onglet.

Du coup , pourquoi Lilly ne taggue pas pas glisser déposer!? Je vais lui en glisser un mot.

Bonjour,

J'ai eu le même problème : le site openstreetmap exige maintenant une connexion en https  (DT utilise http) :

curl http://nominatim.openstreetmap.org/searc...gon_text=1
$ <!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved <a href="https://nominatim.openstreetmap.org/search/paris?format=xml">here</a>.</p>;;
<hr>
<address>Apache/2.4.18 (Ubuntu) Server at nominatim.openstreetmap.org Port 80</address>
</body></html>


Si je patch src/libs/location.c pour utiliser https au lieu de http, cela fonctionne à nouveau. (Je pense qu'il devrait également être possible d'avoir une redirection prise en compte par curl)

Note : j'ai essayé d'envoyer un message sur la liste de dev DT mais refusé ...


Cordialement,

Jean-Luc


Message envoyé sur la liste DT dev  : je n'utilisai pas ma bonne @ mail (j'en ai plusieurs)
Pas certain de comprendre...

Le dysfonctionnement que j'évoquais au début de ce sujet et l'erreur affichée au terminal seraient dus à http plutôt que https ?
Oui, DT accède à l'URL en http, openstreetmap refuse http et fait une redirection vers https qui n'est pas traitée par DT
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)