Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: jean-thevenetheure d'été heure / d'hiver fuseau horaire dans un pays GMT+4 sans été/hiver
#1
Bonjour à vous.

Je n'ai trouvé aucun moyen de dire à Darktable de ne pas se croire en métropole... alors que je suis sur l'île de la Réunion.


je suis obligé pour utiliser un fichier gpx de mettre mes photos à l'heure de la métropole, et d'appliquer -2h en "été" ou -3h en hiver pour charger le fichier gpx et géocoder mes photos avant de refaire dans l'autre sens le décalage: cela est source de manipulation et d'erreurs alors que tout était prévu justement pour éviter ces tracas (les métadonnées, les réglages de fuseau horaire... etc).

- Les appareils photos sont bien en heure GMT avec le réglage du fuseau horaire +4, décalage horaire de mon pays qui ne change pas d'heure été/hiver
- L'heure indiquée dans les métadonnées des jpg produits par les appareils photos ou le smartphone (les raw) est bien l'heure locale.
- L'heure indiquée dans le fichier jpg issue de développement est bien l'heure locale si je n'applique pas un décalage au développement
- L'heure dans les fichiers gpx (obtenu par oruxmap et le smartphone ou bien un compteur de vélo équipé de GPS et le site garmin), est bien l'heure GMT avec la lettre "Z" pour le préciser.
si on pouvait simplement avoir une fenêtre de dialogue avec heure d'été on/off, le décalage horaire GMT + 4 ou autre au choix, mais je ne comprend pas comment darktable considère que les métadonnées des photos sont en heure locale française quelque soit le décalage horaire réglé à l'appareil photo. 

Mon ordinateur est réglé à l'heure GMT et le système est réglé à port-louis île Maurice ce qui donne GMT+4 et affiche correctement la ligne jour/nuit de la carte du monde (en passant interface de linux debian est horriblement compliquée pour aboutir à ce réglage: on ne peut pas régler le fuseau horaire que par choix de ville classées par ordre alphanétique (ce qui gêne considérablement à trouver le bon fuseau horaire) et bien entendue, Cilaos la Réunion n'existe pas dans la liste (heureusement l'ile-maurice est connue. C'est aberrant qu'il manque le choix par fuseau horaire!!!
vraiment on se fait chyer pour des trukalacon

pour le reste, darktable est quasi parfait et je m'en sers systématiquement pour sortir mes photos, malheureusement panoramio est mort, je les envoie sur

https://goo.gl/photos/BczFqb7xfvpvEeKN9
https://photos.app.goo.gl/VHM51NBAaqXI2tzD2
ou ces métadonnées servent à "montrer où c'est"

j'aimerais aussi savoir comment supprimer les vignettes de la carte pour les photos que j'ai géolocalisé manuellement qui s'accumulent (faut t-il le faire en vidant le cache manuellement avec l'explorateur de fichier?), les "timbres" ont envahi la carte alors que le travail est fait, et je ne parviens pas à les effacer après chaque session ils se sont cumulé depuis le début et masquent la carte, mais dans le cache je trouve pas des miniatures qui correspondent aux photos que j'ai géolocalisée, et bien plus nombreuses restées sur la carte.
Répondre
#2
> Je n'ai trouvé aucun moyen de dire à Darktable de ne pas se croire en métropole... alors que je suis sur l'île de la Réunion.

Et comment font les Anglais, Américains, Canadiens, Australiens ????

> Mon ordinateur est réglé à l'heure GMT et le système est réglé à port-louis île Maurice ce qui donne GMT+4 et affiche correctement la ligne jour/nuit de la carte du monde (en passant
> interface de linux debian est horriblement compliquée pour aboutir à ce réglage: on ne peut pas régler le fuseau horaire que par choix de ville classées par ordre alphanétique
> (ce qui gêne considérablement à trouver le bon fuseau horaire) et bien entendue,

Hum, quelle version de Debian? Chez moi j'ai une option "Fuseau horaire automatique" que j'utilise et qui fonctionne bien. Sinon, si je fais manuellement j'ai une carte et je peux cliquer dessus pour désigner mon fuseau. Je viens de tester et je peux sans problème cliquer sur l'ile de la réunion qui est reconnue en GMT+4.

Pas certain que cela te donne une solution, mais clairement ton message est assez étrange et il y a peut-être une incompréhension quelque part.

> j'aimerais aussi savoir comment supprimer les vignettes de la carte pour les photos que j'ai géolocalisé manuellement qui s'accumulent

Oui, le but c'est bien que les images s'accumulent Smile Les images géolocalisées se retrouvent sur la carte et plus on géolocalise plus on a d'image sur la carte. Tu peux zoomer sur une zome pour ne voir que certaines images.

Sinon pour supprimer un image de la carte tu peux la prendre et la déposer dans le film en dessous. MAIS ce va supprimer les informations de gélocalisation de li'mage.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#3
DT->préférences->options d'interface->nombre maximum d’images affichées sur la carte.
Par défaut c'est 100, mais tu peux réduire si tu veux limiter le nombre d'images.
Mes photos : jpverrue.fr
Répondre
#4
Un petit tour dans le salon "Présentation" serait apprécié. Et darktable s'écrit avec un d minuscule même en début de phrase selon le désir du créateur.
Répondre
#5
pour linux c'est débian 9 installée en juillet. On ne peut plus en effet comme avant cliquer sur le fuseau, il faut choisir une ville dans une liste, c'est incompréhensible et anti-ergonomique. Pleins de petits détails sont anti-ergonomiques, je ne suis pas content de cette mise à jour, mais c'était nécessaire pour l'ordinateur moderne de cette année.
Anglais, Américains, Canadiens,  sont dans l'hémisphère nord avec passage heure d'été heure d'hiver. Australiens? oui, comment ils font?!

POUR LES VIGNETTES.
DT->préférences->options d'interface->nombre maximum d’images affichées sur la carte.
je ne parvient pas à trouver le moindre accès à ce menu.

Merci  jpverrue pour les vignettes de la carte, mais c'est l'échec
https://www.darktable.org/usermanual/fr/...ences.html
A button [Image: darkroom_preferences.jpg]located in the upper panel allows you to define various parameters which control darktable's behavior.

Je ne vois pas de trace de ce bouton...
Répondre
#6
pour le nombre d'image sur la carte
problème réglé par l'édition directe du fichier de configuration. darktablerc

plugins/map/max_images_drawn=5
au lieu de
plugins/map/max_images_drawn=100
même 5 c'est chiant, il faut mettre 1 comme ça ça n'affiche que la dernière traitée manuellement.

Dans ce fichier il y a
plugins/lighttable/geotagging/expanded=TRUE
plugins/lighttable/geotagging/offset=+03:00:00
plugins/lighttable/geotagging/tz=Europe/Paris


plugins/lighttable/geotagging/tz=Europe/Paris
voilà peut être la source du problème, si c'est décidé à l'installation, on met quoi pour Cilaos la Réunion? quelle syntaxe pour que le programme comprenne "tz = GMT+4"?
avec tz=Europe/Paris  il faut que je fasse offset=-03:00:00 avant d'appliquer le gpx et  offset=+03:00:00 pour remettre mes photos à l'heure!!!

en cherchant j'ai trouvé une info de syntaxe
http://www.timezoneconverter.com/cgi-bin/zoneinfo

plugins/lighttable/geotagging/tz=Indian/Reunion

problème réglé...

le plus dur c'est de savoir où on habite! je ne me voyais pas trop en inde...
Répondre
#7
Tu accèdes aux préférences avec l'icône en forme de roue dentée en haut de l'écran au dessus de l'affichage des photos

Envoyé de mon Nexus 10 en utilisant Tapatalk
Mes photos : jpverrue.fr
Répondre
#8
(30-10-18, 20:16)jpverrue a écrit : Tu accèdes aux préférences avec l'icône en forme de roue dentée en haut de l'écran au dessus de l'affichage des photos

Envoyé de mon Nexus 10 en utilisant Tapatalk

j'aurais aimé faire simple mais justement (et je l'ai expliqué et cité le manuel) cette roue dentée n'est jamais affichée sur mon système.
un programme connu n'a jamais fonctionné: c'est VLC il peut se lancer par une commande console mais ne charge pas l'interface, après des heures de recherches réitérée pendant quelques mois j'ai trouvé aucun indice, personne n'en parle, j'ai abandonné. Les mises à jour du système, depuis, n'ont rien changé et impossible de compiler un ancien VLC une protection de sécurité l'interdit (les librairies nécéssaire ont une faille de sécurité). Peut être il y a un lien, mais un tel bug sur un des logiciels les plus connus devrait être mentionné.
[Image: interface-darktable.jpg]

j'ai finalement trouvé, c'était le petit triangle qui y donnait accès,. J'ai beaucoup de mal avec les onglets et info masquées de cette manière: j'ai besoin de voir toutes les infos d'un coup pour gérer les choses. Mais pas trouvé dans les préférence de réglage de time-zone
[Image: interface-darktable2.jpg]
Répondre
#9
Là on parle de la version 2.2.1 !!!!! Tu devrais passer rapidement en 2.4.4 car beaucoup de bugs ont été corrigés depuis. T'aider sur cette vieille version est une perte de temps pour tout le monde.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#10
(31-10-18, 14:50)pascal a écrit : Là on parle de la version 2.2.1 !!!!! Tu devrais passer rapidement en 2.4.4 car beaucoup de bugs ont été corrigés depuis. T'aider sur cette vieille version est une perte de temps pour tout le monde.

c'est la dernière version connue pour apt-get

# apt-get install darktable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
darktable is already the newest version (2.2.1-3).

ça oblige encore à aller chercher des sources-listes, ou compiler... etc. ça manque de simplicité

https://darktable.fr/installation/
=> debian
sudo apt-get install darktable
Une version plus récente est peut être présente sur les backports

https://backports.debian.org/ est écrit en rose beef... c'est du touin touin...
Enfin bref, maintenant que Darktable installé est à l'heure, que tout marche bien, que je n'ai plus qu'à passer à la moulinette mes photos... je m'en contente.
pour le reste c'est tout de même un excellent logiciel (je n'en connait d'ailleurs pas d'autre pour faire cela)
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)