Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: benoitdupontManque de réactivité
#1
J'essaie de me mettre à Darktable sur mon mac mais niveau réactivité ce n'est pas ça du tout alors que le mac est tout neuf et que tout est super fluide sur Lightroom et sur CaptureOne.

Voici un log de OpenCL lorsque je fais un rotate de l'image. Je dois slider et viser au pif puis attendre que la correction se fasse avant de voir le résultat et à nouveau y aller au pif et ainsi de suite. Ce n'est pas le seul module qui manque de réactivité.

Peut-être y-a-t'il un paramètre que je peux changer pour voir mes modifications presque en "live".

Après à peine quelques minutes d'utilisation de Darktable le ventilateur se met au maximum...

Code :
33,972502 [opencl_profiling] profiling device 0 ('Intel(R) Iris(TM) Plus Graphics 655'):
33,972507 [opencl_profiling] spent  0,0000 seconds in [Write Image (from host to device)]
33,972510 [opencl_profiling] spent  0,0059 seconds in rawprepare_1f
33,972513 [opencl_profiling] spent  0,0099 seconds in whitebalance_1f
33,972516 [opencl_profiling] spent  0,0314 seconds in ppg_demosaic_green
33,972519 [opencl_profiling] spent  0,0494 seconds in ppg_demosaic_redblue
33,972521 [opencl_profiling] spent  0,0072 seconds in border_interpolate
33,972524 [opencl_profiling] spent  0,1539 seconds in interpolation_resample
33,972527 [opencl_profiling] spent  0,0037 seconds in exposure
33,972529 [opencl_profiling] spent  0,0069 seconds in [Copy Image (on device)]
33,972532 [opencl_profiling] spent  0,0000 seconds in [Write Buffer (from host to device)]
33,972535 [opencl_profiling] spent  0,0274 seconds in lens_distort_lanczos3
33,972538 [opencl_profiling] spent  0,0050 seconds in clip_rotate_lanczos3
33,972541 [opencl_profiling] spent  0,0022 seconds in graduatedndp
33,972559 [opencl_profiling] spent  0,0020 seconds in colorin_unbound
33,972566 [opencl_profiling] spent  0,0543 seconds in eaw_decompose
33,972570 [opencl_profiling] spent  0,0196 seconds in eaw_synthesize
33,972573 [opencl_profiling] spent  0,0020 seconds in pad_input
33,972576 [opencl_profiling] spent  0,0237 seconds in gauss_reduce
33,972578 [opencl_profiling] spent  0,0115 seconds in process_curve
33,972581 [opencl_profiling] spent  0,0233 seconds in laplacian_assemble
33,972584 [opencl_profiling] spent  0,0033 seconds in write_back
33,972587 [opencl_profiling] spent  0,0024 seconds in levels
33,972590 [opencl_profiling] spent  0,0017 seconds in colorcorrection
33,972593 [opencl_profiling] spent  0,0031 seconds in colorout
33,972595 [opencl_profiling] spent  0,0056 seconds in [Read Image (from device to host)]
33,972598 [opencl_profiling] spent  0,4555 seconds totally in command queue (with 0 events missing)
33,972617 [dev_process_image] pixel pipeline processing took 0,824 secs (3,011 CPU)
34,276548 [dev_pixelpipe] took 0,381 secs (1,242 CPU) processed `local contrast' on CPU, blended on CPU [preview]
34,278443 [dev_pixelpipe] took 0,002 secs (0,014 CPU) processed `levels' on CPU, collected histogram on CPU, blended on CPU [preview]
34,281406 [dev_pixelpipe] took 0,003 secs (0,020 CPU) processed `color correction' on CPU, blended on CPU [preview]
34,283796 [dev_pixelpipe] took 0,002 secs (0,018 CPU) processed `output color profile' on CPU, blended on CPU [preview]
34,284306 [dev_pixelpipe] took 0,000 secs (0,004 CPU) processed `gamma' on CPU, blended on CPU [preview]
34,293330 [dev_process_preview] pixel pipeline processing took 0,633 secs (2,708 CPU)
Répondre
#2
OpenCL sur une carte Intel ça ne marche pas et c'est très lent:


Code :
$ darktable --disable-opencl
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#3
pareil, que des merdes avec mon mbp 13 late 11. J'ai désactivé opencl dans les parametres et ca fonctionne tout aussi bien
Répondre
#4
Notez que cela n'est pas spécifique à MacOS, toutes les cartes Intel ont une implémentation de OpenCL très lente pour le traitement d'image comme darktable et ce sur tous les OS.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#5
Sauf que si je désactive openCL via le menu de darktable c'est encore plus lent par la suite.
La carte, même si c'est une Intel ne semble pas si mauvaise : https://www.notebookcheck.net/Intel-Iris...632.0.html
Répondre
#6
Je persiste OpenCL sous Intel c'est très mauvais. Sous Liniux on black liste les cartes Intel pour cette raison.

Maintenant si c'est très lent peut-être que la compilation n'a pas été faite avec OpenMP?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#7
Avec la version 2.4.4 téléchargée depuis darktable.org lorsque j'étais sur Mac OS (Mavericks à fin octobre) et mon Macbook pro de fin 2013 (donc une Intel Iris HD 500, moins performante), c'était rapide (avec l'OpenCL désactivé) et plus lent si j'activais l'OpenCL. Bon, c'est vrai que darktable est plus rapide sur mon Linux, mais tout est plus rapide sous Linux.
Répondre
#8
Il faut peut-être vérifier dans darktablerc que les CPU sont exclus de OpenCL:

```
opencl=TRUE
opencl_device_priority=*/!0,*/*/*
opencl_disable_drivers_blacklist=intel,beignet,neo64
opencl_use_cpu_devices=false
```

Au besoin, spécifier à la main le chemin de la lib OpenCL à charger, à la ligne :
```
opencl_library=
```

(quand c'est vide, dt sélectionne automatiquement)
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Répondre
#9
Bonjour à toutes et à tous,

Pardon de relancer le sujet, mais j'ai passé la soirée sur DT hier soir pour me lancer.
Je bosse sur un Imac retina de 2017 avec un icore 5 et une ardeon Pro 580.

Je trouve également que DT rame pour beaucoup de choses et surtout dans la chambre noire.
Je ne sais pas si ça vient de mon matériel ou du couple avec DT mais du coup je suis un peu déçu pour le moment.

Malheureusement je n'ai pas d'autres machines à part un vieux MBA, pour tester. ( à part mon PC du boulot mais pas sur que je puisse, faut que je demande à mon responsable Smile )

Merci à vous tous pour vos retours et votre aide.
Débutant sur Darktable
Version 2.6.2
Mac OS 10.14
www.romaingirod.fr
Répondre
#10
(28-04-19, 08:31)Applestore a écrit : Bonjour à toutes et à tous,

Pardon de relancer le sujet, mais j'ai passé la soirée sur DT hier soir pour me lancer.
Je bosse sur un Imac retina de 2017 avec un icore 5 et une ardeon Pro 580.

Je trouve également que DT rame pour beaucoup de choses et surtout dans la chambre noire.
Je ne sais pas si ça vient de mon matériel ou du couple avec DT mais du coup je suis un peu déçu pour le moment.

Malheureusement je n'ai pas d'autres machines à part un vieux MBA, pour tester. ( à part mon PC du boulot mais pas sur que je puisse, faut que je demande à mon responsable Smile )

Merci à vous tous pour vos retours et votre aide.

Bonjour,
Ça rame "globalement" ou simplement lorsque tu actives certains modules ?
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)