Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: JeanLucLacroixdt 2.6 lenteur de chargement
#1
Bonjour à tous,

Depuis 2.6, j'ai l'impression nette que dt met beaucoup plus de temps à se lancer. Je dispose pourtant d'une configuration solide:

i7-4790K CPU @ 4.00GHz (4 coeurs, 8 threads)
ram 24 GB
Nvidia GeForce GTX 970
SSD

Temps de chargement de dt: 6 sec.

Pas que je sois inquiet ou impatient (qu'est-ce que 6 secondes en définitive?), je cherche simplement une explication rationnelle à ce ralentissement depuis 2.6.

darktablerc
https://pastebin.com/raw/HkpJsCSB

Des pistes?
Répondre
#2
linux : quelle version ?
que dit dt lorsqu'on le lance depuis un terminal ?
Répondre
#3
(22-01-19, 06:28)kohlerg a écrit : linux : quelle version ?
que dit dt lorsqu'on le lance depuis un terminal ?

1- Debian stretch

2- En mode debug all:


Code :
[memory] at startup
[memory] max address space (vmpeak):      333984 kB
[memory] cur address space (vmsize):      333984 kB
[memory] max used memory   (vmhwm ):       20660 kB
[memory] cur used memory   (vmrss ):       20660 kB
0,045747 [sql] ... SQL stuff
(...)
0,048898 [sql] ... SQL stuff
0,048943 [pwstorage_new] Creating new context 0x55d798008b30
0,048947 [pwstorage_new] using libsecret backend for username/password storage
4.103963 [opencl_init] opencl related configuration options:
4.103971 [opencl_init] 
4.103975 [opencl_init] opencl_library: ''
4.103977 [opencl_init] opencl_memory_requirement: 768
(...)
5,027533 FIN du chargement

Cela semble coincer à [opencl_init]

Edit
Même ralentissement au même endroit en désactivant le support OpenCL
Répondre
#4
En effet, je ne sais pourquoi... Pour moi:


Code :
0.080964 [pwstorage_new] Creating new context 0x557249b195e0
0.080971 [pwstorage_new] using libsecret backend for username/password storage
0.525816 [opencl_init] opencl related configuration options:
0.525830 [opencl_init]
0.525833 [opencl_init] opencl: 1
0.525836 [opencl_init] opencl_library: ''
0.525839 [opencl_init] opencl_memory_requirement: 512
0.525842 [opencl_init] opencl_memory_headroom: 1150
0.525845 [opencl_init] opencl_device_priority: '*/!0,*/*/*'


Avec:

NVIDIA Corporation GM107GLM [Quadro M1000M]
Une seule carte graphique.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#5
Le plus curieux, c'est que quand l'OpenCl est désactivé, le même ralentissement se produit et l'initialisation d'OpenCL se poursuit tout de même.
Répondre
#6
Je dirais que ce n'est pas l'opencl mais l'étape juste avant car le temps indiqué est le début de l'étape. Donc ton backend libsecret est peut être le souci?
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)