Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: JacoTuxfilmique 2.6.1 : problème de tassement de l'histogramme à gauche
#21
(09-03-19, 01:13)aurelienpierre a écrit : Filmique ne marche pas comme il devrait avec SSE2=false et SIMD=true ?

J'y suis retourné voir et bien contrôlé les deux lignes pour SSE2 et SIMD... et ça ne fonctionne pas.

(09-03-19, 01:24)JacoTux a écrit :
(09-03-19, 01:13)aurelienpierre a écrit : Filmique ne marche pas comme il devrait avec SSE2=false et SIMD=true ?

J'y suis retourné voir et bien contrôlé les deux lignes pour SSE2 et SIMD... et ça ne fonctionne pas.

Pour plus d'informations si ça permet un meilleur diagnostique.
Je n'ai pas de gpu sur une carte graphique dédiée, donc c'est mon CPU qui fait le job.
C'est un Sandy Bridge plus précisément l'Intel i5-2430M CPU @ 2.40GHz
#22
Ouf! Merci pour ces mises au point, j'avais aussi remarqué ce problème (image inexploitable avec "conservation de la chrominance" coché) et commençais à me demander si j'avais bien compris l'utilisation de filmique... Vivement la correction!
POur le reste, bravo et merci pour l'activité bouillonnante en ce moment!
#23
Bonjour à tous
Juste mon experience avec Filmique si ça peut aider:
J'ai developpé une série de .NEF avec la version 2.6.0 en suivant le processus decrit par Philippe dans son dernier Tuto.
Je précise que j'active systématiquement "préserver la chrominance" et je corrige ensuite la saturation avec le module balance couleur.
J'ai installé la 2.6.1 hier et je constate:
1 j'ai le même rendu que les images traités avec la 2.6.0
2 si je re-développe des Nef avec la 2.6.1 je n'ai le problème de "tassement de l'histogramme" à gauche avec Filmique et l'activation de la chrominance.

Je suis sous windows 10 et l'openCL est activé;
pour l'instant mon experience de la 2.6.1 est excellente
Richard
#24
Je viens de tester avec la version 2.6.1 que j'ai compilée à partir des sources : darktable-2.6.1-win64.exe :
[Image: image.png]
bizarre je constate le tassement de l'histogramme à gauche mais à la ramener.
#25
(08-03-19, 22:23)aurelienpierre a écrit :
(08-03-19, 21:43)JMM40 a écrit :
(08-03-19, 20:47)aurelienpierre a écrit : Je précise que ce bug n'affecte pas la variante OpenCL.

Bonjour Aurelien, je ne comprend peut-être pas bien, mais sous Windows 10 j'utilise l'OpenCL et j'ai le problème.

Il n'est probablement pas actif alors.

Quelques essais :
Ayant une machine distante sous Win10 1809 équipée d'un i7-870 et une CG AMD Radeon HD 5700 series, j'ai installée la 2.6.1 et.
Je confirme sans l'OpenCL le bug est présent
Mais avec l'OpenCL cela dépend des préférences faites dans le profil de planification de l'OpenCL.
Il y a trois options :
- défaut
- CPU multiples
- CPU très rapide
Seules les deux dernières options ne sont pas affectées.
C'est peut-être pour JMM40 le moyen de contournement.

De retour sur mon PC et sa Manjaro Linux j'ai compilé la version master dans une VM.
Là je confirme que tout fonctionne bien, sans l'OpenCL.

Bon, il est probable que les dev ne puissent sortir une version 2.6.2, voire une inter 2.6.1.1, rapidement, donc je vais passer sur la master.
#26
Sous OpenSUSE, processeur I5 et carte vidéo NVidia GTX 1050, la version compilée à partir de GitHub master, ça fonctionne parfaitement, il lit tout l'historique avec OpenCL sur CPU très rapide :
[Image: image.png]
#27
(09-03-19, 14:56)jpg54 a écrit : Sous OpenSUSE, processeur I5 et carte vidéo NVidia GTX 1050, la version compilée à partir de GitHub master, ça fonctionne parfaitement, il lit tout l'historique avec OpenCL sur CPU très rapide.

Oui c'est aussi le constat que je fais après avoir compilé à partir de GitHub master, il faut néanmoins utiliser un profil de planification de l'OpenCL autrement que la valeur "default" qui est celle à l'installation.
Un piège pour pas mal d'utilisateurs, ayant accès à l'OpenCL, qui n'iront pas voir dans "préférences" onglet "fonctionnement" le réglage.
#28
J'ai toujours CPU très rapide dans les préférences.
#29
Bonjour,
j'ai moi aussi fait quelques essais:
sur Windows 10 dans les préférences avec OpenCL: - décoché            mauvais fonctionnement de filmique
                                                                                    - défaut                mauvais
                                                                                    - GPU multiples    mauvais
                                                                                    - GPU très rapide Bon fonctionnement de filmique

Avec Ubuntu 18.04.2 LTS
Intel Core i5-7400 CPU @ 3.00GHz × 4
Intel HD Graphics 630 (Kaby Lake GT2)
Pas de possibilité d'utilisation d'OpenCL   mauvais fonctionnement de filmique

Je peux donc utiliser darktable avec windows 10 et avec le paramètre OpenCL avec GPU très rapide en attendant que la correction arrive.
#30
@ JMM40

Si ton HD graphics 630 supporte l'OpenCL sous Win10 alors il devrait aussi le supporter sous Linux.
Il te faut le support pour les CPUs, et les GPUs Ivy Bridge (pas tous malheureusement, le mien est trop vieux)
C'est le paquet beignet pour un Buntu donc

Code :
apt-get install beignet beignet-dev


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)