Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: JacoTuxfilmique 2.6.1 : problème de tassement de l'histogramme à gauche
#51
(10-03-19, 11:47)nicoauffray a écrit :
(10-03-19, 11:45)pascal a écrit : > Il faut un (hard)core dev pour s'en occuper (Pascal :-) )

Oui Smile J'ai oublié un patch pour la 2.6.1. Malheureusement je ne peut pas faire de release trop rapprochée car c'est du temps et pas mal d'actions manuelles. Ce qui est certain c'est que ce sera dans la 2.6.2 que l'on peut essayer de faire avant l'été.

Et une 2.6.1 rev2 ou 2.6.1-2, pas possible (en gros simplement ajouter le patch à la 2.6.1 et refaire les paquets) ? A moins que ça revienne au même en termes d'actions qu'une 2.6.2 ?

Cela demande de redemander un build au mainteneur Windows et MacOS. Et donc d'annoncer cette release, car il faut que tout le monde comprenne le problème. Surtout tout les packageur Linux.

Une heure ou deux juste après la sortie c'est possible de faire un "quick-fix" mais là impossible sans mobiliser beaucoup de personne.

Croyez bien que je suis navré de la situation.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
#52
Surtout que c'est pas pour tout le monde, j'essaye de demander à mes correspondants sous WinDows de remonter les problèmes ou pas avec les infos sur leur système.

Je vais faire quelques tests avec ma version sous W10 quand je m'y connecterais !
#53
On pourrait pas patcher la version en changeant la dll ou l'exe qui pose problème à la main? Vu la situation et la non possibilité de redescendre en 2.6, j'hésite à installer la 2.6.1 si filmique marche pas et que la 2.6.2 n'arrive qu'à l'été...
#54
filmique marche parfaitement si l'on ne sélectionne pas Préserver la chrominance et encore ce n'est pas systèmatique, de plus ce n'est pas utile sur toutes les photos et même parfois ça donne des résultats pas très agréable et il vaut mieux ne pas l'activer.
#55
Bonjour
J'ai essayé sous Windows 10
J'ai modifié le fichier darktablerc.
Il est dans Windows/Users/Utilisateur/AppData/Local/darktable
Puis avec éditeur de texte cherchez l'occurrence codepaths/openmp_simd=false
Changez false par true, enregistrez ainsi, lancez darktable...

                          dans les préférences avec OpenCL: - décoché            BON fonctionnement de filmique
                                                                                    - défaut                BON  
                                                                                    - GPU multiples    BON
                                                                                    - GPU très rapide BON fonctionnement de filmique
#56
(10-03-19, 15:10)jpg54 a écrit : filmique marche parfaitement si l'on ne sélectionne pas Préserver la chrominance et encore ce n'est pas systèmatique, de plus ce n'est pas utile sur toutes les photos et même parfois ça donne des résultats pas très agréable et il vaut mieux ne pas l'activer.

Il marche aussi parfaitement avec la préservation de la chrominance (excepté dans la version 2.6.1 dans les cas où le patch oublié est nécessaire). Après, comme il est indiqué dans le manuel, cette option ne s'utilise pas "en tant que tel". Il y a effectivement pas mal de situations où le résultat est déjà très bien sans cette option. Mais pas mal de situations donnent un bien meilleur résultat avec cette option activée. J'ai de nombreuses photos où le résultat est fade lorsque je ne l'active pas et où cette option redonne du peps à l'image. Souvent très saturée donc je descends les curseurs saturation à un niveau qui me convient. Parfois, le module balance couleur est une bonne option pour ajuster comme le décrit le manuel mais bien souvent j'ai d'excellents résultats sans ce dernier module.
Faisant essentiellement de la photo nature, cette option m'est indispensable, en particulier sur les images de paysage contrastées pour ce que j'ai constatée. Par contre, cette option en laissant les curseurs de saturation à 100% est clairement à éviter. Bref, utiliser cette option nécessite de désaturer systématiquement ensuite.

Pour résumer, je ne serais catégorique ni dans un sens ni dans l'autre. Ce qui est important est de tester/tester/tester/tester... puis tester/tester et encore... tester. Comme souvent pousser les curseurs à fond (ou presque) dans un sens puis dans l'autre, donne une idée de ce que ça fait. Ensuite, on ajuste entre les 2 petit à petit, en n'hésitant pas à faire des A/R entre les curseurs pour voir ce que ça donne.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master - Macbook pro fin 2013 13"
#57
(10-03-19, 15:54)nicoauffray a écrit : Bref, utiliser cette option nécessite de désaturer systématiquement ensuite.

Oui effectivement.
Mais dé-saturer ensuite... ou avant avec la saturation en sortie de balance couleur, ce n'est pas mieux ?
#58
(10-03-19, 18:29)JacoTux a écrit :
(10-03-19, 15:54)nicoauffray a écrit : Bref, utiliser cette option nécessite de désaturer systématiquement ensuite.

Oui effectivement.
Mais dé-saturer ensuite... ou avant avec la saturation en sortie de balance couleur, ce n'est pas mieux ?

Je n'en sais rien. Je n'utilise que peu balance couleur pour le moment. Ou du moins je le teste petit à petit.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master - Macbook pro fin 2013 13"
#59
(10-03-19, 18:37)nicoauffray a écrit :
(10-03-19, 18:29)JacoTux a écrit :
(10-03-19, 15:54)nicoauffray a écrit : Bref, utiliser cette option nécessite de désaturer systématiquement ensuite.

Oui effectivement.
Mais dé-saturer ensuite... ou avant avec la saturation en sortie de balance couleur, ce n'est pas mieux ?

Je n'en sais rien. Je n'utilise que peu balance couleur pour le moment. Ou du moins je le teste petit à petit.


Ben je me fie aux conseils prodigués par Aurélien sur cette page, et plus récemment dans le dernier manuel page 113 dt... dont tu es le traducteur (merci).

Extrait du manuel à ce sujet :
C’est pourquoi, lorsque vous utilisez ce mode, une désaturation supplémentaire doit être
effectuée, par exemple, en utilisant la saturation de sortie dans le module de balance des
couleurs entre 65 et 85%.

Mais avant filmique ou après je ne sais ce qui est le mieux ?
#60
Je reviens de sous W10 :
dans les préférences avec OpenCL :
- décoché impossible de récupérer avec Préservation de la chromiance
- défaut BON
- GPU multiples BON
- GPU très rapide BON


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)