Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
filmique 2.6.1 : problème de tassement de l'histogramme à gauche
#11
Je n'ai pas testé 2.6.1 mais vos résultats ne sont pas normaux. La version master fonctionne sans problème depuis près de 3 mois, je pencherais pour une erreur à l'intégration de master -> 2.6.1

Bingo, j'ai trouvé. Le patch https://github.com/darktable-org/darktab...2030/files n'a pas été intégré dans 2.6.1.

Bon voilà https://github.com/darktable-org/darktable/issues/2176

Il faut un (hard)core dev pour s'en occuper (Pascal :-) )
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
#12
Pour info, j'ai le même comportement en utilisant les nouveaux préréglages proposés dans la 2.6.1, vraisemblablement parce qu'ils utilisent l'option "préserver la chrominance"
Amicalement,

Georges

Version 3.2.1 sous Windows
Boitier Fujifilm X-T3




#13
(08-03-19, 20:03)aurelienpierre a écrit : Je n'ai pas testé 2.6.1 mais vos résultats ne sont pas normaux. La version master fonctionne sans problème depuis près de 3 mois, je pencherais pour une erreur à l'intégration de master -> 2.6.1

Bingo, j'ai trouvé. Le patch https://github.com/darktable-org/darktab...2030/files n'a pas été intégré dans 2.6.1.

Bon voilà https://github.com/darktable-org/darktable/issues/2176

Il faut un (hard)core dev pour s'en occuper (Pascal :-) )

Merci Aurélien et bien vu concernant la détermination de la cause de ce comportement.

Merci d'avance @Pascal
#14
(08-03-19, 20:18)GM1901 a écrit : Pour info, j'ai le même comportement en utilisant les nouveaux préréglages proposés dans la 2.6.1, vraisemblablement parce qu'ils utilisent l'option "préserver la chrominance"

Normal du coup. Comme Aurélien vient de le signaler, un patch (une ligne d'après ce que j'ai vu) manque dans la 2.6.1. C'est donc bien un bug de la 2.6.1, ou plutôt un patch oublié dans son intégration qui fausse complètement les résultats de filmique. En bref, filmique est inopérant en l'état sur la 2.6.1. Ca devrait vite être corrigé avec une mise à jour pour corriger cela. Un peu de patience.

D'autant qu'en usage normal (celui que j'ai avec la version de filmique incluant ce patch donc), le résultat est meilleur avec l'option "préserver la chrominance". Sans cette option, les images bien réglées via l'exposition et filmique sont plus ternes, les couleurs reprennent vie en quelque sorte avec cette option

En l'état, ne vous fiez surtout pas à ce module dans la version 2.6.1 actuelle.
Module très recommandé, avec l'option "préserver chrominance" autrement sur toute autre version (2.6.0, master ou la prochaine qui inclura le patch).
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
#15
Je précise que ce bug n'affecte pas la variante OpenCL.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
#16
(08-03-19, 20:47)aurelienpierre a écrit : Je précise que ce bug n'affecte pas la variante OpenCL.

Bonjour Aurelien, je ne comprend peut-être pas bien, mais sous Windows 10 j'utilise l'OpenCL et j'ai le problème.
#17
(08-03-19, 20:47)aurelienpierre a écrit : Je précise que ce bug n'affecte pas la variante OpenCL.

Arhhhhhhhh, merci de retourner le couteau dans la plaie. Cry
J'avais déjà le problème des halos de bord à l'affichage avec le laplacien local du contraste local.
Je n'ai plus qu'à changer de PC si je comprends bien.
#18
(08-03-19, 21:43)JMM40 a écrit :
(08-03-19, 20:47)aurelienpierre a écrit : Je précise que ce bug n'affecte pas la variante OpenCL.

Bonjour Aurelien, je ne comprend peut-être pas bien, mais sous Windows 10 j'utilise l'OpenCL et j'ai le problème.

Il n'est probablement pas actif alors.

(08-03-19, 21:46)JacoTux a écrit :
(08-03-19, 20:47)aurelienpierre a écrit : Je précise que ce bug n'affecte pas la variante OpenCL.

Arhhhhhhhh, merci de retourner le couteau dans la plaie. Cry
J'avais déjà le problème des halos de bord à l'affichage avec le laplacien local du contraste local.
Je n'ai plus qu'à changer de PC si je comprends bien.

Personne n'a dit ça, c'est un bug identifié. On a 3 versions du code, la seule sur les 3 qui est impactée est la version CPU SSE2. Tu peux aussi aller dans darktablerc et chercher codepaths/openmp_simd=false et le passer à codepaths/openmp_simd=true, du coup c'est la version pure C (plus lente) qui sera utilisée.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
#19
(08-03-19, 22:23)aurelienpierre a écrit : Personne n'a dit ça, c'est un bug identifié. On a 3 versions du code, la seule sur les 3 qui est impactée est la version CPU SSE2. Tu peux aussi aller dans darktablerc et chercher codepaths/openmp_simd=false et le passer à codepaths/openmp_simd=true, du coup c'est la version pure C (plus lente) qui sera utilisée.

Oui bien sûr personne ne l'a dit... j'étais juste dans l'idée que je cumulais sur les deux dernières versions de dt avec l'OpenCPL qui n'est pas prise en charge sur mon matériel.
Par contre je ne vois pas bien ce que l'Open Multi-Processing et SIMD change pour le coup, false ou true pas vu de différence.
Tenté aussi de basculer pour le jeu d'instruction SSE2, des fois que... mais sans effet.
#20
Filmique ne marche pas comme il devrait avec SSE2=false et SIMD=true ?

C'est bizarre parce que la ligne manquante dans le code, corrigée par le patch en référence plus haut, n'impacte que la fonction SSE2. Les deux autres fonctions (OpenCL et pur C avec SIMD) sont totalement indépendantes.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]


Atteindre :


Utilisateur(s) parcourant ce sujet : 12 visiteur(s)