Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: JacoTuxfilmique 2.6.1 : problème de tassement de l'histogramme à gauche
#31
(09-03-19, 16:35)JacoTux a écrit : @ JMM40

Si ton HD graphics 630 supporte l'OpenCL sous Win10 alors il devrait aussi le supporter sous Linux.
Il te faut le support pour les CPUs, et les GPUs Ivy Bridge (pas tous malheureusement, le mien est trop vieux)
C'est le paquet beignet pour un Buntu donc

Code :
apt-get install beignet beignet-dev

J'ai bien installé le paquet et apparemment c'est fait, mais dans les préférences de dt je n'ai rien de changé. Je ne suis pas très fort sur Ubuntu y a-t-il autre chose à faire ?
#32
(08-03-19, 22:23)aurelienpierre a écrit : Tu peux aussi aller dans darktablerc et chercher codepaths/openmp_simd=false et le passer à darktablerc=true, du coup c'est la version pure C (plus lente) qui sera utilisée.

Je m'en veux j'ai dit une belle bêtise plus haut en répondant que cela ne fonctionnait pas, je n'avais pas modifié le bon darktablerc.  Sick

Effectivement filmique fonctionne bien sans l'OpenCL si dans ~/.config/darktable/darktablerc
codepaths/openmp_simd=true

Donc c'est le moyen de contournement pour ceux qui n'auraient pas l'OpenCL en attendant une MàJ.



(09-03-19, 17:02)JMM40 a écrit : J'ai bien installé le paquet et apparemment c'est fait, mais dans les préférences de dt je n'ai rien de changé. Je ne suis pas très fort sur Ubuntu y a-t-il autre chose à faire ?


Pour l'OpenCL dans les préférences de darktable à l'onglet "fonctionnement" il faut à "profil de planification OpenCL" prendre "l'option CPU très rapide"
Relancer darktable pour la prise en compte.
#33
(09-03-19, 17:23)JacoTux a écrit :
(08-03-19, 22:23)aurelienpierre a écrit : Tu peux aussi aller dans darktablerc et chercher codepaths/openmp_simd=false et le passer à darktablerc=true, du coup c'est la version pure C (plus lente) qui sera utilisée.

Je m'en veux j'ai dit une belle bêtise plus haut en répondant que cela ne fonctionnait pas, je n'avais pas modifié le bon darktablerc.  Sick

Effectivement filmique fonctionne bien sans l'OpenCL si dans ~/.config/darktable/darktablerc
codepaths/openmp_simd=true

Donc c'est le moyen de contournement pour ceux qui n'auraient pas l'OpenCL en attendant une MàJ.



(09-03-19, 17:02)JMM40 a écrit : J'ai bien installé le paquet et apparemment c'est fait, mais dans les préférences de dt je n'ai rien de changé. Je ne suis pas très fort sur Ubuntu y a-t-il autre chose à faire ?


Pour l'OpenCL dans les préférences de darktable à l'onglet "fonctionnement" il faut à "profil de planification OpenCL" prendre "l'option CPU très rapide"
Relancer darktable pour la prise en compte.

à l'onglet "fonctionnement" il faut à "profil de planification OpenCL" j'ai "non disponible" ! j'ai vérifié le paquet beignet est bien installé .
#34
@JMM40: beignet est blaklisté comme tous les drivers Intel neo car ils ne marchent tout simplement pas.

OpenCL Intel => Poubelle !
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
#35
(09-03-19, 18:19)pascal a écrit : @JMM40: beignet est blaklisté comme tous les drivers Intel neo car ils ne marchent tout simplement pas.

OpenCL Intel => Poubelle !

Merci pour le renseignement, [Image: sad.png]  [Image: shy.png]
#36
Sur Ubuntu 18.04.2 Le PPA de pmjdebruijn ne m'a pas encore été proposé (il est dans mes autres logiciels), c'est du a tout ce qui est expliqué au-dessus, et cela arrivera avec la prochaine release ou j'ai un problème logiciel?
J'ai pu tester sur mes portables Windows, mêmes conclusions que ci-dessus, mais j'aimerais bien l'avoir sur mon poste principal.
#37
(09-03-19, 18:26)mimi85 a écrit : Sur Ubuntu 18.04.2 Le PPA de pmjdebruijn ne m'a pas encore été proposé (il est dans mes autres logiciels), c'est du a tout ce qui est expliqué au-dessus, et cela arrivera avec la prochaine release ou j'ai un problème logiciel?
J'ai pu tester sur mes portables Windows, mêmes conclusions que ci-dessus, mais j'aimerais bien l'avoir sur mon poste principal.

Etant sous linux mint 19.1 le PPA m'a bien proposé la mise à jour !!
darktable 2.6.3 + darktable 3.0 RC1 + Nikon D7200 + Nikon D3

#38
(09-03-19, 18:26)mimi85 a écrit : Sur Ubuntu 18.04.2 Le PPA de pmjdebruijn ne m'a pas encore été proposé (il est dans mes autres logiciels), c'est du a tout ce qui est expliqué au-dessus, et cela arrivera avec la prochaine release ou j'ai un problème logiciel?
J'ai pu tester sur mes portables Windows, mêmes conclusions que ci-dessus, mais j'aimerais bien l'avoir sur mon poste principal.

Bonsoir à tous,
Aucun souci sur Ubuntu 18.04, j’ai bien la version 2.6.1 avec PPA pmjdebruijn.
Canon EOS 80D.
Linus Ubuntu 18.04 LTS Gnome / darktable 3.0.0 + master
#39
Bonsoir à tous,

Je suis sur Debian et j'ai rencontré le même problème après avoir actualisé à la version 2.6.1 : si j'active "préserver la chrominance" sur filmic l’histogramme s'entasse à gauche. Les RAW qui était développés sous la version 2.6 sont affectés aussi.
J'ai changé pour la version master et l'option "préserver la chrominance" marche comme il se doit. Alors sur la version master je rencontre le problème de ne pas pouvoir créer des nouvelles instances sur les modules. Je suis coincé.
Je suis en train d'apprendre français et la photo.
#40
(09-03-19, 19:32)Fotia a écrit : Bonsoir à tous,

Je suis sur Debian et j'ai rencontré le même problème après avoir actualisé à la version 2.6.1 : si j'active "préserver la chrominance" sur filmic l’histogramme s'entasse à gauche. Les RAW qui était développés sous la version 2.6 sont affectés aussi.
J'ai changé pour la version master et l'option "préserver la chrominance" marche comme il se doit. Alors sur la version master je rencontre le problème de ne pas pouvoir créer des nouvelles instances sur les modules. Je suis coincé.

J'ai aussi ce problème sur la version master. Je viens de poster le bug sur redmine pour qu'un développeur voit ce qui a causé cette régression.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master - Macbook pro fin 2013 13"


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)