Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: des-clicmise a jour darktable 2.6.2
#1
bonjour

je n’arrive pas a mettre a jours la version j'ai un message qui me dit que la version 2.6.1 est la plus recente :

Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
darktable est déjà la version la plus récente (1:2.6.1-0pmjdebruijn1~bionic).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  chromium-codecs-ffmpeg-extra libjs-prototype libjs-scriptaculous
  libllvm6.0:i386 linux-headers-4.15.0-46 linux-headers-4.15.0-46-generic
  linux-image-4.15.0-46-generic linux-modules-4.15.0-46-generic
  linux-modules-extra-4.15.0-46-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 13 non mis à jour.

pouvez vous me dire la marche a suivre pour passer a la 2.6.2

j'ai suivi les indication si dessous mais ça ne fonctionne pas

Vous pouvez ajouter la clé du dépôt à apt. Gardez à l'esprit que le propriétaire de la clé peut fournir des mises à jour, des paquets et des dépôts envers lesquels votre système aura confiance (plus d'informations). Pour ajouter la clé, exécutez :
wget -nv https://download.opensuse.org/repositori...elease.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update
Pour xUbuntu 18.04, exécutez :
sudo sh -c "echo 'deb http://download.opensuse.org/repositorie...ntu_18.04/ /' > /etc/apt/sources.list.d/graphics:darktable.list"
sudo apt-get update
sudo apt-get install darktable
Répondre
#2
Pascal De Bruijn n'a toujours pas construit le paquet pour Ubuntu
Comme j'ai l'ai écrit : https://forums.darktable.fr/showthread.p...7#pid31437
c'est la seule possibilité d'avoir la version 2.6.2 avec Ubuntu.
Une recherche t'aurais montré qu'il y a 7 pages pour la release 2.6.2. Il serait bien de lire le règlement du forum (pas bien contraignant) : https://darktable.fr/reglement-du-forum/
Répondre
#3
(01-05-19, 09:51)jpg54 a écrit : Pascal De Bruijn n'a toujours pas construit le paquet pour Ubuntu
Comme j'ai l'ai écrit : https://forums.darktable.fr/showthread.p...7#pid31437
c'est la seule possibilité d'avoir la version 2.6.2 avec Ubuntu.
Une recherche t'aurais montré qu'il y a 7 pages pour la release 2.6.2. Il serait bien de lire le règlement du forum (pas bien contraignant) : https://darktable.fr/reglement-du-forum/

Euh je penses que ce n'est pas le problème ici puisqu'il fait référence au dépôt Opensuse justement...

(01-05-19, 09:28)des-clic a écrit : bonjour

je n’arrive pas a mettre a jours la version j'ai un message qui me dit que la version 2.6.1 est la plus recente :

pouvez vous me dire la marche a suivre pour passer a la 2.6.2

j'ai suivi les indication si dessous mais ça ne fonctionne pas

Vous pouvez ajouter la clé du dépôt à apt. Gardez à l'esprit que le propriétaire de la clé peut fournir des mises à jour, des paquets et des dépôts envers lesquels votre système aura confiance (plus d'informations). Pour ajouter la clé, exécutez :
wget -nv https://download.opensuse.org/repositori...elease.key -O Release.key
sudo apt-key add - < Release.key
sudo apt-get update
Pour xUbuntu 18.04, exécutez :
sudo sh -c "echo 'deb http://download.opensuse.org/repositorie...ntu_18.04/ /' > /etc/apt/sources.list.d/graphics:darktable.list"
sudo apt-get update
sudo apt-get install darktable

C'est la manière dont le numéro de version est noté entre le dépôt pmdebruijn et le dépôt Opensuse à mon avis qui fait que ton système croit que la version darktable pmdebruijn est plus récente.

Je te recommande donc de désinstaller darktable avec un apt autoremove darktable et de supprimer le dépôt pmdebruijn dans ta liste (le plus simple est d'utiliser le "Gestionnaire de mises à jour" et d'aller dans ses préférences pour cela).

Et ensuite, vu que le dépôt Opensuse semble maintenant installé, tu refait un apt install darktable.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#4
Autant pour moi, j'ai pas suivi le reste de ce qu'il a fait et comme je suis maintenant sous Fedora, je dois dire que j'ai un peu oublié les commandes Ubuntu.
Répondre
#5
Sinon, installe un paquet Flatpak. Je suis pas fan des paquets de ce type (duplication de libs), mais avec un cycle de développement plus rapide, les dépôts mis à jour un mois après, ça commence à être la galère. D'autant plus que darktable 2.8 utilisera GTK 2.22 minimum, donc ne pourra plus être packagé pour Debian 8 ou 9 (je ne sais plus) et Ubuntu < 18.04 (de mémoire).
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Répondre
#6
(01-05-19, 10:40)aurelienpierre a écrit : D'autant plus que darktable 2.8 utilisera GTK 2.22 minimum

3.22 Smile
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#7
3.22 en effet. :-P
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique, égaliseur de tons, balance couleur, etc.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)