Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: darkshotcorrection des objectifs, lensfun, Tamron 90 (017)
#1
Bonjour j'ai depuis peu le nouveau Tamron SP 90mm f2.8 Di VC USD Macro (F017).
Darktable ( 2.6.2) et le module correction des objectifs m'affiche bien le nom complet de l'objectif mais il n'est pas dans la liste: "boitier/objectif introuvable--selection manuelle".


 Ici https://forums.darktable.fr/showthread.p...4#pid11224
Je lis ça:
Citation :Exiv2 pour l'identification des objectifs car effectivement dans la donnée exif brute (non décodée) les objectifs sont identifiés avec un simple numéro à 3 chiffres (je crois). Exiv2 utilise ce numéro, la focale min et la focale max, ou la focale tout court pour les focales fixes ; et l'ouverture max pour identifier exactement l'objectif et produire la chaîne de caractère correspondant à son nom complet.

Par exemple, ton sigma 150 porte le numéro 153, a une focale de 150mm et une ouverture max de f/2.8. Ces trois données suffisent apparemment à identifier exactement ton objectif et à retourner son nom complet, à savoir : SIGMA APO MACRO 150mm F2,8 EX DG OS HSM

Lensfun utilisera ensuite ce nom complet pour trouver la correction de l'objectif dans sa base de donnée.

Donc si ça ne fonctionne pas
  1. Est-ce que le nom de l'objectif est correctement affiché dans DT ? Oui : passer au point 2. Non : pas grand chose à faire. Essayer de mettre à jour exiv2 ; peut-être y-a-t-il une version plus récente ? Si ça ne fonctionne toujours pas, faire un rapport de Bug sur le site d'Exiv2 et attendre la prochaine version.
  2. Si le nom s'affiche mais qu'il n'y a pas de correction disponible. Essayer de mettre à jour la base de donnée de Lensfun qui evolue régulièrement (disponible ICI). Si ça ne fonctionne pas, c'est très certainement que l'objectif n'existe pas dans cette BdD. Dans ce cas  tu peux : soit faire toi même la caractérisation, soit envoyer des photos de caractérisation au mainteneur. Tout est expliqué ICI


Le nom s'affiche mais pas de correction possible. J'ai tenté de mettre à jour la base de donnée lensfun, mais cela ne change rien.
Donc j'en déduis que mon objectif n'est pas dans la base de données.
Un petit coup d'oeil ici: https://wilson.bronger.org/lensfun_coverage.html , il y a bien un tamron 90 macro mais je pense que c'est le vieux modèle.

Je comprends qu'il ne me reste qu'à: soit faire moi meme la caractérisation, soit envoyer des photos de caractérisation, comme il est dit dans le post.

Pour la calibration quelle est la meilleure méthode?

Ici: http://lensfun.sourceforge.net/calibration/

on en propose 4. Je ne suis pas un spécialiste de ce genre d'opération.

Merci d'avance.
Répondre
#2
Sans conteste, la méthode 2 de Torsten. Et, pour simplifier, tu peux sauter l'étape des scripts et passer directement à la réalisation.

Envoyé de mon CMR-AL09 en utilisant Tapatalk
Mes photos : jpverrue.fr
Répondre
#3
Bonjour,

Ce n'est pas tant la méthode qui est la même mais plutôt le bon script qu'il s'agit d'avoir ainsi que les dépendances.
Le script proposé sur le deuxième lien est ancien et n'a pas fonctionné chez moi.
Le bon tutoriel pour la réalisation des images à faire est sur le premier lien. Elle pointe aussi vers le script python qui va bien, c'est ici

Pour ce qui est des pré-requis il faut les installer à la main mais la page pixls.us donne ce lien pour installer le tout sous forme de paquet
Pour ceux qui sont sous Arch ou dérivées, c'est possible aussi en installant lens_calibrate à partir de AUR

Pour avoir fait la caractérisation d'un de mes objectifs, le plus compliqué c'est peut-être d'avoir les bons clichés pour travailler.
Répondre
#4
(04-05-19, 07:57)jpverrue a écrit : Sans conteste, la méthode 2 de Torsten. Et, pour simplifier, tu peux sauter l'étape des scripts et passer directement à la réalisation.

Envoyé de mon CMR-AL09 en utilisant Tapatalk

merci.
Un doute m'assaille...Dans la liste de bronger je vois un "Tamron SP 90mm f/2.8 Di VC USD Macro 1:1" qui semble correspondre au nouveau modèle ( 017).
Je ne comprends pas bien...
Répondre
#5
A priori ton objectif semble être dans la base de lensfun pour au moins la distorsion et les aberrations.

Code :
<lens>
       <maker>Tamron</maker>
       <model>Tamron SP 90mm f/2.8 Di VC USD Macro 1:1 F004</model>
       <model lang="en">Tamron SP 90mm f/2.8 Di VC USD Macro 1:1</model>
       <mount>Nikon F AF</mount>
       <mount>Canon EF</mount>
       <mount>Sony Alpha</mount>
       <cropfactor>1.613</cropfactor>
       <calibration>
           <!-- taken with Canon EOS 700D -->
           <distortion model="poly3" focal="90" k1="-0.00085"/>
           <tca model="poly3" focal="90" vr="1.0000890" vb="1.0000142"/>
       </calibration>
</lens>

(04-05-19, 07:57)jpverrue a écrit : Et, pour simplifier, tu peux sauter l'étape des scripts et passer directement à la réalisation.

Qu'entends tu par "sauter l'étape des scripts" ?
Répondre
#6
Citation :A priori ton objectif semble être dans la base de lensfun pour au moins la distorsion et les aberrations.

Code :
<lens>
      <maker>Tamron</maker>
      <model>Tamron SP 90mm f/2.8 Di VC USD Macro 1:1 F004</model>
      <model lang="en">Tamron SP 90mm f/2.8 Di VC USD Macro 1:1</model>
      <mount>Nikon F AF</mount>
      <mount>Canon EF</mount>
      <mount>Sony Alpha</mount>
      <cropfactor>1.613</cropfactor>
      <calibration>
          <!-- taken with Canon EOS 700D -->
          <distortion model="poly3" focal="90" k1="-0.00085"/>
          <tca model="poly3" focal="90" vr="1.0000890" vb="1.0000142"/>
      </calibration>
</lens>

Code :
<model>Tamron SP 90mm f/2.8 Di VC USD Macro 1:1 F004</model>


c'est le modèle 004. Moi j'ai le modèle 017, le nouveau. Merci tu as comfirmé que mon modèle n'est pas dans lensfun ( j'avais un doute)
Répondre
#7
Peut-être une différence entre ce que donne les exifs et la définition dans la base LensFun. Une photo en téléchargement pourrait aider ?
Répondre
#8
> Qu'entends tu par "sauter l'étape des scripts" ?

Je if dire qu'il propose au début de son tutoriel la création de tout un tas de dossiers avec l'aide d'un script (de mémoire). Je trouve que ce n'est vraiment pas indispensable. On peut passer directement au traitement des photos.

Mais comme la bien dit JacoTux, le plus dur est certainement de réaliser les bonnes prises de vues.
Mes photos : jpverrue.fr
Répondre
#9
(04-05-19, 09:17)jpg54 a écrit : Peut-être une différence entre ce que donne les exifs et la définition dans la base LensFun. Une photo en téléchargement pourrait aider ?

https://framadrop.org/r/_7bB0iEalm#xdyEC...5mCPtHtQo=
Répondre
#10
Bon, chez moi, le boîtier n'est pas reconnu et l'objectif est reconnu comme un Canon Macro :
[Image: image.png]
Je pense qu'il y a des incohèrences avec Exiv2 et LensFun. Faut que je fasse des comparaisons !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)