Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: LViatourCorrection des objectifs et Lensfun
#11
(13-05-19, 15:41)LViatour a écrit :
(13-05-19, 13:45)pascalG a écrit : Le problème est que la définition de l'objectif n'est pas présente dans les exifs, mais dans les makernotes.

Et donc c'est le boitier qui n'écrit pas au bon endroit les données exifs de l'optique? 

L'optique est corrigée correctement avec les boîtiers en monture F comme le D850 ou mon ancien D5

Le lensIDNumber de votre objectif est 146. Il semble que la lecture des exifs se passe mal puisque le nom de cet objectif n'apparaît pas dans les informations de l'image dans dt ... Si l'info est cherchée dans les zones vides, c'est effectivement un problème de l'ensemble boîtier+FTZ ...
Dans l'immédiat, je n'ai rien trouvé d'autre que la sélection manuelle.
Windows 10 Pro 1909 - dt 3.0.2
Répondre
#12
(13-05-19, 16:14)pascalG a écrit :
(13-05-19, 15:41)LViatour a écrit :
(13-05-19, 13:45)pascalG a écrit : Le problème est que la définition de l'objectif n'est pas présente dans les exifs, mais dans les makernotes.

Et donc c'est le boitier qui n'écrit pas au bon endroit les données exifs de l'optique? 

L'optique est corrigée correctement avec les boîtiers en monture F comme le D850 ou mon ancien D5

Le lensIDNumber de votre objectif est 146. Il semble que la lecture des exifs se passe mal puisque le nom de cet objectif n'apparaît pas dans les informations de l'image dans dt ... Si l'info est cherchée dans les zones vides, c'est effectivement un problème de l'ensemble boîtier+FTZ ...
Dans l'immédiat, je n'ai rien trouvé d'autre que la sélection manuelle.

Désolé, mais je n'ai pas trouvé le moyen de modifier ces champs exifs avec aucun des outils dont je dispose.  Undecided

Normalement, le Z7 seul renseigne bien ces champs :

[Image: exifs-Z7-1.jpg]

Je pense donc que c'est la combinaison avec la bague FTZ qui pose ce problème ... j'espère me tromper ...
Maintenant, mes autres logiciels lisent sans problème l'objectif et si Rawtherapee le lit aussi c'est que les développeurs ont du se pencher sur le problème et vont chercher l'info ailleurs ou autrement ...

De mon côté, je ne peux rien d'autre que de permettre la sélection manuelle dans le module de correction de l'objectif grâce au fichier xml ci-dessus. Il est facile d'y ajouter les objectifs nécessaires.
Windows 10 Pro 1909 - dt 3.0.2
Répondre
#13
(13-05-19, 07:34)LViatour a écrit : Bonjour à tous,

Je viens de mettre à jour Lensfun et depuis mon nouveau Nikon Z7 est bien reconnu, idem pour le nouveau 24-70 F4 en monture Z (nouvelle monture Nikon).

Mais la série Z de Nikon (Z6 et Z7) peuvent utiliser toutes les anciennes optiques pour Nikon en monture F via une bague FTZ qui transmet bien les données exifs. Avec cette bague toutes les optiques ont rigoureusement les mêmes caractéristiques que sur un boitier reflex en monture F. 

Mais voilà Lensfun ne fait pas le lien entre les optiques en monture F et Le Nikon Z7. Alors qu'en fait le capteur à les mêmes caractéristiques que le Nikon D850. 

Il faudrait donc un lien entre toutes les optiques en monture F (toutes marques confondues) et le Z7 de la même manière qu'un D850. Mais comment signaler cela aux développeur de Lensfun pour adapter la DB Lensfun et ajouter toute la liste des optiques F à la monture Z car dans les exifs il est bine noté monture Z. 

Il y a quelque-part des développeurs de Lensfun francophone ou un forum Lensfun francophone?

Bonjour à tous,

J'ai un Nikon Z6 avec adaptateur FTZ et un Nikkor AF-S 24-120mm f/4G ED VR, ainsi qu'un télé.
Je suis nouvel utilisateur de Darktable, j'ai installé la version 2.6.2 sur un Mac avec le système Mojave (10.14.6).

Lorsque je vais dans les corrections d'objectifs, mon boitier n'est pas reconnu, mais l'objectif oui si je choisi, par exemple le Nikon D750. Hors dans la BDD Lensfun, la dernière version intègre bien les boitiers Z6 et Z7.
Mon problème est de pouvoir mettre à jour cette bibliothèque, car si j'ai bien compris, sur Mac, l'application contient déjà une BDD de Lensfun, disponible lors de la sortie de la version de DT. En fait on télécharge une application complète avec les librairies intégrées.
Avez-vous une solution pour mettre à jour ces librairies, ou dois-je attendre une nouvelle version de DT, comme la 2.7, et si c'est le cas, quand sort-elle, sur Mac ?

Merci de vos réponses

Comment

Bonjour à tous,

J'ai un Nikon Z6 avec adaptateur FTZ et un Nikkor AF-S 24-120mm f/4G ED VR, ainsi qu'un télé.
Je suis nouvel utilisateur de Darktable, j'ai installé la version 2.6.2 sur un Mac avec le système Mojave (10.14.6).

Lorsque je vais dans les corrections d'objectifs, mon boitier n'est pas reconnu, mais l'objectif oui si je choisi, par exemple le Nikon D750. Hors dans la BDD Lensfun, la dernière version intègre bien les boitiers Z6 et Z7.
Mon problème est de pouvoir mettre à jour cette bibliothèque, car si j'ai bien compris, sur Mac, l'application contient déjà une BDD de Lensfun, disponible lors de la sortie de la version de DT. En fait on télécharge une application complète avec les librairies intégrées.
Avez-vous une solution pour mettre à jour ces librairies, ou dois-je attendre une nouvelle version de DT, comme la 2.7, et si c'est le cas, quand sort-elle, sur Mac ?

Merci de vos réponses
Répondre
#14
(02-10-19, 09:55)Aquecoucou31 a écrit : Bonjour à tous,

J'ai un Nikon Z6 avec adaptateur FTZ et un Nikkor AF-S 24-120mm f/4G ED VR, ainsi qu'un télé.
Je suis nouvel utilisateur de Darktable, j'ai installé la version 2.6.2 sur un Mac avec le système Mojave (10.14.6).

Lorsque je vais dans les corrections d'objectifs, mon boitier n'est pas reconnu, mais l'objectif oui si je choisi, par exemple le Nikon D750. Hors dans la BDD Lensfun, la dernière version intègre bien les boitiers Z6 et Z7.
Mon problème est de pouvoir mettre à jour cette bibliothèque, car si j'ai bien compris, sur Mac, l'application contient déjà une BDD de Lensfun, disponible lors de la sortie de la version de DT. En fait on télécharge une application complète avec les librairies intégrées.
Avez-vous une solution pour mettre à jour ces librairies, ou dois-je attendre une nouvelle version de DT, comme la 2.7, et si c'est le cas, quand sort-elle, sur Mac ?

Merci de vos réponses

Comment

Lensfun est pour les objectifs donc s'ils sont correctement reconnus, une mise à jour n'est pas nécessaire. Le support des boitiers signifie le support des RAW et ça c'est la librairie Rawspeed, intégrée à darktable (pour faire simple, c'est donc lié à une mise à jour de darktable). Le support de tes boitiers est annoncé pour la version 3.0 qui sort à Noël (ou pour être précis il est intégré dans la version de développement, 2.7, actuelle). Voir ici ce qui nous attend dans la version 3.0 qui approche :

https://github.com/darktable-org/darktab...E_NOTES.md

Sauf erreur de ma part, il n'y a dans la 2.6.2 qu'un support très partiel des Z6 et Z7.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#15
Bonjour,
je constate que darktable 3.0 ne gère pas le Z6 correctement :
- le Z6 (et le Z7) sont présents dans le fichier rawspeed
- mais ils n'apparaissent pas dans le module correction des objectifs
- mes 2 objectifs Z (le 85mm f/1.8 et le 24-70 f/4) sont bien reconnus dans le module correction des objectifs,
- mais aucune correction ne s'applique vu qu'il n'y a pas de lien avec le boîtier.
(si je sélectionne un autre boîtier ca ne change rien: pas de correction)
Ce qui est bizarre c'est que pour les premiers tests que j'avais réalisés avec le Z6 il y a une semaine, darktable 2.6.2 appliquait bien des corrections d'objectifs. J'ai malheureusement mis ces tests à la poubelle, donc pas de copie d'écran possible.
Il y aurait une régression dans dt 3.0 ?
Ou bien installation foireuse : j'ai installé la v.3.0 avec le PPA de Panda Jim https://launchpad.net/~ubuntuhandbook1/+.../darktable
Qu'en pensez-vous? Une solution ?
Merci d'avance
Yves
[Image: correction-z-24-70.png]

[Image: correction-z-85.png]

[Image: info-image.png]

[Image: rawspeed.png]
Yves Bornemann
https://ybphoto.weebly.com/
Linux mint 19.3 sur PC - Windows 10 sur laptop.
Darktable 3.0.1
Nikon Z6 + 24-70mm f/4
Répondre
#16
Si tu mets 2 RAW en téléchargement pour que je regarde avec la version master et la version 3.0 que j'ai compilé. Ce que tu montres concerne LensFun et pas darktable, possible que l'install du ce PPA ai écrasé la liblensfun et sa base de données.
Tu pourrais essayer de faire : lensfun-update-data
Répondre
#17
(27-12-19, 11:13)jpg54 a écrit : Si tu mets 2 RAW en téléchargement pour que je regarde avec la version master et la version 3.0 que j'ai compilé. Ce que tu montres concerne LensFun et pas darktable, possible que l'install du ce PPA ai écrasé la liblensfun et sa base de données.
Tu pourrais essayer de faire : lensfun-update-data

Bonjour jpg54 et merci pour ta réponse. C'est résolu !
Oui il y avait un souci avec lensfun. Le lensfun-update-data me disait "commande introuvable". J'ai donc cherché comment (ré)installer lensfun.Tout est rentré dans l'ordre en faisant: sudo /usr/bin/g-lensfun-update-data
Smile 
C'était tout simple mais il fallait qu'on me mette sur la bonne piste, merci beaucoup !
Yves Bornemann
https://ybphoto.weebly.com/
Linux mint 19.3 sur PC - Windows 10 sur laptop.
Darktable 3.0.1
Nikon Z6 + 24-70mm f/4
Répondre
#18
Bonjour à tous,
Je reviens sur le sujet, car je viens d’acquérir le Z6 firmware C 3.0 avec la bague FTZ. Je n'ai pour l'instant que mes objectifs AF-S monture F, donc la bague FTZ est pout le moment à demeure sur le boîtier.
J'ai mis lensfun à jour. J'ai bien le boîtier reconnu, mais toujours pas mes objectifs, que je "monte" de ce fait manuellement. A priori il n'y a pas eu d'évolution du côté de la reconnaissance des objectifs monté sur le FTZ.
Si Luc ou quelqu'un d'autre peu me confirmer cela.
Merci
Répondre
#19
non toutes les optiques montées sur ftz ne sont pas liées au Z6 Z7

Il faut donc manuellement aller chercher l'optiques
Luc Viatour Photographe 
Website
Répondre
#20
Merci Luc, c'est ce que je pensais mais j'ai préféré demander.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)