Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: fabien.l14[résolu] Debian Buster DT ne se lance pas
#1
Bonjour à tous, j'ai voulu installer Darktable pour l'essayer (vu que j'en entends parler un peu partout). Installé depuis le dépôt officiel buster  mais impossible de le lancer. Je sais pas pourquoi, tout c'est installé sans erreur, je le vois dans le moniteur système, il paraît démarré...
J'ai cherché sur le forum et google mais rien trouvé, j'ai mis des infos à la suite qui sont parfois demandées pour résoudre ce genre de problème.
Merci.
Quand je lance darktable sur la console :
fabienl14@debian:~$ darktable
[defaults] found a 64-bit system with 7622832 kb ram and 4 cores (0 atom based)
[defaults] setting high quality defaults
Puis le curseur clignote.
---------------------------------------------
Moniteur sytème :
[Image: Capture-d-cran-de-2019-06-23-14-50-50.png]
---------------------------------------------------
[Image: neofetch.png]

---------------------------------------------------

fabienl14@debian:~$ darktable --version
this is darktable 2.6.0
copyright © 2009-2018 johannes hanika
darktable-dev@lists.darktable.org

compile options:
  bit depth is 64 bit
  normal build
  SSE2 optimized codepath enabled
  OpenMP support enabled
  OpenCL support enabled
  Lua support enabled, API version 5.0.0
  Colord support enabled
  gPhoto2 support enabled
  GraphicsMagick support enabled
  OpenEXR support enabled
--------------------------------------------------
Code :
fabienl14@debian:~$ ldd $(which darktable)
   linux-vdso.so.1 (0x00007ffef09b7000)
   libdarktable.so => /usr/bin/../lib/x86_64-linux-gnu/darktable/libdarktable.so (0x00007f9f7f465000)
   libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f9f7f28a000)
   libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f9f7f269000)
   libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f9f7f0e6000)
   libgomp.so.1 => /lib/x86_64-linux-gnu/libgomp.so.1 (0x00007f9f7f0b5000)
   libglib-2.0.so.0 => /lib/x86_64-linux-gnu/libglib-2.0.so.0 (0x00007f9f7ef96000)
   libgtk-3.so.0 => /lib/x86_64-linux-gnu/libgtk-3.so.0 (0x00007f9f7e8a3000)
   libgdk-3.so.0 => /lib/x86_64-linux-gnu/libgdk-3.so.0 (0x00007f9f7e7a7000)
   libpangocairo-1.0.so.0 => /lib/x86_64-linux-gnu/libpangocairo-1.0.so.0 (0x00007f9f7e797000)
   libpango-1.0.so.0 => /lib/x86_64-linux-gnu/libpango-1.0.so.0 (0x00007f9f7e74c000)
   libcairo.so.2 => /lib/x86_64-linux-gnu/libcairo.so.2 (0x00007f9f7e62c000)
   libgdk_pixbuf-2.0.so.0 => /lib/x86_64-linux-gnu/libgdk_pixbuf-2.0.so.0 (0x00007f9f7e606000)
   libgio-2.0.so.0 => /lib/x86_64-linux-gnu/libgio-2.0.so.0 (0x00007f9f7e446000)
   libgobject-2.0.so.0 => /lib/x86_64-linux-gnu/libgobject-2.0.so.0 (0x00007f9f7e3f1000)
   libxml2.so.2 => /lib/x86_64-linux-gnu/libxml2.so.2 (0x00007f9f7e248000)
   libsoup-2.4.so.1 => /lib/x86_64-linux-gnu/libsoup-2.4.so.1 (0x00007f9f7e1b8000)
   libgphoto2.so.6 => /lib/x86_64-linux-gnu/libgphoto2.so.6 (0x00007f9f7e132000)
   libgphoto2_port.so.12 => /lib/x86_64-linux-gnu/libgphoto2_port.so.12 (0x00007f9f7e124000)
   libIlmImf-2_2.so.23 => /lib/x86_64-linux-gnu/libIlmImf-2_2.so.23 (0x00007f9f7de49000)
   libgmodule-2.0.so.0 => /lib/x86_64-linux-gnu/libgmodule-2.0.so.0 (0x00007f9f7de43000)
   librsvg-2.so.2 => /lib/x86_64-linux-gnu/librsvg-2.so.2 (0x00007f9f7d8db000)
   libsqlite3.so.0 => /lib/x86_64-linux-gnu/libsqlite3.so.0 (0x00007f9f7d7b9000)
   libpng16.so.16 => /lib/x86_64-linux-gnu/libpng16.so.16 (0x00007f9f7d780000)
   libz.so.1 => /lib/x86_64-linux-gnu/libz.so.1 (0x00007f9f7d562000)
   libjpeg.so.62 => /lib/x86_64-linux-gnu/libjpeg.so.62 (0x00007f9f7d2f7000)
   libtiff.so.5 => /lib/x86_64-linux-gnu/libtiff.so.5 (0x00007f9f7d278000)
   liblcms2.so.2 => /lib/x86_64-linux-gnu/liblcms2.so.2 (0x00007f9f7d21b000)
   libjson-glib-1.0.so.0 => /lib/x86_64-linux-gnu/libjson-glib-1.0.so.0 (0x00007f9f7d1f1000)
   libexiv2.so.14 => /lib/x86_64-linux-gnu/libexiv2.so.14 (0x00007f9f7cd43000)
   libopenjp2.so.7 => /lib/x86_64-linux-gnu/libopenjp2.so.7 (0x00007f9f7ccec000)
   libsecret-1.so.0 => /lib/x86_64-linux-gnu/libsecret-1.so.0 (0x00007f9f7cc96000)
   libGraphicsMagick-Q16.so.3 => /lib/libGraphicsMagick-Q16.so.3 (0x00007f9f7c999000)
   liblua5.3.so.0 => /lib/x86_64-linux-gnu/liblua5.3.so.0 (0x00007f9f7c95f000)
   libpugixml.so.1 => /lib/x86_64-linux-gnu/libpugixml.so.1 (0x00007f9f7c923000)
   libcolord.so.2 => /lib/x86_64-linux-gnu/libcolord.so.2 (0x00007f9f7c8d0000)
   libcolord-gtk.so.1 => /lib/x86_64-linux-gnu/libcolord-gtk.so.1 (0x00007f9f7c6c9000)
   libcups.so.2 => /lib/x86_64-linux-gnu/libcups.so.2 (0x00007f9f7c634000)
   libstdc++.so.6 => /lib/x86_64-linux-gnu/libstdc++.so.6 (0x00007f9f7c4b0000)
   libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f9f7c496000)
   /lib64/ld-linux-x86-64.so.2 (0x00007f9f7f760000)
   libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f9f7c491000)
   libpcre.so.3 => /lib/x86_64-linux-gnu/libpcre.so.3 (0x00007f9f7c41d000)
   libX11.so.6 => /lib/x86_64-linux-gnu/libX11.so.6 (0x00007f9f7c2da000)
   libXi.so.6 => /lib/x86_64-linux-gnu/libXi.so.6 (0x00007f9f7c0ca000)
   libXcomposite.so.1 => /lib/x86_64-linux-gnu/libXcomposite.so.1 (0x00007f9f7bec7000)
   libXdamage.so.1 => /lib/x86_64-linux-gnu/libXdamage.so.1 (0x00007f9f7bec2000)
   libXfixes.so.3 => /lib/x86_64-linux-gnu/libXfixes.so.3 (0x00007f9f7bcbc000)
   libcairo-gobject.so.2 => /lib/x86_64-linux-gnu/libcairo-gobject.so.2 (0x00007f9f7bcb0000)
   libatk-1.0.so.0 => /lib/x86_64-linux-gnu/libatk-1.0.so.0 (0x00007f9f7bc85000)
   libatk-bridge-2.0.so.0 => /lib/x86_64-linux-gnu/libatk-bridge-2.0.so.0 (0x00007f9f7bc50000)
   libxkbcommon.so.0 => /lib/x86_64-linux-gnu/libxkbcommon.so.0 (0x00007f9f7bc0e000)
   libwayland-cursor.so.0 => /lib/x86_64-linux-gnu/libwayland-cursor.so.0 (0x00007f9f7bc04000)
   libwayland-egl.so.1 => /lib/x86_64-linux-gnu/libwayland-egl.so.1 (0x00007f9f7bbff000)
   libwayland-client.so.0 => /lib/x86_64-linux-gnu/libwayland-client.so.0 (0x00007f9f7bbee000)
   libepoxy.so.0 => /lib/x86_64-linux-gnu/libepoxy.so.0 (0x00007f9f7baba000)
   libharfbuzz.so.0 => /lib/x86_64-linux-gnu/libharfbuzz.so.0 (0x00007f9f7b9bf000)
   libpangoft2-1.0.so.0 => /lib/x86_64-linux-gnu/libpangoft2-1.0.so.0 (0x00007f9f7b9a6000)
   libfontconfig.so.1 => /lib/x86_64-linux-gnu/libfontconfig.so.1 (0x00007f9f7b960000)
   libfreetype.so.6 => /lib/x86_64-linux-gnu/libfreetype.so.6 (0x00007f9f7b8a4000)
   libXinerama.so.1 => /lib/x86_64-linux-gnu/libXinerama.so.1 (0x00007f9f7b89d000)
   libXrandr.so.2 => /lib/x86_64-linux-gnu/libXrandr.so.2 (0x00007f9f7b692000)
   libXcursor.so.1 => /lib/x86_64-linux-gnu/libXcursor.so.1 (0x00007f9f7b685000)
   libXext.so.6 => /lib/x86_64-linux-gnu/libXext.so.6 (0x00007f9f7b473000)
   librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f9f7b469000)
   libthai.so.0 => /lib/x86_64-linux-gnu/libthai.so.0 (0x00007f9f7b45e000)
   libfribidi.so.0 => /lib/x86_64-linux-gnu/libfribidi.so.0 (0x00007f9f7b43f000)
   libpixman-1.so.0 => /lib/x86_64-linux-gnu/libpixman-1.so.0 (0x00007f9f7b399000)
   libxcb-shm.so.0 => /lib/x86_64-linux-gnu/libxcb-shm.so.0 (0x00007f9f7b394000)
   libxcb.so.1 => /lib/x86_64-linux-gnu/libxcb.so.1 (0x00007f9f7b36a000)
   libxcb-render.so.0 => /lib/x86_64-linux-gnu/libxcb-render.so.0 (0x00007f9f7b35b000)
   libXrender.so.1 => /lib/x86_64-linux-gnu/libXrender.so.1 (0x00007f9f7b151000)
   libmount.so.1 => /lib/x86_64-linux-gnu/libmount.so.1 (0x00007f9f7b0f0000)
   libselinux.so.1 => /lib/x86_64-linux-gnu/libselinux.so.1 (0x00007f9f7aec8000)
   libresolv.so.2 => /lib/x86_64-linux-gnu/libresolv.so.2 (0x00007f9f7aeae000)
   libffi.so.6 => /lib/x86_64-linux-gnu/libffi.so.6 (0x00007f9f7aea4000)
   libicui18n.so.63 => /lib/x86_64-linux-gnu/libicui18n.so.63 (0x00007f9f7abc9000)
   libicuuc.so.63 => /lib/x86_64-linux-gnu/libicuuc.so.63 (0x00007f9f7a9f8000)
   libicudata.so.63 => /lib/x86_64-linux-gnu/libicudata.so.63 (0x00007f9f79008000)
   liblzma.so.5 => /lib/x86_64-linux-gnu/liblzma.so.5 (0x00007f9f78fe0000)
   libgssapi_krb5.so.2 => /lib/x86_64-linux-gnu/libgssapi_krb5.so.2 (0x00007f9f78f93000)
   libpsl.so.5 => /lib/x86_64-linux-gnu/libpsl.so.5 (0x00007f9f78f80000)
   libltdl.so.7 => /lib/x86_64-linux-gnu/libltdl.so.7 (0x00007f9f78f75000)
   libexif.so.12 => /lib/x86_64-linux-gnu/libexif.so.12 (0x00007f9f78f2e000)
   libImath-2_2.so.23 => /lib/x86_64-linux-gnu/libImath-2_2.so.23 (0x00007f9f78d1a000)
   libHalf.so.23 => /lib/x86_64-linux-gnu/libHalf.so.23 (0x00007f9f78ad7000)
   libIex-2_2.so.23 => /lib/x86_64-linux-gnu/libIex-2_2.so.23 (0x00007f9f788b7000)
   libIlmThread-2_2.so.23 => /lib/x86_64-linux-gnu/libIlmThread-2_2.so.23 (0x00007f9f786b0000)
   libcroco-0.6.so.3 => /lib/x86_64-linux-gnu/libcroco-0.6.so.3 (0x00007f9f78672000)
   libwebp.so.6 => /lib/x86_64-linux-gnu/libwebp.so.6 (0x00007f9f78407000)
   libzstd.so.1 => /lib/x86_64-linux-gnu/libzstd.so.1 (0x00007f9f78367000)
   libjbig.so.0 => /lib/x86_64-linux-gnu/libjbig.so.0 (0x00007f9f78159000)
   libexpat.so.1 => /lib/x86_64-linux-gnu/libexpat.so.1 (0x00007f9f7811c000)
   libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f9f77ffe000)
   libwebpmux.so.3 => /lib/x86_64-linux-gnu/libwebpmux.so.3 (0x00007f9f77df2000)
   libwmflite-0.2.so.7 => /lib/x86_64-linux-gnu/libwmflite-0.2.so.7 (0x00007f9f77dd2000)
   libSM.so.6 => /lib/x86_64-linux-gnu/libSM.so.6 (0x00007f9f77dc7000)
   libICE.so.6 => /lib/x86_64-linux-gnu/libICE.so.6 (0x00007f9f77baa000)
   libbz2.so.1.0 => /lib/x86_64-linux-gnu/libbz2.so.1.0 (0x00007f9f77b97000)
   libudev.so.1 => /lib/x86_64-linux-gnu/libudev.so.1 (0x00007f9f77b6f000)
   libcolordprivate.so.2 => /lib/x86_64-linux-gnu/libcolordprivate.so.2 (0x00007f9f77b3b000)
   libgthread-2.0.so.0 => /lib/x86_64-linux-gnu/libgthread-2.0.so.0 (0x00007f9f77b36000)
   libgnutls.so.30 => /lib/x86_64-linux-gnu/libgnutls.so.30 (0x00007f9f7798a000)
   libavahi-common.so.3 => /lib/x86_64-linux-gnu/libavahi-common.so.3 (0x00007f9f7797c000)
   libavahi-client.so.3 => /lib/x86_64-linux-gnu/libavahi-client.so.3 (0x00007f9f77969000)
   libdbus-1.so.3 => /lib/x86_64-linux-gnu/libdbus-1.so.3 (0x00007f9f77914000)
   libatspi.so.0 => /lib/x86_64-linux-gnu/libatspi.so.0 (0x00007f9f778e0000)
   libgraphite2.so.3 => /lib/x86_64-linux-gnu/libgraphite2.so.3 (0x00007f9f778b3000)
   libuuid.so.1 => /lib/x86_64-linux-gnu/libuuid.so.1 (0x00007f9f778aa000)
   libdatrie.so.1 => /lib/x86_64-linux-gnu/libdatrie.so.1 (0x00007f9f7789e000)
   libXau.so.6 => /lib/x86_64-linux-gnu/libXau.so.6 (0x00007f9f7769a000)
   libXdmcp.so.6 => /lib/x86_64-linux-gnu/libXdmcp.so.6 (0x00007f9f77494000)
   libblkid.so.1 => /lib/x86_64-linux-gnu/libblkid.so.1 (0x00007f9f7743f000)
   libkrb5.so.3 => /lib/x86_64-linux-gnu/libkrb5.so.3 (0x00007f9f7735f000)
   libk5crypto.so.3 => /lib/x86_64-linux-gnu/libk5crypto.so.3 (0x00007f9f77329000)
   libcom_err.so.2 => /lib/x86_64-linux-gnu/libcom_err.so.2 (0x00007f9f77323000)
   libkrb5support.so.0 => /lib/x86_64-linux-gnu/libkrb5support.so.0 (0x00007f9f77314000)
   libkeyutils.so.1 => /lib/x86_64-linux-gnu/libkeyutils.so.1 (0x00007f9f7730d000)
   libidn2.so.0 => /lib/x86_64-linux-gnu/libidn2.so.0 (0x00007f9f772ee000)
   libunistring.so.2 => /lib/x86_64-linux-gnu/libunistring.so.2 (0x00007f9f7716a000)
   libgpg-error.so.0 => /lib/x86_64-linux-gnu/libgpg-error.so.0 (0x00007f9f77145000)
   libbsd.so.0 => /lib/x86_64-linux-gnu/libbsd.so.0 (0x00007f9f7712b000)
   libp11-kit.so.0 => /lib/x86_64-linux-gnu/libp11-kit.so.0 (0x00007f9f76ffc000)
   libtasn1.so.6 => /lib/x86_64-linux-gnu/libtasn1.so.6 (0x00007f9f76de9000)
   libnettle.so.6 => /lib/x86_64-linux-gnu/libnettle.so.6 (0x00007f9f76db1000)
   libhogweed.so.4 => /lib/x86_64-linux-gnu/libhogweed.so.4 (0x00007f9f76d76000)
   libgmp.so.10 => /lib/x86_64-linux-gnu/libgmp.so.10 (0x00007f9f76cf3000)
   libsystemd.so.0 => /lib/x86_64-linux-gnu/libsystemd.so.0 (0x00007f9f76c52000)
   liblz4.so.1 => /lib/x86_64-linux-gnu/liblz4.so.1 (0x00007f9f76c33000)
Répondre
#2
Bonjour fabien.l14 ,

Nous avons bien pris en compte votre question, comme pour tous les nouveaux accédants au forum,  nous vous suggérons plusieurs actions :

1- Une lecture du règlement du forum ( il est vite lu ): https://darktable.fr/reglement-du-forum/

2- Présentez-vous ici : https://forums.darktable.fr/forumdisplay.php?fid=86
donnez aussi des indications sur votre matériel photo et informatique ainsi que votre version d'OS ou de Windows et version darktable. Vous serez bien accueilli [Image: smile.png]

3- Consultez toutes les rubriques du site darktable : https://darktable.fr/

4- Indispensable, la lecture du manuel de darktable : https://darktable.fr/les-manuels/   Vous y trouverez certainement la réponse à votre question.

5- Faire une recherche poussée sur le forum de darktable et le moteur de recherche d'internet.

Si après avoir fait toutes ces opérations, vous n'avez toujours pas de solution, alors nous serons heureux de répondre à vos questions.

Ceci est une réponse standard, mais pour l'installation, je préconise de passer par le site de darktable. Je ne suis pas spécialiste en installation, mais je pense à priori que le problème vient de là.

Il faudrait aussi pour rendre le forum plus concis, mettre tout le code du message précédent entre balises codes. Merci

Cordialement.
Répondre
#3
Salut JMM40, j'ai suivi tes conseils mais rien n'y fait. J'ai essayé la commande : darktable -d opencl mais même résultat.
J'ai désinstallé et remis depuis le dépôt sur darktable.org et darktable.fr.
«debian
(Of course) there is a darktable package in the Debian repositories.
darktable can be installed by running
sudo apt-get install darktable
If you need a newer version than what is included in your distribution, check out the third party packages section».
Idem.
Répondre
#4
Merci pour le suivi des consignes, mais je laisse de plus qualifiés que moi, te répondre sur ce sujet.
Le forum étant un peu en vacances, ça va peut-être demander un peu plus de temps que d'habitude. [Image: blush.png]

Je rappelle que la version stable de darktable est actuellement la 2.6.2.
Répondre
#5
Bonjour Fabien,

Merci à toi en effet pour ton suivi des quelques petites consignes et ta présentation.

Il n'y a pas de message d'erreur de ce que je vois sur ce que tu postes, pas simple de comprendre d'où ça vient. C'est peut-être le paquet que tu as installé qui déconne sur ta machine. Comme le dit JMM, la version stable actuelle est la 2.6.2, si elle n'est pas encore dans le dépôt Debian, je te recommande d'installer darktable 2.6.2 depuis l'un des dépôts tiers présentés sur le site officiel de darktable : https://www.darktable.org/install/#3rdparty

Rassure toi, que ce soit le packet de pmdebruijn ou celui d'OpenSuse, c'est du sérieux et sûr pour ton install !
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#6
C'est quoi ta carte graphique? As-tu essayé de désactiver OpenCL?

Code :
$ darktable --disable-opencl
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#7
Je prends note de vos conseils merci. Je suis actuellement en déplacement, j'essaierai ça samedi et reviendrai vous dire si ça fonctionne.
Répondre
#8
Thumbs Up 
Bonjour, je viens d'essayer ce matin avec la commande $ darktable --disable-opencl.
Darktable a démarré en un éclair Wink .
Merci à vous tous et particulièrement à toi pascal, je vais enfin pouvoir m'essayer à ce logiciel Cool .
Répondre
#9
bonjour à tous, j'ai trouvé d'où vient le problème, en fait, lors de l'installation des drivers de la carte graphique, j'avais suivi ce tuto :
https://linuxconfig.org/how-to-install-t...-10-buster
J'avais installé le paquet mesa-opencl-icd. En le désinstallant, tout est redevenu normal Smile .

Voilà, si ça peut aider certain
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)