Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: kdfx[Résolu] Utilisation simultannée de Darktable 2.6.2 et 2.2.4
#1
Salut,

j'ai un petit cas de conscience,

sur mon pc, je souhaite utiliser 2 distributions GNU/Linux différentes :
AVLinux : basée sur Debian 9 avec Darktable en version 2.2
ArchLinux : avec Darktable 2.6.2

mes photos se trouvent sur un disque dédié aux photos auquel les 2 systèmes auront accès

y a -t-il un risque particulier si j'édite alternativement mes photos avec l'une et l'autre version de Darktable?
Je me doute que les modules uniquement dispo sur la version plus récente ne s'afficheront pas sur la plus ancienne, mais, si j'édite avec la plus ancienne une photo déjà retouchée, perdrais-je certains réglages?
Répondre
#2
> y a -t-il un risque particulier si j'édite alternativement mes photos avec l'une et l'autre version de Darktable?

oui, DANGER.

De version en version, certains modules évoluent et changent la base de données. darktable 2.6 sait quoi faire avec une base de données 2.4 ou 2.2 (il va la récupérer et la mettre à jour), mais darktable 2.2 ou 2.4 ne savent pas comment gérer la base de données 2.6. Du coup, si tu t'amuses à éditer simultanément sur 2 versions, tu vas mettre un boxon monstrueux dans ta base de données et tes XMP (en plus de perdre certains réglages).
Aurélien, photographe portraitiste sur Nancy-Metz
Développeur de filmique.
Dérive de couleur ? Désactivez courbe de base.
Halos clairs ? Désactivez ombres & hautes lumières.
Répondre
#3
En general une version ancienne de dt va simplement refuser d'ouvrir une base de données ou une image créée avec une version récente.

Par contre, rien ne t'empêche d'installer un dt recent sur la distro qui n'a par défaut qu'un vieux dt...
Répondre
#4
Merci pour les mises en garde, je vais donc éviter les «problèmes»
Répondre
#5
(05-08-19, 13:01)kdfx a écrit : Merci pour les mises en garde, je vais donc éviter les «problèmes»

Le plus simple est d'utiliser la même version (la plus récente, 2.6.2) sur tes 2 ordis. Il te suffit d'utiliser, par exemple, ce dépôt pour l'installer : https://software.opensuse.org/package/darktable
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#6
Merci pour le lien, je ferai un test.
Mon problème est que AVLinux est une distribution pour musicien orientée temps réel particulièrement bien optimisée, et ce d'une manière assez pointue, c'est pourquoi je suis assez frileux… cependant Darktable mérite bien cette exception.

Je vous tiens au courant...
Répondre
#7
(05-08-19, 18:15)nicoauffray a écrit : Le plus simple est d'utiliser la même version (la plus récente, 2.6.2) sur tes 2 ordis. Il te suffit d'utiliser, par exemple, ce dépôt pour l'installer : https://software.opensuse.org/package/darktable

donc j'ai trouvé un .deb de Darktable 2.6.2 pour Debian 9,


pour l'installer, gdebi me signale la nécessité d'installer 1 paquet : liblua5.3-0

avec synaptic, je vois que j'ai déjà liblua5.2-0 qui est installé,
ça signifie que ce sera le seul paquet mis à jour (autre que darktable), je peux supposer que ce changement «minime» n'aura pas d'impact sur la stabilité global du système n'est-ce pas ?
Répondre
#8
Peut-être avec le paquet de Pascal De Bruijn : https://launchpad.net/~pmjdebruijn/+arch...le-release !
Répondre
#9
Par l'intermédiaire du lien opensuse, j'ai choisi dans Debian 9 - Communauté

tangerine:deb9-xfce-4.12

mon système utilisant xfce, ça semblait tout indiqué

je viens de l'installer, tout à l'air parfait !
je pourrai donc utiliser mes 2 systèmes avec le même disque Photos…

C'est génial, merci à tous !
Une tempête de Liberté est en train de souffler dans mon studio ;-)
Répondre
#10
Petit point d'information concernant lua : en principe les deux versions coexistent sur une machine. Un peu comme les multiples versions de Python
Mes photos : jpverrue.fr
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)