Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: thomasbordaldeaOuverture impossible des disques amovibles
#1
Bonjour,

Je viens de passer de la version 2.4 à la 2.6.2.

Lorsque j'ai voulu ouvrir un dossier sur l'un de mes disques durs, aucun n'était accessible via l'onglet "Other locations" que j'utilisais avec l'ancienne version.

Si j'essaie d'ouvrir Darktable à partir d'un dossier, ce message d'erreur s'affiche :

/home/utilisateur/snap/darktable/38/data.db
"Le fichier de verrouillage de la base contient un numéro de process actif sur votre système "2221""

Du coup, je ne peux plus travailler.

Ubuntu 16.04 LTS.

Je ne suis pas une lumière en informatique ;(

Quelqu'un a-t-il rencontré ce problème et pourrait m'aider ?

Merci de vos contributions
Répondre
#2
Bonjour,

Une simple recherche permet de trouver facilement la réponse à ton problème (plusieurs posts en parlent). Une recherche avec le mot "lock" par exemple donne :

https://forums.darktable.fr/showthread.p...light=lock
https://forums.darktable.fr/showthread.p...light=lock

En bref, cela signifie que darktable a un moment n'a pas été fermé correctement (la base est restée verrouillée, processus normal pour éviter de lancer 2 instances de darktable par erreur). Tu trouveras plus de détails et comment résoudre ton problème sur les liens proposés.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#3
Bonjour,

Je te remercie pour ces liens. Le second est beaucoup trop technique pour moi.

Après avoir installé la version 2.6.2 sur Ubuntu, le logiciel n'a pas reconnu les disques externes. Puis, sans que je sache pourquoi et malgré plusieurs  tentatives infructueuses en ce sens, tout d'un coup il a accepté d'ouvrir des dossiers directement avec un clic droit sur ceux-ci depuis leur emplacement sur DD externe. L'importation n'a jamais fonctionné. La communauté Ubuntu s'est penché sans réel succès sur la question. J'ai donc réinstallé la version 2.4.4. Je n'arrive pas à comprendre pourquoi on ne peut pas télécharger une 2.6 stable. Mais j'ai vu que les liens présent sur Dartable.fr pour installer celle-ci étaient tous gelés.

D'autre part, j'ai aussi installé la 2.6.2 sur mon MacBook pro et là plus rien ne marche. Donc, idem, retour vers la 2.4.4.

Je vais gratter ici pour voir si certains parviennent à faire fonctionner sans problème la 2.6. Ça m'arrangerait beaucoup, car sinon ça veut dire que j'ai imprimé pour rien les 250 pages du manuel en français de l'appli.

Que du bonheur ! Impossible de faire fonctionner la 2.4.4 sur le mac. Le téléchargement fonctionne, l'ouverture forcée ne donne rien. Je craque.
Répondre
#4
(19-09-19, 13:33)thomasbordaldea a écrit : [...]

Après avoir installé la version 2.6.2 sur Ubuntu, le logiciel n'a pas reconnu les disques externes.

[...]

Je vais gratter ici pour voir si certains parviennent à faire fonctionner sans problème la 2.6. Ça m'arrangerait beaucoup, car sinon ça veut dire que j'ai imprimé pour rien les 250 pages du manuel en français de l'appli.

Perso je suis aussi sur la v2.6.2 est elle fonctionne parfaitement bien (par contre sur la distribution Fedora 30).

Peut-être que tu devrais essayer d’exécuter darktable en ligne de commande (pour analyser c'est mieux) :
$ darktable -d all


(J'espère que tu vas trouver)

Par contre je partage ton avis sur le fait qu'il n'était pas nécessaire d'imprimer les 250 pages du manuel. Pour deux raisons : il évolue; et c'est plus rapide de faire des recherches sur un fichier PDF.
$ one beer please
Erreur...
$ sudo one beer please
$


Répondre
#5
(19-09-19, 23:06)StephR a écrit :
(19-09-19, 13:33)thomasbordaldea a écrit : [...]

Après avoir installé la version 2.6.2 sur Ubuntu, le logiciel n'a pas reconnu les disques externes.

[...]

Je vais gratter ici pour voir si certains parviennent à faire fonctionner sans problème la 2.6. Ça m'arrangerait beaucoup, car sinon ça veut dire que j'ai imprimé pour rien les 250 pages du manuel en français de l'appli.

Perso je suis aussi sur la v2.6.2 est elle fonctionne parfaitement bien (par contre sur la distribution Fedora 30).

Peut-être que tu devrais essayer d’exécuter darktable en ligne de commande (pour analyser c'est mieux) :
$ darktable -d all


(J'espère que tu vas trouver)

Par contre je partage ton avis sur le fait qu'il n'était pas nécessaire d'imprimer les 250 pages du manuel. Pour deux raisons : il évolue; et c'est plus rapide de faire des recherches sur un fichier PDF.
Merci, 
Je vais essayer ça demain.
Répondre
#6
Bonjour thomasbordaldea
Je travaille avec la version 2.6.2 de darktable sous Ubuntu 18.04.3 LTS, je n'ai aucun problème dans l'utilisation depuis le début de l'année avec cette version qui est vraiment plus finie que les précédentes notamment avec le module filmique qui est une merveille pour moi.
As-tu installé la bonne version de darktable, sur le bon site ? Je remarque en passant qu'il y a eu des changements sur le site de darktable dans l'onglet installer et que ce n'est vraiment pas clair du-tout pour un débutant.
Je serai moi-même assez embarrassé s'il fallait que je réinstalle.
J'espère que le site va vite reprendre un aspect plus convivial à ce niveau! [Image: blush.png]
Répondre
#7
Bonjour JMM40 et StephR

Je vous remercie pour vos messages encourageants. Dans l'immédiat pour pouvoir travailler, je suis retourné à la version 2.4.4. Mais j'ai un problème, j'ai installé sur mon MacBook pro la v.6.2.2. Je rencontre le même problème avec l'ouverture des disques externes, mais c'était déjà le cas avec la v2.4.4 : impossible d'y accéder par +others locations.

J'ai voulu harmoniser et redescendre en 2.4.4, mais je n'y parviens pas. Je charge depuis Darktable.org, installe le logiciel mais celui-ci ne se lance plus.

Avec la ligne de commande que m'a donné StephR la 2.4.4 se lance bien sous Ubuntu. Je vais faire une autre tentative pour essayer d'upgrader et voir comment ça fonctionne. Il y a aussi la solution que je passe à Ubuntu 18.04. Je vais tenter plusieurs essais.

C'est vrai qu'il y a un problème pour trouver le lien de téléchargement : le site français, ici, semble avoir gelé tous les liens d'accès pour rediriger sur Darktable.org. Vu mon niveau en informatique, je joue un peu à l'apprenti sorcier...on verra bien
Répondre
#8
La 2.6.x (quelque soit sa version mineure) fonctionne très bien sous Linux, même Ubuntu (je l'ai utilisé il y a plusieurs mois de ça sans problème avant de ne plus utiliser aujourd'hui que la version master (de développement). Quel paquet utilise-tu (pour être plus précis, depuis quelle source) ?

Si tu récupère la 2.6.2 depuis le dépôt ppa de pmdebruijn ou Opensuse (liens sur la page download/third party repositories sur darktable.org), normalement ça devrait fonctionner.

Et attention, tu ne peux pas utiliser une base de données de darktable avec tes options d'une version ouverte (et donc mise à jour) en version 2.6 depuis une 2.4. L'inverse est possible, mais une seule fois (puisqu'ensuite c'est migré vers la 2.6). A chaque version majeure, même scénario (ce sera aussi le cas entre la prochaine 3.0 et toutes versions antérieures).
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#9
Bon, en fait ça y est.

J'ai désinstallé la version 2.4 puis je suis allé récupérer les paquets de la 2.6.2 ici :

https://software.opensuse.org/download.h...=darktable

Au lancement, contrairement à la première fois, les disques externes sont reconnus. Il n'y a plus qu'à tester sur le long terme.

Maintenant il faut que je règle problème avec le MacBook pro : les disques externes n'apparaissent pas sous "+other locations". Je ne sais pas trop où aller chercher pour résoudre ça. Un petit coup de pouce serait le bienvenu. (système d'exploitation Mac OS High Sierra)

Je vous remercie tous pour votre aide et votre soutien,

Thomas
Répondre
#10
(20-09-19, 14:18)thomasbordaldea a écrit : […]
Maintenant il faut que je règle problème avec le MacBook pro : les disques externes n'apparaissent pas sous "+other locations". Je ne sais pas trop où aller chercher pour résoudre ça. Un petit coup de pouce serait le bienvenu. (système d'exploitation Mac OS High Sierra)

Je vous remercie tous pour votre aide et votre soutien,

Thomas
Bonjour,

est-ce que tu vois dans la liste des dossiers un dossier nommé "/", juste une barre oblique.
L'ouvrir, puis ouvrir le dossier "Volumes". En principe, tes disques externes apparaissent à ce niveau.
Sur l'établi : Images de rêves – des images, des textes
Quelques outils :
— Reflex Pentax, numérique et argentique
— MacBook Pro mid-2010, OS 10.10.5
— Darktable 2.6.2, Lightroom 6.x pour quelque temps encore
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)