Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: LViatourinstallation 2.7 sur Ubuntu problème compilation
#11
Je ne vois pas pourquoi utiliser Docker pour compiler alors que sous Ubuntu ou Mint la compilation directe va très bien.
Répondre
#12
@nicoauffray, Malheureusement, ça ne fonctionne pas:

Code :
michou@michou-Aspire-M3985:~$ sudo apt install llvm9 llvm9-dev
[sudo] Mot de passe de michou :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet llvm9
E: Impossible de trouver le paquet llvm9-dev

@jpg54 comme je l'ai déjà dit plusieurs fois, je ne suis pas à l'aise avec les procédures, et docker avec le tuto de rawfiner, me permet simplement de compiler et de suivre l'évolution de DT. De plus il me semble avoir vu sur la branche Master ceci:
CMakeLists.txt
CI: bump LLVM from 7 to 9
11 days ago
J'avoue mon ignorance sur ce que cela implique, mais y-a-t-il une relation??
En attendant, ayant aussi un poste sur W10, j'ai récupéré une compilation récente de la 2.7, et j'ai pu constaté le bon en avant pour la gestion du bruit effectuée par notre ami @rawfiner.
Répondre
#13
(17-10-19, 14:32)mimi85 a écrit : @nicoauffray, Malheureusement, ça ne fonctionne pas:

Code :
michou@michou-Aspire-M3985:~$ sudo apt install llvm9 llvm9-dev
[sudo] Mot de passe de michou :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet llvm9
E: Impossible de trouver le paquet llvm9-dev

@jpg54 comme je l'ai déjà dit plusieurs fois, je ne suis pas à l'aise avec les procédures, et docker avec le tuto de rawfiner, me permet simplement de compiler et de suivre l'évolution de DT. De plus il me semble avoir vu sur la branche Master ceci:
CMakeLists.txt
CI: bump LLVM from 7 to 9
11 days ago
J'avoue mon ignorance sur ce que cela implique, mais y-a-t-il une relation??
En attendant, ayant aussi un poste sur W10, j'ai récupéré une compilation récente de la 2.7, et j'ai pu constaté le bon en avant pour la gestion du bruit effectuée par notre ami @rawfiner.
On peut te faire un fichier avec toutes les étapes pour compiler directement sous Ubuntu.
Répondre
#14
@jpg54, Oui c'est une bonne idée, au même titre qu'il y a les fichiers de configuration dans l'onglet DOC, il pourrait y avoir marche à suivre pour compiler (outils nécessaires et procédure). Ce serait une évolution positive pour les novices comme je le suis, qui se trouvent démunis dès qu'il y a une "dépendance" non satisfaite.
Répondre
#15
J'avais déjà fait un PDF : https://docs.google.com/document/d/1Cjny...eND80/edit qui est maintenant obsolète avec l'utilisation de GitHub. Après je peux le refaire pour Ubuntu mais il faut savoir qu'il ne peut fonctionner avec toutes les distributions.
Répondre
#16
(18-10-19, 06:53)jpg54 a écrit : J'avais déjà fait un PDF : https://docs.google.com/document/d/1Cjny...eND80/edit qui est maintenant obsolète avec l'utilisation de GitHub. Après je peux le refaire pour Ubuntu mais il faut savoir qu'il ne peut fonctionner avec toutes les distributions.

Il me sert personnellement encore, j'ai compilé une version pour mon fils et pour un collègue tous les deux sur Ubuntu 18.04.

C'est une bonne base il y a juste quelques dépendances manquantes. 

Voici mon mémo basé sur ton PDF:

Compilation github master Darktabe

installer les paquets suivants:
ibsqlite3 libjpeg libpng libpugixml rawspeed gtk+-3 cairo lcms2 exiv2 tiff curl gphoto2 dbus-glib fop openexr libsoup2.4

gcc

gcc g++ cmake intltool xsltproc libgtk-3-dev libxml2-utils libxml2-dev

liblensfun-dev librsvg2-dev libsqlite3-dev libcurl4-gnutls-dev libjpeg-dev libtiff5-dev

liblcms2-dev libjson-glib-dev libexiv2-dev libpugixml-dev


gphoto2 library

create /home/user
/darktable


root:
git clone git://github.com/darktable-org/darktable.git

dans dossier darktable
compilation : ./build.sh

Voir dépendances bloquantes 

git submodule init
git submodule update

Si compillation ok

cmake --build "/home/lviatour/darktable/build" --target install -- -j8


création du lanceur:

sudo apt-get install gnome-panel

gnome-desktop-item-edit --create-new home/user/Bureau

configurer le lanceur sur:
/opt/darktable/bin/darktable
Luc Viatour Photographe 
Website
Répondre
#17
merci de vous interesser à mon PB.
Depuis ma dernière intervention, j'ai réglé "tout seul" le problème de connexion docker deamon, en suivant ce tuto:
https://stackoverflow.com/questions/5329...untu-18-04

Mais ce que je redoutais, que j'avais vu sur mon poste Lubuntu, c'est le Pb de llvm9, et il est arrivé. J'ai donc installé cette bibliothèque par Install
(stable branch):
https://apt.llvm.org/

et là je suis encore bloqué par l'absence d'un fichier "lit-cpuid". En faisant des recherches je suis tombé sur:
https://bugs.debian.org/cgi-bin/bugrepor...bug=941306
de notre ami Roman Lebedev

Juste une question, Comment se fait-il que vous n'avait pas ce problème car je pense que c'est indépendant de docker.

La je pars en réunion club photo, je verrais à mon retour.
Répondre
#18
(17-10-19, 14:32)mimi85 a écrit : @nicoauffray, Malheureusement, ça ne fonctionne pas:

Code :
michou@michou-Aspire-M3985:~$ sudo apt install llvm9 llvm9-dev
[sudo] Mot de passe de michou :
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
E: Impossible de trouver le paquet llvm9
E: Impossible de trouver le paquet llvm9-dev

Ca, ça veut simplement dire que ces paquets ne sont pas trouvés dans les dépôts de paquets que tu as. Je vois que tu as Ubuntu 18.04 et j'utilise Ubuntu 19.10 (où j'ai bien ces 2 paquets), le lien est là. Ubuntu 18.04 doit sûrement être resté sur llvm8 (ou 7).

(18-10-19, 14:35)mimi85 a écrit : merci de vous interesser à mon PB.
Depuis ma dernière intervention, j'ai réglé "tout seul" le problème de connexion docker deamon, en suivant ce tuto:
https://stackoverflow.com/questions/5329...untu-18-04

Mais ce que je redoutais, que j'avais vu sur mon poste Lubuntu, c'est le Pb de llvm9, et il est arrivé. J'ai donc installé cette bibliothèque par Install
(stable branch):
https://apt.llvm.org/

et là je suis encore bloqué par l'absence d'un fichier "lit-cpuid". En faisant des recherches je suis tombé sur:
https://bugs.debian.org/cgi-bin/bugrepor...bug=941306
de notre ami Roman Lebedev

Juste une question, Comment se fait-il que vous n'avait pas ce problème car je pense que c'est indépendant de docker.

La je pars en réunion club photo, je verrais à mon retour.

As-tu bien récupéré (et installé) le paquet "dev", soit llvm9-dev ? Pour compiler, les paquets avec complément -dev sont indispensables.

Pour compiler darktable, sans passer par Docker je précise, j'utilise cette page (en anglais mais facile à suivre) et m'assurer d'avoir tous les paquets nécessaires (installer aussi les paquets optionnels est recommandé, sinon risque de ne pas avoir certaines parties de darktable) : https://redmine.darktable.org/projects/d...rktable_26
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#19
Je vais essayé de suivre ton lien, mais en attendant j'ai un truc que je ne m'explique pas, llvm-9-dev estbien installé, mais lldb refuse de s'installer, car doit rester en l'état??????

Code :
michou@michou-Aspire-M3985:~$ sudo apt-get install llvm-9-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
llvm-9-dev est déjà la version la plus récente (1:9~svn374861-1~exp1~20191015075537.63).
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

michou@michou-Aspire-M3985:~$ sudo apt-get install lldb-9
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
lldb-9 : Dépend: llvm-9-dev mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
Je précise que j'ai tenté cette MàJ Ubuntu Bionic à partir de :https://apt.llvm.org/

Voilà pourquoi j'utilise ou utilisais docker......
En voulant suivre ton tuto @nicoauffray je tombe direct sur un os:

Code :
michou@michou-Aspire-M3985:~$ sudo apt-get install gcc g++ cmake intltool xsltproc libgtk-3-dev libxml2-utils libxml2-dev liblensfun-dev librsvg2-dev libsqlite3-dev libcurl4-gnutls-dev libjpeg-dev libtiff5-dev liblcms2-dev libjson-glib-dev libexiv2-dev libpugixml-dev libcolord-dev libcolord-gtk-dev libcups2-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
gcc est déjà la version la plus récente (4:7.4.0-1ubuntu2.3).
gcc passé en « installé manuellement ».
libxml2-utils est déjà la version la plus récente (2.9.4+dfsg1-6.1ubuntu1.2).
libxml2-utils passé en « installé manuellement ».
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
liblensfun-dev : Dépend: liblensfun1 (= 0.3.2-4) mais 0.3.2-4pmjdebruijn1~bionic devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

michou@michou-Aspire-M3985:~$ sudo apt-get install liblensfun1
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
liblensfun1 est déjà la version la plus récente (0.3.2-4pmjdebruijn1~bionic).
liblensfun1 passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

michou@michou-Aspire-M3985:~$ sudo apt-get install liblensfun-dev
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
liblensfun-dev : Dépend: liblensfun1 (= 0.3.2-4) mais 0.3.2-4pmjdebruijn1~bionic devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
michou@michou-Aspire-M3985:~$
Je suis plein de bonne volonté, mais j'ai du mal à accrocher, d'un côté il me dit que liblensfun-dev ne peut être installé car manque une dépendance liblensfun1; et quand je demande l'installation de cette lib, il me dit qu'elle est déjà installé. Huh Huh
Autre précision, depuis la 2.6.2, j'utilise le dépôt OpenSuse.
Répondre
#20
(19-10-19, 14:02)mimi85 a écrit : Je vais essayé de suivre ton lien, mais en attendant j'ai un truc que je ne m'explique pas, llvm-9-dev estbien installé, mais lldb refuse de s'installer, car doit rester en l'état??????
Je suis plein de bonne volonté, mais j'ai du mal à accrocher, d'un côté il me dit que liblensfun-dev ne peut être installé car manque une dépendance liblensfun1; et quand je demande l'installation de cette lib, il me dit qu'elle est déjà installé. Huh Huh
Autre précision, depuis la 2.6.2, j'utilise le dépôt OpenSuse.

Fait gaffe à ne pas trop avoir de dépôts tiers pour ça. Là, tu as du conflit entre les librairies des dépôts d'Ubuntu et le dépôt pmdebruijn (peut-être même celui d'OpenSuse). Déjà là, sur les 2 derniers, ne garde que l'un ou que l'autre. Et vu les messages que tu as, je virerais le dépôt pmdebruijn, en ayant pris soin de désinstaller les librairies et autres paquets installés depuis ce dépôt. Puis tu réinstalles les mêmes librairies depuis le dépôt Ubuntu (désactives avant le dépôt Opensuse).

Les librairies et paquets sont liés ensemble selon comment ils ont été créés. Donc, ici si une librairie est associée à une version d'un dépôt et qu'une autre essaie de trouver une autre version d'un autre dépôt, ça peut vite devenir le bordel.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)