Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: LViatourinstallation 2.7 sur Ubuntu problème compilation
#21
Code :
michou@michou-Aspire-M3985:~$ sudo apt-get install lldb-9
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
lldb-9 : Dépend: llvm-9-dev mais ne sera pas installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
J'en suis tjrs au même point. Et cependant;
j'ai viré docker.io par synaptic et terminal,pour le remplacer par docker-ce (nouvelle version recommandée) par synaptic.
J'ai vérifié que le dépôt pmjdebruijm est bien inactif, ainsi que celui d'OpenSuse, avec actualisation
J'ai vérifié par synaptic que llvm-9-dev est bien installée sur mon système; surtout que le compilateur docker ou un autre utilise ces librairies. Au fait dernière mise à jour des dépôts llvm ce matin (Bionic (18.04) - Last update : Mon, 21 Oct 2019 02:44:28 UTC / RevisionSmile
Je vais arrêter de me prendre la tête, j'ai trouvé une version récente compilée sous windows à partir de pixel's, ça me permet de voir et d'apprécier les évolutions. Je vais attendre sagement la 3.0 au pied de sapin et surtout continuer à faire des photos, sachant que j'ai des expos à préparer.
Merci de vous être penchés sur mon problème.
Répondre
#22
Étant un peu têtu sur les bords, je ne voulais rester sur un échec, j'ai donc essayé de nettoyer toutes références à DT avant de recommencer une compilation, et j'ai suivi le lien que tu m'as donné @nicoauffray et je suis arrivé au bout de la compilation....Yes!!! et merci.
MAIS, j'ai du faire un loupé quelque part, car j'ai bien darktable qui se lance, en haut à gauche 2.7.0 mais rien derrière caractérisant la version de compilation?? De plus dans les préférences c'est toujours l'ancien panneau de configuration?? Dans la chambre noire, toujours l'ancien filmic??
En fin de compilation en lançant DT qui se lance bien, j'ai ce message:

Code :
-- Installing: /opt/darktable/share/man/es/man1/darktable-generate-cache.1
-- Installing: /opt/darktable/share/man/es/man1/darktable-cltest.1
-- Installing: /opt/darktable/share/man/es/man1/darktable-cmstest.1
martine2@martine2-Compaq-CQ58-Notebook-PC:~/darktable$ /opt/darktable/bin/darktable
[defaults] found a 64-bit system with 3622616 kb ram and 2 cores (0 atom based)
[defaults] setting very conservative defaults

(darktable:32274): dbind-WARNING **: 18:48:07.768: Error retrieving accessibility bus address: org.freedesktop.DBus.Error.ServiceUnknown: The name org.a11y.Bus was not provided by any .service files
martine2@martine2-Compaq-CQ58-Notebook-PC:~/darktable$
Je suis sur un ancien portable réssucité (banc d'essai) avec Lubuntu 18.04 LTS pour me faire la main avant de m'attaquer à mon PC Ubuntu 18.04 LTS.
Répondre
#23
(02-11-19, 19:20)mimi85 a écrit : Étant un peu têtu sur les bords, je ne voulais rester sur un échec, j'ai donc essayé de nettoyer toutes références à DT avant de recommencer une compilation, et j'ai suivi le lien que tu m'as donné @nicoauffray et je suis arrivé au bout de la compilation....Yes!!! et merci.
MAIS, j'ai du faire un loupé quelque part, car j'ai bien darktable qui se lance, en haut à gauche 2.7.0 mais rien derrière caractérisant la version de compilation?? De plus dans les préférences c'est toujours l'ancien panneau de configuration?? Dans la chambre noire, toujours l'ancien filmic??

Une bonne qualité que d'être têtu !

Déjà tu progresses. Reste que du coup tu es visiblement sur une très vieille version master. Créé un fichier, que tu nommeras par exemple compilerdt.sh

Dedans, tu ajoutes les lignes suivantes :

Code :
### Building manually

#!/bin/sh

cd /path/to/darktable
rm -rf build /opt/darktable
git pull
git submodule update
./build.sh --prefix /opt/darktable --build-type Release --install

exit 0

Tu adaptes bien sûr les chemins dans le texte ci-dessus, à commencer par '/path/to' où tu remplaces par le chemin vers le dossier darktable source.
Comme tu peux le voir, ça fait le ménage (virer le dossier build de la compilation précédente et virer le dossier où est installé darktable), indispensable pour éviter une compilation ratée/non mise à jour correctement.
Ensuite git pull assure de récupérer la dernière version de darktable. Attention, fais un essai avant dans le dossier de cette commande pour voir si tu as bien le lien avec le dépôt distant. Si message d'erreur, tu fais :
Code :
git remote add upstream git://github.com/darktable-org/darktable.git
et tu relances git pull.

git submodule update met à jour le module rawspeed (à condition qu'il est bien initialisé, à faire une seule fois via git submodule init).

La ligne ./build.sh, permet une compilation optimisée (recommandation d'Aurélien).

Ensuite, tu rends ce fichier exécutable (via un clic droit puis propriétés via le navigateur (tu trouveras l'option pour rendre exécutable facilement normalement. Sinon, en ligne de commande tu fais un :
Code :
chmod +x compilerdt.sh

Et tu exécutes ce fichier ensuite en mode root.
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#24
Après avoir galéré hier soir, la tempête de cette nuit m'a balayé l'esprit. Ce matin, j'ai repris le doc du redmine, et j'ai adapté.... En fait dans ce doc il y a un checkout avec un N° de tag (release). Il faut strapper ces deux lignes et ensuite tout se déroule correctement. j'ai maintenant à dispo la 2.7.0+2163~gc93b23f13
Comme j'y suis enfin arrivé sur ce vieux PC Lubuntu, ça devrait le faire sur mon PC Ubuntu. Encore une question, comment fait-t-on pour garder en parallèle la 2.6.3 (version officielle) et la/une version compilée, sans destruction?
Encore merci pour ton aide Smile Smile Smile

Merci aussi à toi @jpg54, c'est vrai que ce n'est pas compliqué.....une fois que l'on a appréhendé le problème.
Répondre
#25
darktable 2.6.x est installé dans usr/bin alors que la version master compilé est installé dans opt/darktable/bin. Par contre ils vont utiliser le même répertoire config et je te conseille de créer un lanceur comme le mien par exemple : /opt/darktable/bin/darktable --configdir .config/dt-master
Répondre
#26
@jpg54 Sans vouloir abuser de ta bonté, travaillant sur les mêmes photos, et je crois avoir lu qu'il y a incompatibilité arrière, au moins pour les nouveaux modules, il faut dupliquer???
Répondre
#27
J'ai un répertoire ou je mets les photos à traiter avec la version master compilée ou l'inverse.
Répondre
#28
Sinon le plus simple est de n'utiliser que la version master au stade où elle en est actuellement. Elle est franchement plutôt stable et il n'y aura plus de fonctionnalités intégrées et donc normalement que des corrections de bugs. J'utilise la master depuis le début d'année uniquement, sans problème majeur.

Sinon, en effet, vouloir utiliser les 2 oblige à jongler entre 2 répertoires de config différents, des options et logiques différentes (surtout avec le nombre impressionnant de changements que la version master, future 3.0, apporte).
Aussi appelé Nilvus !
Ubuntu 19.04 - darktable master - Macbook pro fin 2013 13"
Répondre
#29
(03-11-19, 18:33)nicoauffray a écrit : Sinon le plus simple est de n'utiliser que la version master au stade où elle en est actuellement. Elle est franchement plutôt stable et il n'y aura plus de fonctionnalités intégrées et donc normalement que des corrections de bugs. J'utilise la master depuis le début d'année uniquement, sans problème majeur.

Sinon, en effet, vouloir utiliser les 2 oblige à jongler entre 2 répertoires de config différents, des options et logiques différentes (surtout avec le nombre impressionnant de changements que la version master, future 3.0, apporte).

je dois dire que j'utilise la master depuis maintenant un ans sans très gros problèmes et en utilisation professionnelle. Et je dois aussi dire que quand je rencontre un petit problème,je le signale ici et souvent c'est réglé dans les heures qui suivent Wink

Pas certain que ceux qui envoient un problème chez Adobe reçoivent un correctif dans les heures qui suivent Wink
Luc Viatour Photographe 
Website
Répondre
#30
Je posais la question pour finir de me convaincre de n'utiliser que la version compilée. En plus je me suis fait plaisir en remettant un peu de couleur comme dans ma 2.6.3. Fichier dispo dans https://forums.darktable.fr/showthread.p...7#pid35367
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)