Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: patrick Lcomment installer opencl sur nvidia gtx 1060 + linux mint 19 [resolu]
#1
Bonjour  à vous tous.

Je viens d'acheter un ordi neuf avec un amd ryzen 3   et une carte gtx 1060.   Et je veux installer OpenCL .   j'ai active le pilote propriétaire de nvidia  dans les pilotes additionnels

j'ai toujours "non disponible" au niveau des paramètres de fonctionnement de darktable. 

j'ai installé les paquets  indiqués dans darktable.org  et leur installation  provoque des écrans noirs,    des fois des icônes énormes. 

Alors est ce qu'il existe un paquet  pour installer ce OpenCL sur nvidia,  cpu amd ryzen 3,  carte mère asus,  bios legacy,   et carte vidéo gtx 1060. 

Liste des paquets Nvidia installés
Code :
$ dpkg -l | grep -i nvidia
ii  libnvidia-cfg1-430:amd64                                    430.26-0ubuntu0.18.04.2              amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-430                                        430.26-0ubuntu0.18.04.2              all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-430:amd64                                 430.26-0ubuntu0.18.04.2              amd64        NVIDIA libcompute package
ii  libnvidia-compute-430:i386                                  430.26-0ubuntu0.18.04.2              i386         NVIDIA libcompute package
ii  libnvidia-decode-430:amd64                                  430.26-0ubuntu0.18.04.2              amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-430:i386                                   430.26-0ubuntu0.18.04.2              i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-430:amd64                                  430.26-0ubuntu0.18.04.2              amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-430:i386                                   430.26-0ubuntu0.18.04.2              i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-430:amd64                                    430.26-0ubuntu0.18.04.2              amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-430:i386                                     430.26-0ubuntu0.18.04.2              i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-430:amd64                                      430.26-0ubuntu0.18.04.2              amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-430:i386                                       430.26-0ubuntu0.18.04.2              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-430:amd64                                    430.26-0ubuntu0.18.04.2              amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-430:i386                                     430.26-0ubuntu0.18.04.2              i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  nvidia-compute-utils-430                                    430.26-0ubuntu0.18.04.2              amd64        NVIDIA compute utilities
ii  nvidia-dkms-430                                             430.26-0ubuntu0.18.04.2              amd64        NVIDIA DKMS package
ii  nvidia-driver-430                                           430.26-0ubuntu0.18.04.2              amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-430                                    430.26-0ubuntu0.18.04.2              amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-430                                    430.26-0ubuntu0.18.04.2              amd64        NVIDIA kernel source package
ii  nvidia-prime                                                0.8.8.2                              all          Tools to enable NVIDIA's Prime
ii  nvidia-prime-applet                                         1.0.7                                all          An applet for NVIDIA Prime
ii  nvidia-settings                                             390.77-0ubuntu0.18.04.1              amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-430                                            430.26-0ubuntu0.18.04.2              amd64        NVIDIA driver support binaries
ii  xserver-xorg-video-nvidia-430                               430.26-0ubuntu0.18.04.2              amd64        NVIDIA binary Xorg driver



j'ai lancé l'installation des paquets indiqués dans darktable.org.   Et alors  en rebootant j'ai le plantage de l'affichage

merci de vos réponses.
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060


darktable 2.6.2





Répondre
#2
Il te faut au moins aussi : nvidia-opencl-icd
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#3
Il doit te manquer le paquet opencl. C'est un truc qui s'appelle cuda ou du moins qui contient ce mot dans le nom, il semble. Cependant, je n'utilise pas cette distrib, donc ce que je dis est susceptible d'être erroné.

Pour ma distrib, j'ai les paquets suivants installés :
i | kernel-firmware-nvidia | Kernel firmware files for Nvidia Tegra and graphics drivers
i+ | nvidia-computeG04 | NVIDIA driver for computing with GPGPU
i+ | nvidia-gfxG04-kmp-default | NVIDIA graphics driver kernel module for GeForce 400 series and newer
i+ | nvidia-glG04 | NVIDIA OpenGL libraries for OpenGL acceleration
i+ | x11-video-nvidiaG04 | NVIDIA graphics driver for GeForce 400 series and newer
Et ça fonctionne parfaitement
Mes photos : jpverrue.fr
Répondre
#4
Je suis repassé sous Mint 19.2 Je regarde quand je suis chez moi.
Répondre
#5
J'ai un portable Dell avec un i5 et une NVidia GTX 1050.
Je peux passer de la carte NVidia à la carte Intel :
[Image: image.png]

[Image: image.png]

[Image: image.png]
Répondre
#6
Merci à vous tous d'avoir résolu mon problème.

Bilan  : pour les autres qui viendraient à  se poser la question.
Sous synaptic     cocher pour installation    les paquets suivants.


Code :
libnvidia-compute-430
libnvidia-compute-430:i386
nvidia-opencl-dev
nvidia-profiler
nvidia-visual-profiler
ocl-icd-libopencl1
ocl-icd-libopencl-dev
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060


darktable 2.6.2





Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)