Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: crissMaJ vers dt 3.0 problème migration .db
#1
Bonjour

J'ai mis à jour 2.6.3 vers la 3.0 l'installation c'est bien passée .
Mais au lancemnt de dt il me demande de mettre à jour les bases de données , je valide mais rien ne se passe .
Je me suis dis  qu'il fallait un peu de temps , mon fichier library .de fait 59040 ko mais au bout de quelques heures toujours rien .

Je suis sur win 10 .
avez-vous une idée ?

 Merci
Répondre
#2
Non pas d'idée Sad Le mieux c'est arrêter dt et de repartir depuis les backups si ça plante lorsque tu relances. Attention tu aura probablement besoin de supprimer les .lock. Voir les messages sur le forum a propos de cette manip sur Windows.
--
Pascal - GNU/Debian (sid) - version darktable git/master
http://photos.obry.net
Répondre
#3
(05-11-19, 19:37)pascal a écrit : Non pas d'idée Sad Le mieux c'est arrêter dt et de repartir depuis les backups si ça plante lorsque tu relances. Attention tu aura probablement besoin de supprimer les .lock. Voir les messages sur le forum a propos de cette manip sur Windows.

Merci Pascal
Les fichiers .lock se supprime automatiquement après que j'ai validé la mise à jour de la base de données . Je n'ai pas de plantage , aucun message  rien .
existe-t'il une autre façon de faire la migration de la base .
Répondre
#4
Bonsoir,
As tu résolu ton problème ?
Car je viens de mettre dt 3.0 et j'ai le même soucis ... avec library.db dt est vide, si je le remplace par ma sauvegarde, dt ne s'ouvre pas et je me retrouve avec ce que tu as mis dans ton premier post ...
je n'oublie pas que le chêne, avant d'être grand et fort, était comme moi ... un gland !
Répondre
#5
Bonjour la foule,
J'ai trouvé une parade à mon soucis ; si ça peut aider ...

Tous mes dossiers photos sont classés par jour (AAMMJJ-[titre succinct])
Habituellement j'importe UN dossier et il se constitue des photos qui le compose. Je n'avais jamais essayé auparavant, mais on peut importer plusieurs dossier à la fois, il suffit de les sélectionner et d'importer. Une barre de progression par dossier apparaît en bas à gauche.
Je suis en train de m'occuper de les remonter mois par mois. Et pour le moment tout va bien. Et comme je n'ai dt que depuis son passage sur win cela me fait pas trop de boulot. Néanmoins il faudra que je me méfie aux prochaines MAJ.
Quand tout sera fini je supprimerai le dossier library1.db que j'avais sauvegardé (de la 2.6) et qui ne m'est pas utile.

l'année commence bien, pourvu que ça dure !
je n'oublie pas que le chêne, avant d'être grand et fort, était comme moi ... un gland !
Répondre
#6
En fait l'année ne commence pas si bien ...

Lors du développement d'une photo, en fin de traitement, je trouve deux taches (pétouilles) et je vais sur le module de correction des taches. Les taches ne disparaissent pas ... mais pas du tout. Voulant passer à autre chose je ferme dt. Depuis impossible de le ré ouvrir, un message au début comme quoi il serait déjà ouvert (numéro de process actif...).

En cherchant dans le forum je trouve une réponse des fichiers lock qu'il faut supprimer ... je supprime (en les sauvegardant) rien n'y fait. Je les remets comme ils étaient, toujours impossible de redémarer dt.

Ce matin je décide de supprimer dt (avec ccleaner) et je rédémarre mon micro ; je retourne chercher dt 3.0 pour win64, et je réinstalle.

mais je ne peux toujours pas démarrer dt.
Je n'avais, de mémoire, jamais eu de problème avec 2.6. Et là la 3.0 ... ne fonctionne pas. Je ne sais plus quoi faire et je m'absente une semaine où je n'aurais pas internet. J'espérais traiter des photos que j'ai stockées "pour mes soirées d'hiver" mais bon ... !

Alors ma question (si réponse, je ne la verrais peut être qu'à mon retour) comment nettoyer complètement dt pour ré implanter 3.0 et que ça fonctionne ?
Seconde question : à quoi servent les autres fichier téléchargeables du tableau (la page est tout en anglais et ce n'est pas ma tasse de thé)
D'avance merci.
Pascal
je n'oublie pas que le chêne, avant d'être grand et fort, était comme moi ... un gland !
Répondre
#7
(02-01-20, 12:18)PB2N a écrit : Lors du développement d'une photo, en fin de traitement, je trouve deux taches (pétouilles) et je vais sur le module de correction des taches. Les taches ne disparaissent pas ... mais pas du tout. Voulant passer à autre chose je ferme dt. Depuis impossible de le ré ouvrir, un message au début comme quoi il serait déjà ouvert (numéro de process actif...).

En cherchant dans le forum je trouve une réponse des fichiers lock qu'il faut supprimer ... je supprime (en les sauvegardant) rien n'y fait. Je les remets comme ils étaient, toujours impossible de redémarer dt.

Ce matin je décide de supprimer dt (avec ccleaner) et je rédémarre mon micro ; je retourne chercher dt 3.0 pour win64, et je réinstalle.

mais je ne peux toujours pas démarrer dt.
Je n'avais, de mémoire, jamais eu de problème avec 2.6. Et là la 3.0 ... ne fonctionne pas. Je ne sais plus quoi faire et je m'absente une semaine où je n'aurais pas internet. J'espérais traiter des photos que j'ai stockées "pour mes soirées d'hiver" mais bon ... !

Alors ma question (si réponse, je ne la verrais peut être qu'à mon retour) comment nettoyer complètement dt pour ré implanter 3.0 et que ça fonctionne ?
Seconde question : à quoi servent les autres fichier téléchargeables du tableau (la page est tout en anglais et ce n'est pas ma tasse de thé)
D'avance merci.
Pascal

Déjà, je te recommande le module retouche plutôt que correction des tâches (retouche remplace ce dernier, avec les mêmes options et bien plus).

Pour ton problème, ce n'est pas lié à la 3.0, c'est certain d'autant que le module correction des tâches n'a pas évolué depuis... longtemps. Ou à moins que ce soit un bug inconnu lié à la réorganisation du pipe (le module correction des tâches étant probablement aujourd'hui très peu utilisé puisque retouche est bien meilleur).

Ca sent la base de données corrompue ton problème. Puisque si tu as redémarré ton ordi, tu n'as plus de processus actif. Déjà, il te faut bien supprimer les fichiers lock et ne pas les remettre. Si darktable ne redémarre jamais, je te conseille de supprimer (conserve une sauvegarde tout de même) le fichier library.db ET le xmp du RAW que tu traitais au moment du crash. Bon là, j'espère que tu as bien laissé l'option pour avoir les fichiers xmp pour la suite.

Une fois fait, tu relances darktable. Comme tu as viré le fichier library.db, si darktable s'ouvre bien (logiquement il devrait), tu n'auras plus d'images. Il te faudra donc réimporter tes dossiers actuels pour les retrouver (les XMP permettront de retrouver aussi tous tes traitements.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#8
Merci de ta réponse @nicoauffray (je profite d'un accès pour consulter le forum)

J'étais parti avec le fichier d'installation. J'ai donc cherché un peu et voici comment je me suis dépanné.

Il était impossible de réinstaller dt tel qu'il m'était proposé (et comme il l'était précédemment) j'avais toujours l'impossibilité de l'ouvrir.
Alors au moment du début de l'installation, lorsqu'il propose l'emplacement du répertoire darktable, j'ai intercalé dt/ avant "darktable" dans la ligne de l'emplacement. Et maintenant ça fonctionne.

Bien sûr, j'ai toujours utilisé les fichiers xmp (depuis le tout début), donc pas de soucis à ce sujet.
Pour la retouche j'ai compris pourquoi : systématiquement l'opacité est à 0% je dois donc, pour chaque masque, faire le shift+molette

Pour le module retouche, j'ai bien regardé plusieurs fois les deux vidéos sur YT (JPVERRUE et ... ? ...) mais au moment de pratiquer sur mes photos je n'obtiens pas ce que je souhaite. Il va donc falloir que je les revisionne. Dès que je rentre à la maison, ce sera ma priorité.

Merci encore.
Pascal
je n'oublie pas que le chêne, avant d'être grand et fort, était comme moi ... un gland !
Répondre
#9
(04-01-20, 10:20)PB2N a écrit : Pour le module retouche, j'ai bien regardé plusieurs fois les deux vidéos sur YT (JPVERRUE et ... ? ...) mais au moment de pratiquer sur mes photos je n'obtiens pas ce que je souhaite. Il va donc falloir que je les revisionne. Dès que je rentre à la maison, ce sera ma priorité.

Merci encore.
Pascal

Tu verras pourtant que les options de correction des tâches sont dans retouche. Pour celles-là, l'usage est le même. Pour le reste, l'article linuxfr sur la 2.6 (qui a vu l'arrivée du module retouche) te donnera aussi un très bon premier tuto pour commencer : https://linuxfr.org/news/darktable-2-6-0...e-retouche
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#10
(05-11-19, 19:12)criss a écrit : Bonjour

J'ai mis à jour 2.6.3 vers la 3.0 l'installation c'est bien passée .
Mais au lancemnt de dt il me demande de mettre à jour les bases de données , je valide mais rien ne se passe .
Je me suis dis  qu'il fallait un peu de temps , mon fichier library .de fait 59040 ko mais au bout de quelques heures toujours rien .

Je suis sur win 10 .
avez-vous une idée ?

 Merci

Bonjour, je suis novice ...et perdu.
Un peu le même problème que vous: désinstallation d'une ancienne version et installation de 3.0. Message d'erreur: le fichier de verrouillage contient un n° de process actif sur votre système "15720". Quitter Darktable.  Une idée pour résoudre celà ? Merci d'avance. Marc
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)