Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
darktable_exported
#1
J'utilise darktable avec des raw dans des dossiers (pellicules)
je sors des jpg dans les sous dossiers des dossiers raw nommés darktable-exported
* Seules les pellicules apparaissent dans la fenêtre Filtres de collections de la table lumineuse
je sauvegarde le tout sur un disque dur externe.
-----------------
Je formate mon disque dur et installe une autre distribution linux
je recopie dossiers raw et sous dossiers darktable_exported dans le dossier Images de ma nouvelle distribution linux.
----------------
Je lance darktable
j'importe mes fichiers en mode récursif pour avoir toute la branche : 2019/
* Les pellicules apparaissent dans la fenêtre Filtres de collections de la table lumineuse mais aussi tous les sous dossiers darktable_exported.
Pourrait-on éviter que ces sous dossiers darktable_exported se retrouvent en pellicules dans la liste des filtres de collections ?
Lille. Hauts de France
Site web : http://www.philippedeletree.fr
Youtube : Darktable
Linux Solus

Répondre
#2
Bonjour,

Décocher "importer les dossiers récursivement" dans les préférences > options d'interface serait une solution qui imposerait d'importer dossier image RAW par dossier.

Or je comprends qu'il s'agit de l'importation du dossier 2019 et tous ses sous-dossiers (et leurs sous-dossiers)...

En alternative, il y a l'option "ignorer les fichiers JPEG"...
Ubuntu 18.04 + dt "master"
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#3
[Image: filtres-et-darktable-exported.png]

En fait quand l'importation se fait, il y a les jpg du sous dossier darktable_exported à côté des raw dans la table lumineuse.
Quand on clique sur un jpg du sous dossier darktable_exported il se retrouve en chambre noire et un fichier xml est créé, générant peut-être du même coup l'arrivée du sous dossier darktable_exported dans les filtres de collections.
darktable devrait interdire l'ouverture d'un jpg du dossier "darktable_exported" dans la chambre noire puisqu'il est déjà développé (depuis un raw ou un jpg origine)
bon ... pas grave.
Lille. Hauts de France
Site web : http://www.philippedeletree.fr
Youtube : Darktable
Linux Solus

Répondre
#4
(21-12-19, 14:06)valmy a écrit : [Image: filtres-et-darktable-exported.png]

En fait quand l'importation se fait, il y a les jpg du sous dossier darktable_exported à côté des raw dans la table lumineuse.
Quand on clique sur un jpg du sous dossier darktable_exported il se retrouve en chambre noire et un fichier xml est créé, générant peut-être du même coup l'arrivée du sous dossier darktable_exported dans les filtres de collections.
darktable devrait interdire l'ouverture d'un jpg du dossier "darktable_exported" dans la chambre noire puisqu'il est déjà développé (depuis un raw ou un jpg origine)
bon ... pas grave.

C'est justement pour ça qu'il existe l'option "ignorer les fichiers JPEG lors de l'importation d'un dossier" dans les préférences.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#5
Donc le photographe qui ne shoote qu'en jpg il n'importe rien ?
bof, je me complique la vie :-)
Lille. Hauts de France
Site web : http://www.philippedeletree.fr
Youtube : Darktable
Linux Solus

Répondre
#6
(21-12-19, 15:58)valmy a écrit : Donc le photographe qui ne shoote qu'en jpg il n'importe rien ?
bof, je me complique la vie  :-)

Euh, la case tu peux la cocher (donc aussi la décocher). Ca permet d'adapter selon ce que tu veux importer ou non. Et tu peux aussi changer entre les imports, ça changera ce qui se passe. Tu peux même changer cela dans la fenêtre d'import (d'une image ou d'un dossier) via le bouton "options d'importation" en bas à droite de cette boite dialogue. Bref, tu as le choix.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#7
Cette option n'est clairement pas pour eux ! ?

Alternative : recopier sur disque que les dossiers des raws (donc aucun darktable_exported), importer ces photos dans dt puis recopier les dossiers exported_data sur disque.
Ubuntu 18.04 + dt "master"
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#8
je vois bien l'incompatibilité de la case "ignorer les fichier jpg" dans certains workflow.
Peut-être qu'une option pour un filtre d'exclusion lors de l'import sera un jour ajoutée, mais comme dit si bien valmy, ne nous compliquons pas la vie d'ici là Wink
Répondre
#9
(22-12-19, 17:37)i blonchk a écrit : je vois bien l'incompatibilité de la case "ignorer les fichier jpg" dans certains workflow.
Peut-être qu'une option pour un filtre d'exclusion lors de l'import sera un jour ajoutée, mais comme dit si bien valmy, ne nous compliquons pas la vie d'ici là Wink

Euh là, je ne comprends pas vos remarques. L'option existe déjà dans les 3 fenêtres d'option. A l'import d'un dossier, d'une image ou depuis un boîtier/carte mémoire, il y a l'option d'import ou non des jpg.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#10
(23-12-19, 20:19)nicoauffray a écrit :
(22-12-19, 17:37)i blonchk a écrit : je vois bien l'incompatibilité de la case "ignorer les fichier jpg" dans certains workflow.
Peut-être qu'une option pour un filtre d'exclusion lors de l'import sera un jour ajoutée, mais comme dit si bien valmy, ne nous compliquons pas la vie d'ici là Wink

Euh là, je ne comprends pas vos remarques. L'option existe déjà dans les 3 fenêtres d'option. A l'import d'un dossier, d'une image ou depuis un boîtier/carte mémoire, il y a l'option d'import ou non des jpg.

Ceux qui externalisent leurs exports hors de l'arborescence des images de darktable n'auront jamais ce problème, mais imagine qu'on a toute une hierarchie à réimporter. Avec des contenus raw et jpg pertinents dans tous les répertoires de l'arborescence. Malheureusement, on a également un "darktable_exported" dans chacun d'entre-eux, avec plein de jpg qu'on ne veut surtout pas (ré)importer. Actuellement, ce n'est pas jouable directement dans dt parce qu'on ne peut pas définir un filtre d'exclusion. Il faut alors réimporter chaque pellicule une à une avec "récursivement: non" et "ignorer jpg: non" ... mais on s'en sort facilement.

Cette commande (bash/linux) externalise darktable_exported en y déplaçant tous les sous-répertoires du même nom rencontrée dans l'arborescence courante, en reconstituant la hiérarchie relative. 

Code :
$ CIBLE=darktable_exported
$ mv $CIBLE $CIBLE.sos    # si besoin est
$ find * -type d -name $CIBLE -print0 | xargs -0 dirname | while read P; do mkdir -p "$CIBLE/`dirname $P`"; mv "$P/$CIBLE" "$CIBLE/$P"; done
(mieux vaut ne pas oublier les guillemets)
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)