Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: nicoauffrayPaquets Linux de darktable 3.0 dispos
#31
bonsoir à vous tous. 

Code :
sudo ppa-purge ppa:pmjdebruijn/darktable-release
sudo apt update
sudo add-apt-repository ppa:dhor/myway
sudo apt update
sudo apt install darktable
tar -Ppzcvf  complete-config-darktable_v2.6.2_2019-04-01.tar.gz ~/.config/darktable
darktable

et j'ai la version 3.0.0  de darktable
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#32
(04-01-20, 20:22)nicoauffray a écrit :
(04-01-20, 19:33)manu a écrit :
(04-01-20, 15:03)nicoauffray a écrit :
(04-01-20, 07:51)Jean-Luc a écrit : Vraiment compliqué pour Ubuntu ! toujours pas en ligne Sad

Si, en fait ils y sont (et depuis quelques jours). Je viens de l'apprendre de darix (qui gère le dépôt Opensuse) : les paquets Debian et Ubuntu sur ce lien, notés 2.6.2 sont en fait bien la version 3.0.0. En gros, le nom ne s'est pas mis à jour et la cause n'est pas trouvée encore.

Euh... chez opensuse, en suivant les instructions de la page Ubuntu c'est la 3.1 qui est installée, par la 3.0...

Euh... as-tu lu mon message ? Je parle du lien que j'ai posté sur le premier post de ce fil, ce n'est pas celui-là. Allez, je te le remets : https://software.opensuse.org/download.h...=darktable

Et là pour Debian et Ubuntu, ça indique 2.6.2. Le problème est que ça ce n'est pas à jour. Je ne sais pas quand c'est corrigé mais malgré tout derrière, c'est bien une 3.0.0. Il est possible de l'installer en le téléchargeant mais il faut s'assurer de ne pas avoir de dépôt actif avec une 2.6.3 sinon c'est aller au devant de problème.

@Roger : oui si tu as une 2.6.3, comme le paquet est noté par erreur 2.6.2, ton système considère que la version est plus ancienne. Il ne peut pas savoir qu'en réalité derrière, c'est une 3.0.0. Mais je viens d'installer le paquet noté 2.6.2 pour Ubuntu 19.10 et j'ai bien une 3.0.0 qui s'ouvre.

Bref, ne l'installer que sous TOUTES ces conditions :
- après avoir désinstallé la 2.6.x que vous avez déjà (par sécurité)
- fait une sauvegarde de votre dossier .config/darktable
- vous savez ensuite comment bloquer la mise à jour d'un paquet spécifique (ici darktable pour à tout prix éviter qu'il mette à jour vers une vraie 2.6.3 ; parce que là, vous ne pourrez plus ouvrir les images, la base de données ne sera plus compatible avec une 2.6.x)
- et enfin, vous restez en veille de la correction du dépôt pour savoir quand vous pourrez enlever le blocage de mise à jour pour avoir ensuite automatiquement les bonnes mises à jour 3.0.1, etc.

Sinon, le plus prudent est de patienter afin que ce soit corrigé. Ou pour ceux sous Ubuntu, tester le dépôt dhor proposé par jpg54 (je ne sais pas ce qu'il vaut pour ma part).

Merci pour les explications, je n'avais pas compris  Wink .
---------------------
Débian 9 Stretch - CPU Intel I3, Radéon HD 4870, SSD 128 Go + HDD1 To + HDD 2To dédié aux photos
darktable 2.6.2
---------------------
Éternel débutant  Shy
Répondre
#33
Bonjour,
Etant sur debian 10, j'ai trouvé la solution suivante pour l'installation en 3.0 à partir du dépot opensuse https://software.opensuse.org/download.h...=darktable avec un pinning de package :

Dans un terminal en Super User :

Code :
apt remove darktable
echo 'deb http://download.opensuse.org/repositories/graphics:/darktable/Debian_10/ /' > /etc/apt/sources.list.d/graphics:darktable.list
wget -nv https://download.opensuse.org/repositories/graphics:darktable/Debian_10/Release.key -O Release.key
apt-key add - < Release.key
nano /etc/apt/sources.list.d/99-stable-darktable
éditer les 3 lignes qui suivent et valider CTRL+x :
  Package: darktable
  Pin: release o=obs://build.opensuse.org/graphics:darktable/Debian_10
  Pin-Priority: 900

Code :
apt-get update
apt-cache policy darktable

pour vérifier sur le package opensuse est priorisé par rapport à celui de buster
Code :
apt-get install darktable

et pas de problème d'écrasement avec une mise à jour debian (apt-get upgrade). A voir avec le temps.

Mes étapes en détail : https://debian-facile.org/viewtopic.php?...18#p322418
Suite à la remarque de jpg54, j'ai mis à jour le message avec des blocs codes
Répondre
#34
Tu pourrais mettre dans un bloc "code" pour éviter l'interprétation HTTP !
Répondre
#35
Bonjour à tous,

Pour info et ceux qui veulent des paquets propres (bon numéro de version), les paquets 3.0.0 sont ok maintenant pour Ubuntu et Debian (avec le bon numéro de version) sur le dépôt Opensuse :

https://software.opensuse.org/download.h...=darktable

Ca fait peut-être un moment mais je n'avais pas été voir depuis.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master - Macbook pro fin 2013 13"
Répondre
#36
(01-02-20, 12:17)nicoauffray a écrit : Pour info et ceux qui veulent des paquets propres (bon numéro de version), les paquets 3.0.0 sont ok maintenant pour Ubuntu et Debian (avec le bon numéro de version) sur le dépôt Opensuse :

J'utilise Mint. Quelqu'un pourrait-il m'aider à comprendre SVP :
- Mint 19.3 tourne, je crois, sur Ubuntu 18.04
- Sur Opensuse il y a des paquets 18.04, 18.10, 19.04 et 19.10 mais il est indiqué "xUbuntu" or si je ne trompe pas xUbuntu ce n'est ps vraiment Ubuntu puisque le desktop est basé sur Xfce et pas Gnome...

Bref, lequel finalement pourrait convenir pour Mint 19.3 svp ?
Huh 
merci d'avance
Yves Bornemann
https://ybphoto.weebly.com/
Linux mint 19.3 sur PC - Windows 10 sur laptop.
Darktable 3.0.1
Nikon Z6 + 24-70mm f/4
Répondre
#37
XUbuntu utilise xfce comme interface graphique et Mint Cinnamon, ces 2 interfaces graphiques sont dérivées de GNome 2 et seuls les logiciels installés avec sont différents. En principe tu ne devrais pas avoir de problèmes.
Répondre
#38
(01-02-20, 18:26)jpg54 a écrit : XUbuntu utilise xfce comme interface graphique et Mint Cinnamon, ces 2 interfaces graphiques sont dérivées de GNome 2 et seuls les logiciels installés avec sont différents. En principe tu ne devrais pas avoir de problèmes.

Merci jpg54.  Le paquet le plus récent : xUbuntu 19.10 ?
Yves Bornemann
https://ybphoto.weebly.com/
Linux mint 19.3 sur PC - Windows 10 sur laptop.
Darktable 3.0.1
Nikon Z6 + 24-70mm f/4
Répondre
#39
Je prendrais XUbuntu 18.04.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)