Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: loicbPlantage copie développement [RÉSOLU]
#1
Bonjour,

j'ai tenté de faire plusieurs copies de développement mais darktablese fige à chaque fois.

1. Je sélectionne dans la table lumineuse ma photo modifiée
2. Dans "développement", je clique sur "copier"
3. Je sélectionne toutes mes photos
4. Je clique sur "coller" dans "développement" et je ne sélectionne que le module que je souhaite appliquer à toutes mes photos.
5. je clique sur "OK" et j'attends, j'attends, j'attends...
Je ne vois rien avancer et dt semble planté.

Au bout de 2-3 minutes (habituellement, ce type de copie prend 10-20 secondes) je décide de crasher dt
Je le réouvre et je constate que la copie du développement a bien fonctionné.
J'ai essayé sur plusieurs modifications de modules et le résultat est le même : le développement est bien copié mais darktable plante (reste figé comme sur l'image jointe).

Avez-vous le même problème et surtout comment le résoudre ?

Précisions : j'utilise Linux Ubuntu 19.10 avec dt 3.0
Merci


[Image: plantage-copie-dev.jpg]
Répondre
#2
Bonjour,

C'est quoi la fenêtre d'alerte derrière celle de sélection des modules à copier ?
Répondre
#3
Je viens d'essayer avec la 3.0.0 du PPA dhor/myway sous Mint 19.3 (dérivé d'Ubuntu 18.0 LTS) et aussi avec la version master. Je n'ai pas eu de problème à la copie sur 4 autres RAW.
Répondre
#4
Jamais eu ça ni vu de retour de quelqu'un ayant eu ce problème.

3 questions :

- d'où vient ta version de dt 3.0 (quel ppa ? ou compilation ?) ?
- Quel matériel as-tu (taille RAM ? Processeur ? Carte graphique ? OpenCL activé ou non ?)
- Quels réglages dans le 2ème onglet des préférences, dans la partie CPU/GPU/mémoire ? (une capture d'écran de ce bloc serait le plus simple)
Aussi appelé Nilvus !
Ubuntu 19.10 - darktable master - Macbook pro fin 2013 13"
Répondre
#5
@Cailloux : c'est la fenêtre de Ubuntu pour demander si on veut "attendre" ou "forcer à quitter" quand on logiciel ne rend pas la main.

@jpg54 : donc le problème semble venir de chez moi

@nico :
ma version dt 3.0 vient de ce ppa : http://ppa.launchpad.net/ubuntuhandbook1...ble/ubuntu
Je n'ai rien trouvé d'autre pour installer cette version chez moi.

J'ai : RAM = 12Go
processeur = Intel Core i3-4130 CPU @ 3.40GHz × 4
carte graphique = intégrée à ma carte mère et je ne rappelle plus
OpelCL activé : aucune idée, c'est quoi ce truc ?

[Image: plantage-copie-dev2.jpg]
Répondre
#6
J'ai émis des réserves pour le PPA que tu as choisi et quelques utilisateurs ont signalé des problèmes. J'ai d'ailleurs plusieurs fois donner ce PPA : https://launchpad.net/~dhor/+archive/ubuntu/myway et @nicoauffray celui d'OpenSuse : https://software.opensuse.org/package/darktable
Il peux rappeler le fil de discussion. Le passage a la version 3.0.0 a été de nombreuses fois évoquées sur le forum.
Pour ton ordinateur n'est pas un foudre de guerre mais il est suffisant pour l'utilisateur de darktable sauf pour l'OpenCL avec la carte graphique intégrée. Les cartes graphiques Intel intégrées ne sont bien gérées qu'à partir des processeurs en version 8xxx et avec l'utilisateur du nouveau driver NEO.
Répondre
#7
(19-01-20, 12:00)loicb a écrit : @nico :
ma version dt 3.0 vient de ce ppa : http://ppa.launchpad.net/ubuntuhandbook1...ble/ubuntu
Je n'ai rien trouvé d'autre pour installer cette version chez moi.

J'ai : RAM = 12Go
processeur = Intel Core i3-4130 CPU @ 3.40GHz × 4
carte graphique = intégrée à ma carte mère et je ne rappelle plus
OpelCL activé : aucune idée, c'est quoi ce truc ?

[Image: plantage-copie-dev2.jpg]

Avec 12 Go de RAM, monte la mémoire limite de tuilage de 1500 à 6000 (j'avais des crash d'export ces derniers jours sur un RAW de 40 Mo, avec 4000 sur ce réglage ; en montant à 6000 + une Swap de 4 Go que j'avais auparavant désactivé, je n'ai plus eu de crash).

Si tu as 4 fils sur ton CPU, descends le nombre de fils de 8 à 4.

OpenCL c'est une librairie permettant de se servir de la puissance d'une carte graphique. Mais sur une carte intel intégrée d'un CPU aussi vieux, ça ne sert à rien et darktable te dit bien d'ailleurs qu'OpenCL n'est pas activé. Donc ça c'est très bien comme ça.

Dernière chose : vire le PPA Ubuntuhandbook que tu as, désinstalle darktable et récupère darktable 3.0 dpuis le PPA dhor que jpg recommande. Le PPA que t'utilise a amené à plusieurs retours propres à lui de problèmes que darktable 3.0 n'a normalement pas.

En gros, ça te fait au moins 2 raisons possibles de tes problèmes : le réglage du tuilage (mon premier conseil) et le PPA choisi. Pour le 2ème conseil sur les fils, c'est juste un bonus d'optimisation des réglages de darktable.
Aussi appelé Nilvus !
Ubuntu 19.10 - darktable master - Macbook pro fin 2013 13"
Répondre
#8
Bien vu Nicolas pour le nombre de fils, j'avais pas remarqué.
Répondre
#9
Merci tous les deux pour vos retours.
J'ai viré mon ppa, mis celui de jp et fais les modifs dans les paramètres de dt. Bilan, ça fonctionne à nouveau. Merci beaucoup !
Pour ce qui est de la (non) puissance de mon ordinateur, je vais poster un nouveau post.
Répondre
#10
J'ai pas dit qu'il est pas assez puissant, il est suffisant !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)