Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: CATONHistogramme bloqué
#1
[Image: image-test.jpg]

Bonsoir à tous.


Depuis quelque temps (installation de la version 3,0? ) sur mon écran l’histogramme de la chambre noire a un comportement surprenant.
Toutes les courbes se terminent abruptement à gauche sur une ligne verticale positionnée à environ 1/8 de la fenêtre d’affichage de l’histogramme. C’est comme si les courbes rencontraient un mur. J’ai beau forcer sur les noirs rien n’y fait. L’image est bien modifiée mais l’histogramme ne dépasse jamais cette limite géométrique.


Pour info je précise que je travaille sous Windows 10, avec un processeur Intel CORE I5 7200U à 2,5GHz, une carte NVIDIA Geforce 940MZ et Open CL activé.


Sous ACDSEE l’affichage de l’histogramme est correct.


Une idée ? Merci d’avance.


PJ : une copie d’écran
Répondre
#2
Peut-être avec le RAW et le .xmp nous aideraient en téléchargement sur FramaDrop par exemple.
Répondre
#3
(23-01-20, 08:26)jpg54 a écrit : Peut-être avec le RAW et le .xmp nous aideraient en téléchargement sur FramaDrop par exemple.

Bonjour.

Les liens sur FramaDrop.

https://framadrop.org/r/O_0Eq3D-Jk#q6ptc...TC8OFIBoC4=

https://framadrop.org/r/-DKk-7lToP#ljhZs...B5Xq9t9J9I=
Répondre
#4
Une chose déjà : l'histogramme n'a pas forcément à être sous une forme ou une autre. L'histogramme est une forme de visualisation de l'image, qui peut aider dans certains cas à identifier où et comment traiter. Le but n'est pas d'avoir un histogramme type mais bien l'image qu'on veut. Bref, la forme et l'aspect visuel important, c'est l'image, pas l'histogramme. Ca n'est pas un bug ce que tu as, juste la visualisation de l'histogramme de ton image telle qu'elle et telle qu'elle est traitée.

Ceci dit, ta correction du niveau de noir pourrait à mon avis être à 0 ici. Tu as un trou à gauche de ton pic. Et idéalement, il est préférable de ne toucher à ce réglage que pour aligner à gauche l'histogramme.
Aussi appelé Nilvus !
Ubuntu 19.10 - darktable master - Macbook pro fin 2013 13"
Répondre
#5
(23-01-20, 14:23)nicoauffray a écrit : Une chose déjà : l'histogramme n'a pas forcément à être sous une forme ou une autre. L'histogramme est une forme de visualisation de l'image, qui peut aider dans certains cas à identifier où et comment traiter. Le but n'est pas d'avoir un histogramme type mais bien l'image qu'on veut. Bref, la forme et l'aspect visuel important, c'est l'image, pas l'histogramme. Ca n'est pas un bug ce que tu as, juste la visualisation de l'histogramme de ton image telle qu'elle et telle qu'elle est traitée.

Ceci dit, ta correction du niveau de noir pourrait à mon avis être à 0 ici. Tu as un trou à gauche de ton pic. Et idéalement, il est préférable de ne toucher à ce réglage que pour aligner à gauche l'histogramme.

D'accord avec toi sur la lecture toute relative à avoir de l'histogramme.

Sur l'image jointe, j'ai majoré les noirs "pour voir". Mais quoique je fasse, et ce sur toutes mes images, j'ai de fait ce trou à gauche.
Et cependant je réussis à avoir des images acceptables, même si j'ai encore des progrès à faire.
Répondre
#6
(23-01-20, 14:48)CATON a écrit : D'accord avec toi sur la lecture toute relative à avoir de l'histogramme.

Sur l'image jointe, j'ai majoré les noirs "pour voir". Mais quoique je fasse, et ce sur toutes mes images, j'ai de fait ce trou à gauche.
Et cependant je réussis à avoir des images acceptables, même si j'ai encore des progrès à faire.

Je viens de télécharger et traiter ton image. Déjà plusieurs remarques sur ton traitement de base :

- le module réduction du bruit de profil est sur les réglages darktable 2.6 et il y a eu beaucoup d'améliorations. Assure-toi de mettre à jour les réglages (en passant par exemple au nouveau mode par défaut "moyennes non locales auto" ; voir la dernière vidéo de rawfiner sur son travail sur ce module). Et au moins quand tu vois les cases "correction des bugs dans l'algorithme", "mise à niveau...", coche les. Sur ce module, tu as aussi l'option "balance des blancs adaptative", active-là sur la 1ère instance de ce module (si tu crée d'autres instances à ne pas activer comme la bulle d'aide te l'indique quand tu passe le curseur sur cette option).
- le module "correction du profil d'entrée" : déjà, il sert rarement à quelque chose mais le laisser avant le module profil de couleur d'entrée qu'il est censé corriger. A déplacer au dessus donc, voire même à désactiver. Pour cette image, je n'ai pas vu de différence visible avec.
- le module "aberrations chromatiques" : si ton objectif a des paramètres actifs de correction des aberrations dans le module correction des objectifs, il est à éviter (ça te ferait corriger des aberrations déjà corrigées). De manière générale, active ce module si la correction des objectifs ne fait pas d'effet et que tu constate toujours des aberrations chromatiques.
- enfin ton image de départ est sous exposé, monter l'expo générale dans le module exposition vers un gris moyen sur l'image (donc pas forcément toute la largeur de l'histogramme) est mieux. Tu affine ensuite avec filmique.

Et voilà ton image traitée à ma manière. Tu verras qu'il n'y a pas de pic. Je ne pourrais pas t'expliquer comment, juste que mon traitement donne ce résultat et donc l'histogramme associé. A toi de voir les paramètres et comprendre ce qu'ils font. Et l'égaliseur de tons est parfait pour ajuster les différences d'exposition inévitables entre le ciel et l'avant-plan sur une telle image.

[Image: FGPI7711.jpg]
Aussi appelé Nilvus !
Ubuntu 19.10 - darktable master - Macbook pro fin 2013 13"
Répondre
#7
Bonsoir à tous,

En regardant ton historique je vois filmic, donc traitement avec un version darktable 2.6...
Si maintenant tu souhaites reprendre le traitement de cette photo, je te conseil de clic sur "supprimer le traitement" dans la table lumineuse et de re traiter ta photo avec ta version de darktable 3.00
Le Filmic de la version 2.6 est incompatible avec la version 3.00. J'avais rencontré le même souci.
Canon EOS 80D.
Linus Ubuntu 18.04 LTS Gnome / darktable 3.0.0 + master
Répondre
#8
(23-01-20, 18:55)Atriaze a écrit : Bonsoir à tous,

En regardant ton historique je vois filmic, donc traitement avec un version darktable 2.6...
Si maintenant tu souhaites reprendre le traitement de cette photo, je te conseil de clic sur "supprimer le traitement" dans la table lumineuse et de re traiter ta photo avec ta version de darktable 3.00
Le Filmic de la version 2.6 est incompatible avec la version 3.00. J'avais rencontré le même souci.

Bonsoir Atriaze, merci de préciser cela. Dans mes remarques, j'ai oublié de préciser cela.
Aussi appelé Nilvus !
Ubuntu 19.10 - darktable master - Macbook pro fin 2013 13"
Répondre
#9
Bonsoir à tous et merci de vos remarques.

Je dois reconnaître avoir été négligent en soumettant un traitement entaché d'hésitations datant de l'époque ou je bégayais mon darktable.

J'en propose un nouveau (voir liens framadrop ci-après), sans doute plus pertinent.
Mais cela ne change rien au comportement de l'histogramme, toujours verrouillé sur sa gauche. Peut-être dois-je l'oublier si j'obtiens des résultats satisfaisants.

https://framadrop.org/r/gBN-Fh3BZ7#TnYOY...zt7qnv1pkU=

https://framadrop.org/r/fRR44yiqIp#/PiK+...Oii7Im2NV4=


[Image: histogramme.jpg]
Répondre
#10
(23-01-20, 23:56)CATON a écrit : Mais cela ne change rien au comportement de l'histogramme, toujours verrouillé sur sa gauche. Peut-être dois-je l'oublier si j'obtiens des résultats satisfaisants.

Oui curieux quand même.
Ta photo et son développement, ne me donne jamais cet aspect de l'histogramme, que ce soit sous Win10 + dt 3.0 ou sous Linux Manjaro + dt 3.1.0+379, j'ai le même résultat sous les deux OS... d'ailleurs quelque soit les modules utilisés ou pas je n'ai pas cet arrêt brutal à gauche.

[Image: Capture-d-cran-2020-01-24-01-14-18.png]

Et l'affichage en mode linéaire donne aussi une butée ?
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)