Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU] Correction des objectifs: Tamron 24-70 g2
#31
(29-01-20, 18:14)nicoauffray a écrit : Ce problème est vraiment étrange mais après relecture (et tests), lensfun peut être éliminé du problème puisque l'objectif est bien dans la liste. D'ailleurs, darkshot tu le confirme en indiquant que tu as pu le sélectionner. Donc, Lensfun connaît l'objectif. Et si l'info n'est pas mise à jour dans les données de l'image, c'est lié au lien entre le numéro détecté d'objectifs par rapport aux infos connus de la librairie exiv2 installée sur le système.

Par exemple, j'ai testé le premier RAW de darkshot et j'ai le même problème (lensfun est à jour et j'utilise la version master ; exiv2 0.25 sur Ubuntu 19.10) : l'affichage du Canon 300 mm au lieu du Tamron. Pour l'image de la fille que jacotux a trouvé sur le web (boîtier 5D mark IV), pas d'objectif détecté carrément et je peux du coup sélectionner le Tamron dans la liste d'objectifs (donc Lensfun ok mais Exiv2 merde dans la détection de l'objectif, donc ne permet pas à Lensfun de poser la bonne correction d'objectifs).

Voilà déjà pour ce qu'on peut confirmer. Maintenant, sur Exiv2, on voit que la même version peut fonctionner sur Windows et Linux mais pas forcément sur tous les systèmes Linux. Mais ça ne semble pas non plus être un problème de version d'Exiv2 puisqu'à priori rencontré aussi bien sur Exiv2 0.25 que 0.26, 0.27...

Donc il y a autre chose en lien et probablement pas lié à darktable mais peut-être à une configuration d'Exiv2. Là je ne maîtrise pas assez Exiv2 pour aller plus loin mais ça donne une direction pour trouver l'origine de cet étrange bug !

Pour Rawtherapee, je ne suis pas sûr qu'il utilise Exiv2. Je sais qu'il utilise Lensfun ensuite pour la correction d'objectifs comme darktable mais malgré recherches, je n'ai trouvé aucune mention d'Exiv2 qui serait utilisé par Rawtherapee (évidemment, ça ne veut pas dire que Rawtherapee ne l'utilise pas).

J'avais pensé à un problème de correspondance de noms d'objectif entre lensfun et exiv2. Mais apparement non.
Ce qui est assez pénible et frustrant c'est de ne rien comprendre aux 3/4 posts sur le site de exiv2 ( voir post précédent).

[quote pid='38535' dateline='1580320818']


D'après les rapports de bugs cités, la solution serait de créer un fichier '.exiv2' à la racine du dossier utilisateur et d'y coller le code suivant :


[/quote]

Qu'entends-tu par "racine du dossier utilisateur? /home?
Répondre
#32
En faisant la commande suivante adaptée (expliqué sur le lien suivant : https://dev.exiv2.org/issues/1372), aucun "LensID" détectée donc pas de numéro d'identifiant d'objectif détectée. Et comme il détecté un type d'objectif Canon 300mm, par défaut c'est celui-là qui est affiché) :


Code :
Code :
exiv2 -pa --grep Lens fichierimage.cr2

J'insiste mais moi j'ai

[Image: Capture-2020-01-29-19-18-26.png]

Sinon après relecture je me suis mal exprimé avant en parlant de compilation, je ne voudrais pas jeter le trouble..
Bien sûr que la compilation à la main est conduite de la même façon peu importe la lignée de distribution utilisée.
De plus pour darktable nous allons chercher les mêmes sources au même endroit, que ce soit la 3.0 ou la master.

Là où je voulais en venir et là où ça diffère nous avons besoin des dépendances pour que la compilation aille à son terme.
Et ces dépendances nous viennent de nos dépots respectifs et pas forcément toutes aux mêmes versions, tout dépend du cycle de livraison des distri.
Répondre
#33
(29-01-20, 19:22)darkshot a écrit : Ce qui est assez pénible et frustrant c'est de ne rien comprendre aux 3/4 posts sur le site de exiv2 ( voir post précédent).

Qu'entends-tu par "racine du dossier utilisateur? /home?

Euh là, tu m'inquiètes. As-tu lu mes posts ? Je prends le temps de lire les rapports que tu ne comprends pas et t'en résumer ce qui en est important pour ton problème, te proposer une potentielle solution simple à tester (créer ce fichier .exiv2 avec les lignes à copier) et tu te contentes de me renvoyer vers ton post précédent... Sur mon précédent post (le 2ème), je commence quand même par " Je viens en plus de regarder ce qui est indiqué sur les rapports de bugs Exiv2".

Et je suis surpris qu'un truc aussi simple que "racine du dossier utilisateur" ne soit pas clair. Dossier utilisateur, c'est le dossier où tes données persos sont stockées donc pas /home mais le dossier avec ton nom d'utilisateur dans le dossier /home... Et la racine, j'espère que tu connais le sens de ce mot (là c'est du français).

(29-01-20, 19:27)JacoTux a écrit : En faisant la commande suivante adaptée (expliqué sur le lien suivant : https://dev.exiv2.org/issues/1372), aucun "LensID" détectée donc pas de numéro d'identifiant d'objectif détectée. Et comme il détecté un type d'objectif Canon 300mm, par défaut c'est celui-là qui est affiché) :

J'insiste mais moi j'ai

[Image: Capture-2020-01-29-19-18-26.png]

Oui, c'est ce que j'ai précisé, pas de LensID. Mais en prenant les liens que tu avais partagé et en les lisant, tu verras que c'est normal pour cet objectif et que c'est par une autre option de la commande exiv2 que tu obtiens le numéro ID par une ligne LensType.

Après pour ta capture et "j'insiste", je ne vois pas ce que ça apporte. Ok, on a vu que tu as les données mais ça ne change pas le problème.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#34
Citation :Euh là, tu m'inquiètes. As-tu lu mes posts ? Je prends le temps de lire les rapports que tu ne comprends pas et t'en résumer ce qui en est important pour ton problème, te proposer une potentielle solution simple à tester (créer ce fichier .exiv2 avec les lignes à copier) et tu te contentes de me renvoyer vers ton post précédent... Sur mon précédent post (le 2ème), je commence quand même par " Je viens en plus de regarder ce qui est indiqué sur les rapports de bugs Exiv2".

Et je suis surpris qu'un truc aussi simple que "racine du dossier utilisateur" ne soit pas clair. Dossier utilisateur, c'est le dossier où tes données persos sont stockées donc pas /home mais le dossier avec ton nom d'utilisateur dans le dossier /home... Et la racine, j'espère que tu connais le sens de ce mot (là c'est du français).

désolé, moment d'égarement, j'ai passé un bon moment à éplucher plein de trucs et je me suis un peu perdu
...je pensais à un truc à propos de exiv2.
Répondre
#35
@ darkshot > Après pour ta capture et "j'insiste", je ne vois pas ce que ça apporte. Ok, on a vu que tu as les données mais ça ne change pas le problème.

Pas d'énervement, je planche depuis hier soir à essayer de comprendre le problème.
Ben si justement ça change que moi ce problème je ne le vois pas et je ne l'ai pas.

Alors si, je viens de le mettre en évidence sur mon petit EeePC 1011, Linux Mint 19.1, darktable 2.4.2, c'est de l'ancien ok
Pour exiv2 (0.25-3.1ubuntu) néanmoins le retour de la commande est différente que sous ma Manjaro datée en machine virtuelle, elle aussi en exiv2 0.25 et pourtant sur celle-ci aucun problème avec un dt 2.6 !

Là je vois deux lignes absentes ailleurs le Canon EF 300 et en dessous 24.0 - 70.0 mm ???

[Image: Capture-2020-01-29-20-25-35.png]
Répondre
#36
J'ai crée un fichier .exiv2 dans mon home avec le code, mais cela ne change rien. Je continue à chercher. Merci!

Citation :@ darkshot > Après pour ta capture et "j'insiste", je ne vois pas ce que ça apporte. Ok, on a vu que tu as les données mais ça ne change pas le problème.

Pas d'énervement, je planche depuis hier soir à essayer de comprendre le problème.
Ben si justement ça change que moi ce problème je ne le vois pas et je ne l'ai pas.
@jacotux
C'est pas moi!!! Big Grin Cool
Répondre
#37
Bon pour moi la messe est dite.
Je viens d'installer une Xubuntu toute neuve, dernier modèle et juste descendu darktable et ton raw
Ça y est je fais partie de la bande... ça ne fonctionne pas, LOL
M'enfin noyau 4.15, le gestionnaire de fichier en 1.6.15 alors que la dernière version c'est du 1.8.11
On me dira que ça n'a rien à voir mais si le reste est du même topo, hein !
Comme je ne vais pas passer ma soirée à faire le tour de tous les PPA pour avoir quelque chose d'à peu près up to date, j'en reste là.

Comique darktable s'installe sans exiv2

[Image: Capture-d-cran-2020-01-29-21-35-09.png]

Quant on possède un 5D mark IV et un Tamron 28-70 on ne reste pas sous une butinerie quelconque, désolé d'être un peu dur.
Moi aussi je fini par perdre patience
Répondre
#38
Citation :Quant on possède un 5D mark IV et un Tamron 28-70 on ne reste pas sous une butinerie quelconque, désolé d'être un peu dur.
 Désolé pas compris...

Citation :Moi aussi je fini par perdre patience

Ok, merci pour tes contributions!
Répondre
#39
(29-01-20, 21:13)darkshot a écrit : @jacotux
C'est pas moi!!! Big Grin Cool

Désolé à vous deux je n'avais pas vu que nicoauffray avait fait une double réponse
En plus je réponds à coté de la plaque sans réagir à ce que me signifiait nicoauffray au sujet de la commande

J'ai pix comme viewer d'image, moins gourmand en dépendances, j'ai essayé de remonter l'arbre, mais c'est un bout sans fin
Il doit probablement manquer un paquet, un lien symbolique ou je ne sais quoi à l'installation de dt dans une buntu
Ce que voit pix, bon il y en a des pages et des pages si c'est un jpeg dévellopé sous dt on a tout le détail du pipe

[Image: Capture-d-cran-2020-01-29-22-05-02.png]
Répondre
#40
(29-01-20, 22:04)darkshot a écrit :
Citation :Quant on possède un 5D mark IV et un Tamron 28-70 on ne reste pas sous une butinerie quelconque, désolé d'être un peu dur.
 Désolé pas compris...

Le problème vient de la distribution ou plutôt de sa lignée et son mode de paquetage .deb, mais quoi je n'en sais rien.
Très probablement dans les paquets descendus des dépôts demandés comme dépendance.
Chaque lignée voit midi à sa porte et gère l'arbre des dépendances de façon différente.
D'autant que l'on a parfois des versions très décalées de paquets.

Il serait intéressant de savoir si ceux qui travaillent sur une base Red Hat, paquet .rpm ont aussi le même résultat... ou d'autre .tgz (slackware)
Un archer contre trois ou quatre debianistes je me sens en infériorité Cool
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)