Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
[RÉSOLU] Correction des objectifs: Tamron 24-70 g2
#41
Bon, j'ai repris le fil en lisant bien tout.
A priori dans un système Ubuntu vous travaillez avec exiv2 v0.25-3 du 21 juin 2015
En remontant les infos des bugs signalés par nicoauffray je tombe sur celui-ci
- 0001373: Tamron SP 24-70mm F/2.8 Di VC USD not recognized properly

Je crois que c'est clairement dit, problème fixé a partir de la version exiv2 v0.26 du 28 avril 2017
Dit autrement soit attendre une mise à jour sur les dépôts Ubuntu soit compiler une v0.26 ou plus, la v0.27.2 est sortie en juillet 2019
Voir éventuellement ce fil sur pixls.us > https://discuss.pixls.us/t/darktable-on-...is/8587/29
Répondre
#42
J'avais déjà suivi ce fil sans trouver de solution. Je vais voir celui sur PixLs. J'ai aussi réinstallé exiv2 et libexiftool sans succès.

Peut-être une solution provisoire en attendant : https://discuss.pixls.us/t/darktable-on-...is/8587/23?
Répondre
#43
Oui jpg54, mais à votre place plutôt que de bricoler sa distri et surtout pour darkshot qui peut aller chercher à la main son objectif, donc ce n'est pas rédhibitoire, j'attendrais patiemment la Ubuntu 20.04... on en est plus bien loin.
Répondre
#44
Je n'ai pas cet APN ni cet objectif, j'ai participé pour essayer comprendre le pourquoi du comment. Depuis un moment, j'ai supposé qu'il y a un blême avec exiv2.
Répondre
#45
Oui, j'ai vu qu'il faut une version exiv2 0.26 au minimum et c'est pourquoi j'ai proposé de tester la solution du fichier .exiv2 à darkshot qui dis avoir compilé la version 0.27. Donc soit il a compilé cette version mais le paquet exiv2 0.25 était toujours là et en réalité utilisé à la place de sa version compilé. Et dans ce cas, le problème de version est le plus probable, soit c'est bien la version 0.27 qui était utilisé par darkshot et le problème n'est pas là.

Quant à attendre Ubuntu 20.04, à mon avis, c'est une mauvaise idée. Ubuntu cale nombre de ces paquets sur Debian et Debian persiste à utiliser la version 0.25 depuis plusieurs années. Aucune montée en version connue à ce jour, donc à ce stade, j'ai bien peur qu'Ubuntu 20.04 utilise encore exiv2 0.25.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#46
(30-01-20, 09:55)nicoauffray a écrit : Quant à attendre Ubuntu 20.04, à mon avis, c'est une mauvaise idée. Ubuntu cale nombre de ces paquets sur Debian et Debian persiste à utiliser la version 0.25 depuis plusieurs années. Aucune montée en version connue à ce jour, donc à ce stade, j'ai bien peur qu'Ubuntu 20.04 utilise encore exiv2 0.25.

Si darkshot dit avoir compilé la 0.27 et installée il devrait retrouver la même chose que cette ultime intervention de R. Mills, à savoir libexiv2lib.so.... dans ./local/lib

Code :
My Linux VM is Ubuntu 18.04 LTS and it was created a few weeks ago for Exiv2 v0.27 development. So it's mostly unpolluted.
rmills@rmillmbp-ubuntu:/usr$ find . -type f | grep libexiv2 | grep -v -e share
./local/lib/libexiv2lib.so.0.27.0.1  <--- That's the Exiv2 v0.27 RC1 (which I'm developing)
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0 <--- That's Exiv2 v0.25 (delivered by the Linux Gods)
rmills@rmillmbp-ubuntu:/usr$

Je n'avais pas été si loin, effectivement si la Debian scotch encore exiv2 c'est pas top et comme la manip du .exiv2 ne solutionne rien.
Mais est-ce sûr, il vient juste de grimper d'un cran en unstable, peut-être disponible dans les dépôts backport prochainement
Répondre
#47
(30-01-20, 09:55)nicoauffray a écrit : Oui, j'ai vu qu'il faut une version exiv2 0.26 au minimum et c'est pourquoi j'ai proposé de tester la solution du fichier .exiv2 à darkshot qui dis avoir compilé la version 0.27. Donc soit il a compilé cette version mais le paquet exiv2 0.25 était toujours là et en réalité utilisé à la place de sa version compilé. Et dans ce cas, le problème de version est le plus probable, soit c'est bien la version 0.27 qui était utilisé par darkshot et le problème n'est pas là.

Quant à attendre Ubuntu 20.04, à mon avis, c'est une mauvaise idée. Ubuntu cale nombre de ces paquets sur Debian et Debian persiste à utiliser la version 0.25 depuis plusieurs années. Aucune montée en version connue à ce jour, donc à ce stade, j'ai bien peur qu'Ubuntu 20.04 utilise encore exiv2 0.25.

J'ai signalé depuis le début que j'ai compilé soit lensfun que exiv2 ( j'avais déjà vu les rapports de bug et autres posts, et compris qu'il me fallait ces dernières versions)
 J'avais déjà viré exiv2 0.25
Code :
exiv2 --version
exiv2 0.27.2

et: 
Code :
/usr$ find . -type f | grep libexiv2 | grep -v -e share
./local/lib/libexiv2-xmp.a
./local/lib/libexiv2.so.0.27.2
./lib/x86_64-linux-gnu/libexiv2.a
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0
 
Qu'en dites-vous?
Répondre
#48
(30-01-20, 12:01)darkshot a écrit :
Code :
/usr$ find . -type f | grep libexiv2 | grep -v -e share
./local/lib/libexiv2-xmp.a
./local/lib/libexiv2.so.0.27.2
./lib/x86_64-linux-gnu/libexiv2.a
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0
 
Qu'en dites-vous?

Que ça se croise les doigts à cause de

Code :
./lib/x86_64-linux-gnu/libexiv2.a
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0
qui ne devrait plus y être... si j'ai bien compris
Répondre
#49
(30-01-20, 12:16)JacoTux a écrit :
(30-01-20, 12:01)darkshot a écrit :
Code :
/usr$ find . -type f | grep libexiv2 | grep -v -e share
./local/lib/libexiv2-xmp.a
./local/lib/libexiv2.so.0.27.2
./lib/x86_64-linux-gnu/libexiv2.a
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0
 
Qu'en dites-vous?

Que ça se croise les doigts à cause de

Code :
./lib/x86_64-linux-gnu/libexiv2.a
./lib/x86_64-linux-gnu/libexiv2.so.14.0.0
qui ne devrait plus y être... si j'ai bien compris

Oui ./lib/x86_64-linux-gnu/libexiv2.so.14.0.0 c'est du exiv2 0.25...

et là je sèche...

Comment est-ce possible de retomber sur la version 0.25 alors que j'ai compilé la 0.27.2 et viré la 0.25???

Ici il semble que le problème ne soit pas exiv2 mais bien darktable ( ma version de darktable?) qui fait tourner une 0.25

https://dev.exiv2.org/issues/0001373

ou mieux il me faudrait compiler une version de darktable qui comprenne déjà une version supérieure à 0.25.
Répondre
#50
Tu dis avoir viré la 0.25, oui mais comment, même en ligne de commande si Exiv2 v0.25 n'y est plus ses dépendances y sont encore car partagées avec d'autres.
D'où un système pollué comme le dit R. Mills dans l'issue 1373.
Non darktable n'a rien à voir, il prend ce qu'on lui donne.
Regarde du coté des dépôts backport, la exiv2 v0.27 y sera tôt ou tard, l'installation sera plus propre, pas garantie à 100% c'est quand même du rétroportage.
En initialisant les backports tu mets déjà un pied dans la prochaine Ubuntu et comme nous n'en sommes plus bien loin ça devrait descendre une grosse MàJ si tu ne l'as pas déjà fait.
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 2 visiteur(s)