Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Installation darktable stable et à tester
#1
Bonjour les amis,

suite à quelques soucis (détaillés dans deux de mes posts) on m'a dit qu'une partie des bugs était réglée dans la 3.0.1. On m'a aussi dit que cette version 3.0.1 était déjà assez stable. J'aimerais pouvoir l'installer, même si pas finalisée, pour tester et voir lesquels de mes problèmes sont résolus ou pas, et aussi pour pouvoir travailler avec moins de plantages. Mais j'ai beau chercher je ne vois pas comment installer cette version dans l'état actuel. 
Huh
Alors je sais que certains me diront qu'il faut chercher. Je l'ai fait, en français et en anglais, mais je n'ai pas trouvé... en tout cas rien d'assez clair pour un mec comme moi qui utilise Linux et darktable depuis quelques années sans toutefois être un as de la bidouille en terminal et sudo. En fait en cherchant je tombe plutôt souvent sur des infos périmées ou contradictoires. En tout cas rien de clair et net.

J'en profite d'ailleurs pour dire que l'installation de darktable 3.0 est vachement "pas claire" les amis depuis que les PPA Pascal deBruin ne suivent plus le mouvement. On parle de PPA Opensuse, PPA Dhor, PPA Panda Jim, PPA Ubuntuhandbook,... et pour chaque PPA j'ai lu des commentaires disant de ne pas l'installer ou de faire attention. Sans parler de la version 3.0 qui s'installe avec le paquet 2.6.3...

Mettez-vous à la place des nouveaux ... Il y en a beaucoup et c'est formidable. Ce serait dommage de les dégoûter.
A moins que darktable ne soit destinés qu'aux développeurs et bidouilleurs...
Undecided
Suggestions :

- si qq'un pouvait (re)faire un post clair qui servira de référence, en le gardant à jour, sur l'installation actuelle de darktable Linux, version stable et versions à tester,  ce serait vachement utile. (en spécifiant au passage la différence entre 3.0.1 et 3.1 parce que peu de gens connaissent la logique des versions)

- sans oublier de corriger les liens des sites .fr et .org qui pointent où il ne faut pas, (au fait c'est lequel le "bon" PPA ?)

Qu'en pensez-vous ?

Si j'étais capable de le faire, je le ferais. Dans la mesure de mes capacités je suis prêt à aider.

NB: J'ai p.ex. fait un petit tuto sur facebook "darktable 3.0: développer une photo studio sur fond noir"
https://www.facebook.com/yb.bornemann.9/...574&type=3
Yves Bornemann
https://ybphoto.weebly.com/
Linux Mint 20 sur PC + Win10 sur laptop.
Darktable 3.4.1
Nikon Z6
Répondre
#2
(04-02-20, 09:45)spray a écrit : Bonjour les amis,
 
Alors je sais que certains me diront qu'il faut chercher. Je l'ai fait, en français et en anglais, mais je n'ai pas trouvé... en tout cas rien d'assez clair pour un mec comme moi qui utilise Linux et darktable depuis quelques années sans toutefois être un as de la bidouille en terminal et sudo. En fait en cherchant je tombe plutôt souvent sur des infos périmées ou contradictoires. En tout cas rien de clair et net.

Bonsoir spray,

Chercher est la première étape puisque beaucoup de solutions sont déjà disponibles. Après si tu ne trouve pas, c'est autre chose. Par contre, pour ce que tu demande ici, à savoir accéder à la potentielle future 3.0.1 avant qu'elle soit finalisée, ça ne peut passer que par la compilation, donc à coup de terminal et sudo. Et là les règles de compilation existent, elles n'ont pas changé depuis la version 2.6 et se trouvent sur le forum, en version anglaise et précise ici : https://redmine.darktable.org/projects/d..._darktable

Et si besoin, depuis longtemps, de l'aide est possible via framateam.org sur les canaux de discussion darktable, pour te guider dans la compilation.

(04-02-20, 09:45)spray a écrit : J'en profite d'ailleurs pour dire que l'installation de darktable 3.0 est vachement "pas claire" les amis depuis que les PPA Pascal deBruin ne suivent plus le mouvement. On parle de PPA Opensuse, PPA Dhor, PPA Panda Jim, PPA Ubuntuhandbook,... et pour chaque PPA j'ai lu des commentaires disant de ne pas l'installer ou de faire attention. Sans parler de la version 3.0 qui s'installe avec le paquet 2.6.3...

Mettez-vous à la place des nouveaux ... Il y en a beaucoup et c'est formidable. Ce serait dommage de les dégoûter.

A moins que darktable ne soit destinés qu'aux développeurs et bidouilleurs...

Il faut comprendre (ça a déjà été dit) que les intervenants sur darktable sont des passionnées qui font ça sur leur temps libre, que quand on parle de la disponibilité d'une version, c'est en fait le code source validé pour une version. Après il reste à faire les paquets compilés pour une installation plus facile. Et ça ça dépend des bonnes volontés des mainteneurs de paquets. Et Linux a un inconvénient : la multiplicité des distributions et versions de distributions qui impliquent à peu près autant de paquets nécessaires à créer. Et ça ça prend du temps à faire et vérifier que tout est ok.

Ce n'est pas pour embêter les nouveaux ou compliquer l'accès, ça dépend simplement de la disponibilité, compétences, temps et volonté de ceux qui s'en chargent ou sont prêts à le faire. Et comme c'est sur son temps libre que chacun intervient, de manière bénévole et volontaire donc, chacun reste (heureusement) libre de son temps libre.

Ca a l'inconvénient en effet parfois de ne pas toujours avoir les bons paquets disponibles rapidement, il faut l'accepter. Il n'y aucune volonté de quelque sorte ici, seulement cette réalité et ces conséquences.

Donc, non, darktable n'est pas pour les bidouilleurs et développeurs uniquement et la version 3.0 est même plus simple pour les nouveaux. Mais par contre, on fait à hauteur des moyens des volontaires participant à l'aventure darktable et du temps libre qu'ils sont prêts (peuvent et veulent) à accorder. Rien de plus. Pas d'autre intention ici.

Et de fait, il n'est par contre pas pour les utilisateurs voulant quelque chose de disponible dès qu'ils le veulent, comme ils le veulent et en quelques clics simples, non pas parce qu'on ne le veut pas mais encore une fois simplement la conséquence de tout ça : derrière un logiciel libre comme darktable, juste des passionnés bénévoles sans obligation ni de moyen ni de résultats (mais souhaitant quand même faire au mieux de leurs possibilités) ; pas comme une société commerciale en tout cas qui pourrait/devrait avoir ces obligations.

Pour le PPA, de ceux que tu as cité, je ne connais que ceux d'Opensuse, dhor et ubuntuhandbook. Le dernier est clairement à éviter, les 2 autres sont normalement ok. J'ai signalé il y a 2 ou 3 jours que le PPA Opensuse était désormais ok. Voir mon fil sur les paquets 3.0 disponibles dans la rubrique "Actualité de darktable".

(04-02-20, 09:45)spray a écrit : Suggestions :

- si qq'un pouvait (re)faire un post clair qui servira de référence, en le gardant à jour, sur l'installation actuelle de darktable Linux, version stable et versions à tester,  ce serait vachement utile. (en spécifiant au passage la différence entre 3.0.1 et 3.1 parce que peu de gens connaissent la logique des versions)

- sans oublier de corriger les liens des sites .fr et .org qui pointent où il ne faut pas, (au fait c'est lequel le "bon" PPA ?)

Qu'en pensez-vous ?


Pour la 1ère suggestion, j'y ai répondu plus haut.

Pour la 2ème : ok, mais encore faudrait-il que les liens à corriger soient connus ? Lesquels ? J'ai déjà eu l'occasion d'en corriger mais je ne passe pas ma vie à refaire les pages que je connais déjà pour vérifier si les liens fonctionnent. Et comme on ne nous signale pas les liens qui fonctionnent...

En bref, beaucoup d'infos sont déjà là !
Aussi appelé Nilvus !
Debian Sid - darktable master
Répondre
#3
Merci NicoAuffray pour tes réponses,


oui je me doute que ce n'est pas évident de faire tout ça en plus de tout ce que vous, les développeurs, faites déjà...

J'ai regardé le lien que tu as passé pour compiler la v.3.0.1. J'aurais bien voulu endosser le rôle de testeur pour modestement vous aider mais bon, j'avoue que c'est trop compliqué pour moi.
Confused
Yves Bornemann
https://ybphoto.weebly.com/
Linux Mint 20 sur PC + Win10 sur laptop.
Darktable 3.4.1
Nikon Z6
Répondre
#4
J'essaie de motiver du monde pour fournir des paquest appimages (qui ne nécessitent pas d'installation) de la version 3.1/master. On va voir si le lobbying fonctionne.

À terme, ça permettrait, sous Linux, de seulement télécharger l'appimage, de double-cliquer dessus et de lancer le logiciel, sans avoir à désinstaller la version stable. Puis de recommencer chaque semaine pour suivre les nouveaux développements.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
Répondre
#5
(05-02-20, 00:26)aurelienpierre a écrit : J'essaie de motiver du monde pour fournir des paquest appimages (qui ne nécessitent pas d'installation) de la version 3.1/master. On va voir si le lobbying fonctionne.

À terme, ça permettrait, sous Linux, de seulement télécharger l'appimage, de double-cliquer dessus et de lancer le logiciel, sans avoir à désinstaller la version stable. Puis de recommencer chaque semaine pour suivre les nouveaux développements.

Wouaw ça serait génial !
Yves Bornemann
https://ybphoto.weebly.com/
Linux Mint 20 sur PC + Win10 sur laptop.
Darktable 3.4.1
Nikon Z6
Répondre
#6
Effectivement, une excellente idée pour agrandir l'accessibilité aux bêta-testeurs qui ne peuvent pas compiler d'avoir accès à une version de darktable master fonctionnelle.
Répondre
#7
(05-02-20, 00:26)aurelienpierre a écrit : J'essaie de motiver du monde pour fournir des paquest appimages (qui ne nécessitent pas d'installation) de la version 3.1/master. On va voir si le lobbying fonctionne.

À terme, ça permettrait, sous Linux, de seulement télécharger l'appimage, de double-cliquer dessus et de lancer le logiciel, sans avoir à désinstaller la version stable. Puis de recommencer chaque semaine pour suivre les nouveaux développements.

Il existe déjà un flatpak sur flathub.org (mais en version 2.6) qui présente les mêmes avantages. Souhaitons qu'il soit mis à jour en version 3.
Heureux utilisateur de la Fedora Silverblue, c'est le principal mode d'installation des applis. Et d'aucuns prédisent que ce sera la future Fedora-IBM, donc une large promotion est à prévoir pour ce type de paquet. Sur cette distrib, la version 3.0 est disponible en container docker/podman
Répondre
#8
Flatpak, c'est autre chose. Personnellement, je trouve ça épouvantable comme idée, en tant que gestionnaire de paquet de base. C'est le pire de Windows marié au pire de Linux dans un même produit.

L'idée ici, c'est bien d'avoir un appimage de la version instable, pour permettre plus de béta-tests avant de publier une version.

Pour les versions stables, les paquets de vos distros sont la façon la plus sécurisée d'obtenir vos logiciels et de garder un système propre.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
Répondre
#9
(05-02-20, 15:25)aurelienpierre a écrit : Flatpak, c'est autre chose. Personnellement, je trouve ça épouvantable comme idée, en tant que gestionnaire de paquet de base. C'est le pire de Windows marié au pire de Linux dans un même produit.

L'idée ici, c'est bien d'avoir un appimage de la version instable, pour permettre plus de béta-tests avant de publier une version.

Pour les versions stables, les paquets de vos distros sont la façon la plus sécurisée d'obtenir vos logiciels et de garder un système propre.

Linuxien depuis plus de 20 ans, je ne peux adhérer à cette comparaison avec la daube. En tous cas et sans vouloir lancer un troll, ils sont tous les deux affectés de défauts qui pourraient amener à cette même comparaison...A noter cependant, que le flatpak est dans un bac à sable et qu'on peut lancer des versions concurrentes, ce qui n'est pas négligeable pour les versions instables.
Répondre
#10
Je suis de l'avis d'Aurélien Pierre pour flatpak  c'est monstrueux : plus de 2 go sur le disque pour un seul logiciel, donc à éviter

En ce moment j'utilise sans trop de problème 3.1 même en tant que débutant que je trouve ici 
https://software.opensuse.org/download.h...=darktable

Le plus difficile est de se documenter sur ce qui est nouveau, mais je considère que c'est mon problème suite à mon choix de documenter pour mon usage et ma propre compréhension (puis pour les autres autour de moi) mon appropriation de dt en mode RVB linéaire. Ça avance, avec 3 ou 4 opérations dont filmique j'arrive à produire une photo prise dans un musée bien mieux que le jpg ! Je vais donc pouvoir compléter la doc que j'ai entrepris  à partir de ce que j'ai  lu ou vu dans les forums et blogs et le manuel (j'ai hâte au manuel v3)

Je vis un peu les mêmes difficultés que spray, l'abord de dt pour un non connaissant (c'est pas la même chose qu'un nul) est difficile, il faut s'accrocher et je continue à penser qu'il ne faut pas demander aux développeurs clés qui font un travail formidable de prendre en charge tous les gens comme moi c'est trop chronophage, mais il faut que des membres de la communauté le fassent. Ils sont tellement dans leur logiciel qu'ils n'ont même plus idée de ce sur quoi le novice bloque et c'est tout à fait normal. C'est pourquoi je pense qu'il faut que quelques uns documentent leur apprentissage (pas dans tous ses méandres bien sûr) car une fois fait ils les oublient.

Pour le moment mon effort personnel c'est ici https://pascot.ca/labo/, si ça peut aider tant mieux, sinon en le faisant j'apprends beaucoup (naturellement j'ai commencé par le plus simple, la table lumineuse)
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)