Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Pb base de données version dev
#1
Bonsoir à tous,

J'ai fait une bourde...
En fin d'année 2019, j'avais installé la version de développement de darktable par le biais du dépôt prévu à cet effet. Ceci afin de travailler avec filmique RVB, ayant arrêté de développer toutes mes photos depuis quasiment un an puisque je ne m'en sortais pas avec filmique.
Problème à la sortie de la version finale 3.0.0, j'ai oublié de désactiver le dépôt source lié au développement de darktable. Ce week-end j'ai eu une erreur de clé concernant ce dépôt. Je l'ai donc supprimé.
Et je me suis dit autant refaire les choses proprement. J'ai donc sauvegardé ma base construite avec la version de développement. J'ai désinstallé darktable dev. J'ai installé la version 3.0.0 officielle.
J'ai voulu commencer à réimporter mes images dossier par dossier, et bien il ne lit pas les xmp pour les images traitées à partir de la version de dev, l'historique est vide (8 modules par défaut)...
Est-ce normal ? Suis-je contraint à remettre une version de développement pour pouvoir retrouver mes développements ou existe-t-il une astuce pour lire ces xmp ?

Merci pour votre aide
darktable 3.6.0 - Ubuntu 21.04
Répondre
#2
Bonsoir. Il est fréquent qu'une nouvelle version entraîne des évolutions de la base de données et des XMP donc en général une image traité avec une version supérieure n'est pas lisible correctement avec une version précédente. Tout ça dépend avant tout des évolutions proposées. Maintenant la version 3.0.1 est peut-être ok pour tes développements (tout dépend de la dernière version master que tu as utilisé), sinon la version de développement actuelle est très stable et plus que la 3.0.0 selon moi. Et tu n'es pas obligé ensuite de mettre à jour la version de développement.
Aussi appelé Nilvus !
Debian Sid - darktable master
Répondre
#3
(09-03-20, 23:20)nicoauffray a écrit : Bonsoir. Il est fréquent qu'une nouvelle version entraîne des évolutions de la base de données et des XMP donc en général une image traité avec une version supérieure n'est pas lisible correctement avec une version précédente. Tout ça dépend avant tout des évolutions proposées. Maintenant la version 3.0.1 est peut-être ok pour tes développements (tout dépend de la dernière version master que tu as utilisé), sinon la version de développement actuelle est très stable et plus que la 3.0.0 selon moi. Et tu n'es pas obligé ensuite de mettre à jour la version de développement.

Merci Nicoauffray,
J'ai essayé d'installer la version proposée par pascal, j'ai eu une erreur lors du make. J'ai pas creusé plus. Il faut que je retente..

EDIT : Installation version 3.0.1 réussie, (un problème récurrent concernant rawspeed que je n'arrive pas à comprendre). Le problème est le même qu'avec la version 3.0.0, les développements effectués à partir d'une certaine date (fin janvier peut-être) ne sont pas lisibles, pas très grave.
darktable 3.6.0 - Ubuntu 21.04
Répondre
#4
(09-03-20, 23:35)Olivier-40 a écrit :
(09-03-20, 23:20)nicoauffray a écrit : Bonsoir. Il est fréquent qu'une nouvelle version entraîne des évolutions de la base de données et des XMP donc en général une image traité avec une version supérieure n'est pas lisible correctement avec une version précédente. Tout ça dépend avant tout des évolutions proposées. Maintenant la version 3.0.1 est peut-être ok pour tes développements (tout dépend de la dernière version master que tu as utilisé), sinon la version de développement actuelle est très stable et plus que la 3.0.0 selon moi. Et tu n'es pas obligé ensuite de mettre à jour la version de développement.

Merci Nicoauffray,
J'ai essayé d'installer la version proposée par pascal, j'ai eu une erreur lors du make. J'ai pas creusé plus. Il faut que je retente..

EDIT : Installation version 3.0.1 réussie, (un problème récurrent concernant rawspeed que je n'arrive pas à comprendre). Le problème est le même qu'avec la version 3.0.0, les développements effectués à partir d'une certaine date (fin janvier peut-être) ne sont pas lisibles, pas très grave.

La librairie rawspeed est une librairie utilisée par darktable pour lire les fichiers RAW (les reconnaître en gros). Elle indépendante du développement du logiciel (même si liée) et du coup, il est en effet important de lancer une commande de mise à jour avant de compiler (pour t'assurer de la dernière version notamment). C'est via 'git submodule update' (en considérant qu'une 'git submodule init' a été fait, à faire une seule fois sur le dossier de compil). J'espère que ça éclaire ta compréhension de cela.

Pour tes développements effectués non lisibles, ça ça veut dire que tu as dû utiliser une version de master avec des évolutions prévues pour la prochaine version majeure (la 3.2 pour Noël prochain) et forcément ce n'est pas lisible.
Aussi appelé Nilvus !
Debian Sid - darktable master
Répondre
#5
J'ai retenté une installation propre avec la procédure indiquée ici :https://darktable.fr/2020/03/sortie-de-darktable-3-0-1/
Tout a fonctionné sauf la deuxième commande $ git cd darktable que j'ai remplacée par ça $ cd darktable
Et surtout git submodule init et git submodule update avant la dernière commande
Je reprends mes traitements qui se sont perdus, ça fait de l'exercice Smile
Merci bien
darktable 3.6.0 - Ubuntu 21.04
Répondre
#6
@Olivier-40 : ça s'appelle une coquille le git avant cd darktable. @aurelienpierre : si tu passe par là, je me suis permis de corriger cette coquille sur ton article.
Aussi appelé Nilvus !
Debian Sid - darktable master
Répondre
#7
Ok, merci bien.
darktable 3.6.0 - Ubuntu 21.04
Répondre
#8
raaah, moi stupide. Tu as bien fait Nicolas, merci.
Aurélien, photographe portraitiste, spécialiste calcul.
Développeur de filmique, égaliseur de tons, balance couleur, etc.
darktable est mon métier, pensez à m'aider :
[Image: 2FAd4rc]
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)