Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Thread Contributor: jean935Installation Darktable 3.0.2 sur Linux Mint 18.2 (Sylvia)
#1
Le gestionnaire de logiciels sur mon ordinateur équipé de Linux Mint, ne possède que la version 2.4.4 de Darktable. J'ai voulu installer la version 3.0.2 par opensuse en exécutant les commandes données pour XUbuntu 18.4. Le processus se plante sur la commande sudo apt update :

Err :4 http://download.opensuse.org/repositorie...untu_18.04 InRelease
Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 040524A84C70D8B5
Réception de :10 http://archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages [1 161 kB]
Réception de :11 http://archive.ubuntu.com/ubuntu xenial-updates/main i386 Packages [928 kB]
Lecture des listes de paquets... Fait
W: Erreur de GPG : http://download.opensuse.org/repositorie...untu_18.04 InRelease : Les signatures suivantes n'ont pas pu être vérifiées car la clé publique n'est pas disponible : NO_PUBKEY 040524A84C70D8B5
E: Le dépôt http://download.opensuse.org/repositorie...untu_18.04 InRelease n'est pas signé.
N: Les mises à jour depuis un tel dépôt ne peuvent s'effectuer de manière sécurisée, et sont donc désactivées par défaut.
N: Voir les pages de manuel d'apt-secure(8) pour la création des dépôts et les détails de configuration d'un utilisateur.
p { margin-bottom: 0.25cm; line-height: 120% }

De ce fait à l'installation par 'sudo apt install darktable' le système me dit que j'ai la dernière version, à savoir la 2.4.4 !

Comment résoudre ce probème SVP ? Merci d'avance.
Répondre
#2
Il faut suivre les étapes de cette page : https://software.opensuse.org/download.h...=darktable.

Tu clique sur l'icône Ubuntu puis sur Ajouter le dépôt et installer manuellement. C'est la 2ème ligne liée à Ubuntu 18.04 (qui commence par wget) qui te manque pour récupérer la clé de vérification du dépôt et paquets.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#3
(18-06-20, 16:31)nicoauffray a écrit : Il faut suivre les étapes de cette page : https://software.opensuse.org/download.h...=darktable.

Tu clique sur l'icône Ubuntu puis sur Ajouter le dépôt et installer manuellement. C'est la 2ème ligne liée à Ubuntu 18.04 (qui commence par wget) qui te manque pour récupérer la clé de vérification du dépôt et paquets.

Comme je l'ai écrit j'ai bien suivi la page que vous indiquez, j'ai tapé les quatre commandes et constaté que ça ne marchait pas. wget était dedans et, si j'ai bien compris, a eu pour effet de rajouter darktable dans le répertoire '/etc/apt/trusted.gpg.d' !
Répondre
#4
(18-06-20, 16:41)jean935 a écrit : Comme je l'ai écrit j'ai bien suivi la page que vous indiquez, j'ai tapé les quatre commandes et constaté que ça ne marchait pas. wget était dedans et, si j'ai bien compris, a eu pour effet de rajouter darktable dans le répertoire '/etc/apt/trusted.gpg.d' !

Pourtant, c'est bien cette ligne qui concerne le problème et le lien indiqué du dépôt n'est pas tout à fait le même, donc ne permettait pas d'être sûr que ce soit ces lignes que vous aviez utilisé.

Je viens de réaliser un truc : Mint 18.2 est basé sur Ubuntu 16.04 (https://www.linuxmint.com/rel_sonya_cinn...atsnew.php) et non pas 18.04 donc c'est normal que ce dépôt ne fonctionne pas. Il faudrait mettre à jour Mint sur une distribution plus récente. Et darktable ne peut pas être installé sur une version antérieur, notamment du fait de la librairie Gtk utilisée pour l'interface graphique de la 3.0.0 et +.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#5
J'ai tapé ces quatre commandes :

echo 'deb http://download.opensuse.org/repositorie...ntu_18.04/ /' | sudo tee /etc/apt/sources.list.d/graphics:darktableConfusedtable.list
sudo wget -nv https://download.opensuse.org/repositori...elease.key -O "/etc/apt/trusted.gpg.d/graphics:darktableConfusedtable.asc"
sudo apt update
sudo apt install darktable

Je crois comprendre que la commande 'apt update' devrait tenir compte de ce qu'il y a dans 'etc/apt/trusted.gpg.d' pour y faire confiance mais elle ne ferait pas ?
Undecided

Nota : j'ai un autre ordinateur avec UBUNTU 18.04 et la mise à jour a fonctionné...

(18-06-20, 16:49)nicoauffray a écrit :
(18-06-20, 16:41)jean935 a écrit : Comme je l'ai écrit j'ai bien suivi la page que vous indiquez, j'ai tapé les quatre commandes et constaté que ça ne marchait pas. wget était dedans et, si j'ai bien compris, a eu pour effet de rajouter darktable dans le répertoire '/etc/apt/trusted.gpg.d' !

Pourtant, c'est bien cette ligne qui concerne le problème et le lien indiqué du dépôt n'est pas tout à fait le même, donc ne permettait pas d'être sûr que ce soit ces lignes que vous aviez utilisé.

Je viens de réaliser un truc : Mint 18.2 est basé sur Ubuntu 16.04 (https://www.linuxmint.com/rel_sonya_cinn...atsnew.php) et non pas 18.04 donc c'est normal que ce dépôt ne fonctionne pas. Il faudrait mettre à jour Mint sur une distribution plus récente. Et darktable ne peut pas être installé sur une version antérieur, notamment du fait de la librairie Gtk utilisée pour l'interface graphique de la 3.0.0 et +.

Merci pour ce complément. Je pensais que les numéros de UBUNTU et MINT étaient les mêmes. Mais je m'étonnais d'avoir Darktable 2.6.2 dans la bibliothèque de mon ordi UBUNTU 18.04 et Darktable 2.4.4 dans celle de MINT 18.02.
Je vais essayer de monter en grade MINT. Et dire qu'avant j'avais pourtant fait une mise à niveau car j'étais en MINT 16 ! Rolleyes
Répondre
#6
(18-06-20, 17:01)jean935 a écrit : Merci pour ce complément. Je pensais que les numéros de UBUNTU et MINT étaient les mêmes. Mais je m'étonnais d'avoir Darktable 2.6.2 dans la bibliothèque de mon ordi UBUNTU 18.04 et Darktable 2.4.4 dans celle de MINT 18.02.
Je vais essayer de monter en grade MINT. Et dire qu'avant j'avais pourtant fait une mise à niveau car j'étais en MINT 16 ! Rolleyes

Ubuntu se base sur l'année et le mois de sortie. Donc 18.04 = sortie en avril 2018. Par contre, Mint, c'est visiblement simplement un ordre de sortie entre versions, indépendamment de l'année (à priori, c'est plus aléatoire mais je ne maîtrise pas la numérotation Mint). En tout cas, Mint 20 va pas tarder de sortir (actuellement en beta de ce que j'ai vu et on est bien en 2020. Mais Mint 18.02 date de 2017.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#7
Bonjour.

Ce n'est pas vraiment une réponse mais comme je n'ai pas réussi non plus à mettre à jour mes repositories pour installer la dernière version de darktable (qui n'est de toutes manières que la 3.0.1 disponible par ce biais il me semble) je suis allé chercher l'archive de la 3.0.2 ici https://github.com/darktable-org/darktab...ease-3.0.2 puis je l'ai recompilée chez moi en suivant la procédure pour compiler darktable.
Ca fonctionne très bien.
Et une fois qu'on en est là, tant qu'à faire, on peut commencer à s'amuser avec la version master...
HTH.
Mathias.
Répondre
#8
(18-06-20, 17:13)margu a écrit : Bonjour.

Ce n'est pas vraiment une réponse mais comme je n'ai pas réussi non plus à mettre à jour mes repositories pour installer la dernière version de darktable (qui n'est de toutes manières que la 3.0.1 disponible par ce biais il me semble) je suis allé chercher l'archive de la 3.0.2 ici https://github.com/darktable-org/darktab...ease-3.0.2 puis je l'ai recompilée chez moi en suivant la procédure pour compiler darktable.
Ca fonctionne très bien.
Et une fois qu'on en est là, tant qu'à faire, on peut commencer à s'amuser avec la version master...
HTH.
Mathias.

Malheureusement, ça ne fonctionnera pas sur une distribution antérieure à une 18.04. darktable 3.0, pour gérer les améliorations graphiques, nécessite Gtk+ 3.22 au minimum.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#9
Euh oui pardon j'avais pas bien lu tous les posts mais même sur une distribution s'appuyant sur Ubuntu 20.04 la version 3.0.2 de darktable ne s'installe pas par un simple apt install. Il me semble qu'on récupère une 3.0.1.
Répondre
#10
Je ne sais pas comment je me suis débrouillé mais j'ai bien Darktable 3.0.2 sur mon UBUNTU 18.4 !

Pour MINT, d'abord j'ai la version 18.3 et non pas, comme je l'avais écrit, la 18.2. Il me faut donc passer à la version 19 mais, comme on me met en garde sur la nécessité de faire des sauvegardes, je repousse cette opération risquée...

La suite un autre jour.

Considérant que la solution est de passer à MINT 19, je marquerais bien ce sujet comme résolu, mais je ne suis pas capable de trouver comment faire !
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)