Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
DT 3.2.1 erreur à l'ouverture
#1
Bonjour.
DT 3.2.1 ne démarre pas car erreurs des fichiers data et library.
Effectivement en passant sur la nouvelle version, les deux versions était présente dans le dossier.
Même en supprimant tous ces fichiers, Darktable démarre normalement.
Puis au prochain démarrage ordi, même problème qui réapparaît.
J'avais déjà ce problème quelque fois sous les version 3.0.
Maintenant même en supprimant les fichiers data et library, ce problème revient tout les jours.
[Image: dt-erreur.png]

Avez une solution à me proposer svp?
Voir PJ pour message d'erreur et configuration ordinateur.
Cordialement.
Boîtier X-T1
Carte SD Sandisk Extreme PRO 16 Go
XF 16mm F 2.8
XF 50mm F 2
Darktable sous Linuxmint 20 cinnamon
Version cinnamon 4.6.7
Noyau linux 5.4.0-42-generic
Carte graphique ATI Radeon RX 550
Répondre
#2
La première ligne renvoie au problème (très) classique du verrou, qui n'est pas relâché quand dt n'est pas fermé correctement.

Trouves-tu des fichiers $HOME/.config/darktable/*.lock ?

Si oui, et si dt n'est pas lancé (a priori non), tu peux les supprimer.
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#3
(16-08-20, 09:10)manu a écrit : La première ligne renvoie au problème (très) classique du verrou, qui n'est pas relâché quand dt n'est pas fermé correctement.

Trouves-tu des fichiers $HOME/.config/darktable/*.lock ?

Si oui, et si dt n'est pas lancé (a priori non), tu peux les supprimer.

Non il y a rien dans le fichier darktable en question.
voir PJ
[Image: direction-vers-dt.png]
Boîtier X-T1
Carte SD Sandisk Extreme PRO 16 Go
XF 16mm F 2.8
XF 50mm F 2
Darktable sous Linuxmint 20 cinnamon
Version cinnamon 4.6.7
Noyau linux 5.4.0-42-generic
Carte graphique ATI Radeon RX 550
Répondre
#4
Ah OK, ce n'est pas le bon chemin.

Regarde dans le 1er screenshot, le $HOME/.var/app...
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#5
(16-08-20, 10:09)manu a écrit : Ah OK, ce n'est pas le bon chemin.

Regarde dans le 1er screenshot, le $HOME/.var/app...

Je supprime a chaque fois les 3 fichiers data et les 3 fichiers library.
A ce moment DT démarre impecable.
Mais quand je démarre mon ordi le jour suivant, le mss d'erreur revient et rebelote.
Comme à chaque fois je réimporte mes photos, est-ce du peut être à un fichier corronpu ou xmp?
Voir PJ
[Image: dt-lock.png]
Boîtier X-T1
Carte SD Sandisk Extreme PRO 16 Go
XF 16mm F 2.8
XF 50mm F 2
Darktable sous Linuxmint 20 cinnamon
Version cinnamon 4.6.7
Noyau linux 5.4.0-42-generic
Carte graphique ATI Radeon RX 550
Répondre
#6
Mais est-ce que si, quand le message d'erreur apparaît, tu fermes dt, supprimes les deux fichiers .lock de ce dossier que tu montres et relances dt, il y a le même message d'erreur ?
Ces deux fichiers data.db.lock et library.db.lock sont les verrous mentionnés dans le message d'erreur.

Je veux dire, juste ces deux fichiers, pas les autres.
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#7
(16-08-20, 11:08)manu a écrit : Mais est-ce que si, quand le message d'erreur apparaît, tu fermes dt, supprimes les deux fichiers .lock de ce dossier que tu montres et relances dt, il y a le même message d'erreur ?
Ces deux fichiers data.db.lock et library.db.lock sont les verrous mentionnés dans le message d'erreur.

Je veux dire, juste ces deux fichiers, pas les autres.

En supprimant ces deux fichiers, il démarre comme il faut, merci!
Par contre j'ai remarquer que DT a fermer suite au chargement d'un dossier photo sur la table lumineuse.
J'ai pu supprimer ce dossier et faire plusieurs essais de démarrage rajout de mes styles et pré réglage.
Tout à l'air de démarrer et fonctionner comme il faut.
Peut être des images corrompu ou incompatibilité avec la nouvelle version?
Par contre sur des photos traité avec les anciennes version, des bug apparaisse sur ces fichier tant en table lumineuse qu'a l'affichage dans la chambre noir.
Dans ces anciens dossiers, les images qui s'affiche bien, non plus mes traitements photos, et les images qui bug ont mes traitements photos.
Cela veut dire qu'à chaque fois que l'on change de version DT, il faut que je refasse les retouches sur les anciennes images?
Est-ce normal?
voir PJ
[Image: bug-affichage.png]
Boîtier X-T1
Carte SD Sandisk Extreme PRO 16 Go
XF 16mm F 2.8
XF 50mm F 2
Darktable sous Linuxmint 20 cinnamon
Version cinnamon 4.6.7
Noyau linux 5.4.0-42-generic
Carte graphique ATI Radeon RX 550
Répondre
#8
OK, c'était donc ce qui était explicitement écrit au point 3 du message affiché. :-)

En définitive, dt se plantait et donc laissait ses verrous en place. Le grand classique déjà évoqué plein de fois ici. J'ai pour ma part écrit un script pour lancer dt qui fait le boulot à ma place, c'est à dire vérifie l'existence ou non d'une instance dt et selon m'informe ou dégage les verrous résiduels.

Pour l'autre problème (peut-être ouvrir un autre sujet), la réponse est non ce n'est pas normal, et personnellement je n'ai pas d'idée sur la cause.
Ubuntu 20.04 + dt stable depuis 3.6
Pentax K-3 II + objectifs Pentax et Sigma

Répondre
#9
Thumbs Up 
(16-08-20, 12:53)manu a écrit : OK, c'était donc ce qui était explicitement écrit au point 3 du message affiché. :-)

En définitive, dt se plantait et donc laissait ses verrous en place. Le grand classique déjà évoqué plein de fois ici. J'ai pour ma part écrit un script pour lancer dt qui fait le boulot à ma place, c'est à dire vérifie l'existence ou non d'une instance dt et selon m'informe ou dégage les verrous résiduels.

Pour l'autre problème (peut-être ouvrir un autre sujet), la réponse est non ce n'est pas normal, et personnellement je n'ai pas d'idée sur la cause.

Merci bcp pour ton aide. Cool Cool
Je verrai une prochaine fois pour les anciennes photos.
Je peux retourner à mes développement photo! Big Grin
Boîtier X-T1
Carte SD Sandisk Extreme PRO 16 Go
XF 16mm F 2.8
XF 50mm F 2
Darktable sous Linuxmint 20 cinnamon
Version cinnamon 4.6.7
Noyau linux 5.4.0-42-generic
Carte graphique ATI Radeon RX 550
Répondre
#10
Bonjour cedbarret

Pour les bugs d'affichage concernant des images déjà travaillées dans dt, je n'en ai trouvé qu'une seule, une image que j'avais clonée pour faire de multiples essais de styles.
[Image: darktable3-2-1-pb-table-lumineuse.png]

En parcourant l'historique j'ai remarqué deux choses :
- aucune mention ni de la courbe de base, ni de filmique : étrange, mais je ne me souviens plus en détail de ce que j'avais fait sur cette photo
- les problèmes d'affichage bizarre surviennent à partir de "table correspondance couleur"
[Image: darktable3-2-1-pb-chambre-noire.png]

Je mets le RAW et le .xmp associé à disposition, si ça peut aider quelqu'un à comprendre ce qui se passe...
http://www.mediafire.com/folder/zyi3eqqj...n23/shared

PS : comme je n'avais qu'une seule image touchée, il m'a suffi de réinitialiser le traitement et tout roule (en prime avec filmique v4 vraiment génial par défaut Smile ). Ce sera peut-être plus embêtant pour ceux qui auraient de nombreux traitements à reprendre
G.Eco
Joujoux : Canon EOS 6D Mark II & 60D / Fujifilm X100V
Cailloux : Canon EF 50 f1.8 II / EF 24-105 f4 L IS USM II / EF 70-200 f4 L IS USM / Tokina AT-X 11-16 f2.8 DX
Dans les choux avec : dt 3.4.1 sous Linux Mint 20.1 Ulyssa
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)