Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
encore un probleme installation opencl [ resolu]
#1
bonjour

suite à des plantages de linux mint  19  19.3 et 20  j'ai décidé d'installer lmde4 la version  debian.    
mais la version  de darktable dans les dépots  debian  est la 2.6  j'ai donc installé   en flatpack et là j'ai la version récente...

en installant opencl  via la methode à jpg   dans le sujet  : https://forums.darktable.fr/showthread.php?tid=4029  dans synaptic  j'ai pas de paquet libnivdia-compute   ni de paquet ocl-icd-libopencl-dev
Code :
ii  libnvidia-compute-430:amd64                                 430.26-0ubuntu0.18.04.2              amd64        NVIDIA libcompute package
ii  libnvidia-compute-430:i386                                  430.26-0ubuntu0.18.04.2              i386         NVIDIA libcompute package
 
j'ai fait une recherche  sur nvidia-compute sur internet  pour lmde  (et donc debian).   et j'ai   rien trouvé.     

la liste  des paquets installés  avec le pilote proprietaire nvidia.   

et aussi   est ce que le fait d'installer enb flatpack peut bloquer le opencl ? 

Code :
patrick@patrick-sedatech ~ $ dpkg -l | grep nvidia
ii  glx-alternative-nvidia                1.0.0                               amd64        allows the selection of NVIDIA as GLX provider
ii  libegl-nvidia0:amd64                  418.152.00-1                        amd64        NVIDIA binary EGL library
ii  libegl-nvidia0:i386                   418.152.00-1                        i386         NVIDIA binary EGL library
ii  libgl1-nvidia-glvnd-glx:amd64         418.152.00-1                        amd64        NVIDIA binary OpenGL/GLX library (GLVND variant)
ii  libgl1-nvidia-glvnd-glx:i386          418.152.00-1                        i386         NVIDIA binary OpenGL/GLX library (GLVND variant)
ii  libgles-nvidia1:amd64                 418.152.00-1                        amd64        NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia1:i386                  418.152.00-1                        i386         NVIDIA binary OpenGL|ES 1.x library
ii  libgles-nvidia2:amd64                 418.152.00-1                        amd64        NVIDIA binary OpenGL|ES 2.x library
ii  libgles-nvidia2:i386                  418.152.00-1                        i386         NVIDIA binary OpenGL|ES 2.x library
ii  libglx-nvidia0:amd64                  418.152.00-1                        amd64        NVIDIA binary GLX library
ii  libglx-nvidia0:i386                   418.152.00-1                        i386         NVIDIA binary GLX library
ii  libnvidia-cbl:amd64                   418.152.00-1                        amd64        NVIDIA binary Vulkan ray tracing (cbl) library
ii  libnvidia-cfg1:amd64                  418.152.00-1                        amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-compiler:amd64              418.152.00-1                        amd64        NVIDIA runtime compiler library
ii  libnvidia-eglcore:amd64               418.152.00-1                        amd64        NVIDIA binary EGL core libraries
ii  libnvidia-eglcore:i386                418.152.00-1                        i386         NVIDIA binary EGL core libraries
ii  libnvidia-fatbinaryloader:amd64       418.152.00-1                        amd64        NVIDIA FAT binary loader
ii  libnvidia-fatbinaryloader:i386        418.152.00-1                        i386         NVIDIA FAT binary loader
ii  libnvidia-glcore:amd64                418.152.00-1                        amd64        NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-glcore:i386                 418.152.00-1                        i386         NVIDIA binary OpenGL/GLX core libraries
ii  libnvidia-glvkspirv:amd64             418.152.00-1                        amd64        NVIDIA binary Vulkan Spir-V compiler library
ii  libnvidia-glvkspirv:i386              418.152.00-1                        i386         NVIDIA binary Vulkan Spir-V compiler library
ii  libnvidia-ml1:amd64                   418.152.00-1                        amd64        NVIDIA Management Library (NVML) runtime library
ii  libnvidia-ptxjitcompiler1:amd64       418.152.00-1                        amd64        NVIDIA PTX JIT Compiler
ii  libnvidia-ptxjitcompiler1:i386        418.152.00-1                        i386         NVIDIA PTX JIT Compiler
ii  libnvidia-rtcore:amd64                418.152.00-1                        amd64        NVIDIA binary Vulkan ray tracing (rtcore) library
ii  nvidia-alternative                    418.152.00-1                        amd64        allows the selection of NVIDIA as GLX provider
ii  nvidia-cuda-doc                       9.2.148-7                           all          NVIDIA CUDA and OpenCL documentation
ii  nvidia-detect                         418.152.00-1                        amd64        NVIDIA GPU detection utility
ii  nvidia-driver                         418.152.00-1                        amd64        NVIDIA metapackage
ii  nvidia-driver-bin                     418.152.00-1                        amd64        NVIDIA driver support binaries
ii  nvidia-driver-libs:amd64              418.152.00-1                        amd64        NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-driver-libs:i386               418.152.00-1                        i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES libraries)
ii  nvidia-driver-libs-i386:i386          418.152.00-1                        i386         NVIDIA metapackage (OpenGL/GLX/EGL/GLES 32-bit libraries)
ii  nvidia-egl-common                     418.152.00-1                        amd64        NVIDIA binary EGL driver - common files
ii  nvidia-egl-icd:amd64                  418.152.00-1                        amd64        NVIDIA EGL installable client driver (ICD)
ii  nvidia-egl-icd:i386                   418.152.00-1                        i386         NVIDIA EGL installable client driver (ICD)
ii  nvidia-installer-cleanup              20151021+9                          amd64        cleanup after driver installation with the nvidia-installer
ii  nvidia-kernel-common                  20151021+9                          amd64        NVIDIA binary kernel module support files
ii  nvidia-kernel-dkms                    418.152.00-1                        amd64        NVIDIA binary kernel module DKMS source
ii  nvidia-kernel-support                 418.152.00-1                        amd64        NVIDIA binary kernel module support files
ii  nvidia-legacy-check                   418.152.00-1                        amd64        check for NVIDIA GPUs requiring a legacy driver
ii  nvidia-modprobe                       418.56-1                            amd64        utility to load NVIDIA kernel modules and create device nodes
ii  nvidia-opencl-common                  418.152.00-1                        amd64        NVIDIA OpenCL driver - common files
ii  nvidia-opencl-dev:amd64               9.2.148-7                           amd64        NVIDIA OpenCL development files
ii  nvidia-opencl-icd:amd64               418.152.00-1                        amd64        NVIDIA OpenCL installable client driver (ICD)
ii  nvidia-openjdk-8-jre                  9.+8u77~9.2.148-7                   amd64        NVIDIA provided OpenJDK Java runtime, using Hotspot JIT
ii  nvidia-persistenced                   418.56-1                            amd64        daemon to maintain persistent software state in the NVIDIA driver
ii  nvidia-profiler                       9.2.148-7                           amd64        NVIDIA Profiler for CUDA and OpenCL
ii  nvidia-settings                       418.74-1                            amd64        tool for configuring the NVIDIA graphics driver
ii  nvidia-smi                            418.152.00-1                        amd64        NVIDIA System Management Interface
ii  nvidia-support                        20151021+9                          amd64        NVIDIA binary graphics driver support files
ii  nvidia-vdpau-driver:amd64             418.152.00-1                        amd64        Video Decode and Presentation API for Unix - NVIDIA driver
ii  nvidia-visual-profiler                9.2.148-7                           amd64        NVIDIA Visual Profiler for CUDA and OpenCL
ii  nvidia-vulkan-common                  418.152.00-1                        amd64        NVIDIA Vulkan driver - common files
ii  nvidia-vulkan-icd:amd64               418.152.00-1                        amd64        NVIDIA Vulkan installable client driver (ICD)
ii  nvidia-vulkan-icd:i386                418.152.00-1                        i386         NVIDIA Vulkan installable client driver (ICD)
ii  xserver-xorg-video-nvidia             418.152.00-1                        amd64        NVIDIA binary Xorg driver


merci de votre aide...

bilan  :  résolu en installant  le pilote nvidia   et en lancant les commandes.


Code :
sudo apt-get install nvidia-cuda-toolkit
sudo  apt-get install mesa-utils clinfo
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#2
Bonjour Patrick
Je ne peux pas te répondre pour openCL mais par contre tu peux tout à fait trouver les paquets d'install de la dernière version darktable (3.2.1) ici : https://software.opensuse.org/download.h...=darktable

Pour ma part, pas de problème OpenCL sous Linux Mint 20
G.Eco
Joujoux : Canon EOS 6D Mark II & 60D / Fujifilm X100V
Cailloux : Canon EF 50 f1.8 II / EF 24-105 f4 L IS USM II / EF 70-200 f4 L IS USM / Tokina AT-X 11-16 f2.8 DX
Dans les choux avec : dt 3.2.1 sous Linux Mint 20 Ulyana
Répondre
#3
merci du lien... mais debian bloque les depots ajoutés par add-apt-repository.

ce que je cherche c'est les paquets libnividia-compuute-418:am64 (et :i386) et le paquet libnvidia-opencl-dev
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#4
Salut patrick L

Les flatpak font tout un tas de trucs bizarres dans ton dos, c'est pas exclu que ce soit l'origine de ton problème.

Sur Debian, je te conseille plutôt d'utiliser les backports. Avec LMDE, donc Debian stable, tu auras au moins la v3.0.2 en attendant le prochain rétroportage de v3.2.1
> https://debian-facile.org/doc:system:apt...-backports
> https://packages.debian.org/search?suite...=darktable

Les noms des paquets et les dépendances ne sont pas forcément les mêmes entre Debian (donc LMDE) et Ubuntu (donc Mint), d'où le conseil de ne jamais mélanger les paquets ou dépots Debian avec ceux d'Ubuntu.
Vu que tu es passé sur LMDE, donc base Debian, la méthode que tu cites en lien ne va pas forcément fonctionner et les paquets ne portent pas forcément les mêmes noms.
Je n'ai pas de Debian sous la main, mais une chose est sûre, il n'y a aucun paquet libnvidia-compute-*.
> https://packages.debian.org/search?searc...ia-compute
Je pense plutôt que le paquet que tu cherches se nomme nvidia-libopencl1.

Pour info, les paquet *-dev ne servent que pour compiler. Ce qui n'est pas ton cas ici, donc même si le paquet ocl-icd-libopencl-dev existait, il ne te servirait à rien.
Répondre
#5
(03-10-20, 19:26)Nel a écrit : Salut patrick L

Les flatpak font tout un tas de trucs bizarres dans ton dos, c'est pas exclu que ce soit l'origine de ton problème.

Sur Debian, je te conseille plutôt d'utiliser les backports. Avec LMDE, donc Debian stable, tu auras au moins la v3.0.2 en attendant le prochain rétroportage de v3.2.1
> https://debian-facile.org/doc:system:apt...-backports
> https://packages.debian.org/search?suite...=darktable

Les noms des paquets et les dépendances ne sont pas forcément les mêmes entre Debian (donc LMDE) et Ubuntu (donc Mint), d'où le conseil de ne jamais mélanger les paquets ou dépots Debian avec ceux d'Ubuntu.
Vu que tu es passé sur LMDE, donc base Debian, la méthode que tu cites en lien ne va pas forcément fonctionner et les paquets ne portent pas forcément les mêmes noms.
Je n'ai pas de Debian sous la main, mais une chose est sûre, il n'y a aucun paquet libnvidia-compute-*.
> https://packages.debian.org/search?searc...ia-compute
Je pense plutôt que le paquet que tu cherches se nomme nvidia-libopencl1.

Pour info, les paquet *-dev ne servent que pour compiler. Ce qui n'est pas ton cas ici, donc même si le paquet ocl-icd-libopencl-dev existait, il ne te servirait à rien.

Merci de votre réponse.  
j'ai chargé  les backports...  et j'ai bien darktable 3.0.2 

mais j'ai une question :   est ce que c'est possible d'avoir opencl   mais sur le pilote "nouveau" de la carte graphique.    je suis revenu  avant l'installation  des pilotes graphiques nvidia parce que hier   j'ai eu un plantage comme avant sur mint 19 et 20?  

retour de inxi -G 
Code :
patrick@patrick-sedatech ~ $ inxi -G
Graphics:
  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] driver: nouveau v: kernel
  Display: x11 server: X.Org 1.20.4 driver: modesetting unloaded: fbdev,vesa
  resolution: 1920x1080~60Hz
  OpenGL: renderer: NV136 v: 4.3 Mesa 18.3.6



sur le flatpack     j'ai fait   flatpak   install  org.darktable.Darktable     et ca m'a mis plein de trucs y compris  sur la carte video...   j'ai desinstallé  via flatpak   remove org.darktable.Darktable    ensuite sur la doc flatpak   j'ai fait     flatpak   uninstall  --unused   org.darktable.Darktable flathub
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#6
Le pilote propriétaire Nvidia est obligatoire pour avoir OpenCL fonctionnel.
Le pilote nouveau gère très peu de chose. Pas d'accélération graphique, donc pas d'OpenGL ni d'OpenCL. En plus ta carte fonctionnera également en mode dégradé. Nvidia n'a pas fourni le firmware qui permet de débloquer la vitesse d'horloge et exploiter toutes les capacités des cartes graphiques pour les générations des GeForce 1000 et plus récentes. Bref, le pilote nouveau ne permet que l'affichage d'un simple bureau.

Par contre, ça m'étonne que le pilote Nvidia plante. Personnellement, je suis sur Linux+Nvidia depuis 2006, avec différentes cartes (6600GT, 9600GT, 660GTX, 1070Ti), plusieurs distributions en base Debian (Ubuntu, Mint, Debian), toutes les versions des pilotes au fur et à mesure de leur publication, et je n'ai jamais eu aucun souci de plantage, même dans les jeux vidéo les plus exigeants.
Répondre
#7
NelLe pilote propriétaire Nvidia est obligatoire pour avoir OpenCL fonctionnel.
Le pilote nouveau gère très peu de chose. Pas d'accélération graphique, donc pas d'OpenGL ni d'OpenCL. En plus ta carte fonctionnera également en mode dégradé. Nvidia n'a pas fourni le firmware qui permet de débloquer la vitesse d'horloge et exploiter toutes les capacités des cartes graphiques pour les générations des GeForce 1000 et plus récentes. Bref, le pilote nouveau ne permet que l'affichage d'un simple bureau.

Par contre, ça m'étonne que le pilote Nvidia plante. Personnellement, je suis sur Linux+Nvidia depuis 2006, avec différentes cartes (6600GT, 9600GT, 660GTX, 1070Ti), plusieurs distributions en base Debian (Ubuntu, Mint, Debian), toutes les versions des pilotes au fur et à mesure de leur publication, et je n'ai jamais eu aucun souci de plantage, même dans les jeux vidéo les plus exigeants.

j'ai peut etre un probleme de fiabilité de mon ordi sedatech.  
via les backports   j'ai une version 3.0.2  de darktable.   et j'ai viré la version   dans le flatpak moins  bien  que celle de aout 2020. donc je dois  remettre les pilotes nvidia et installer nvidia-libopencl1 ?

J'ai lu que nvidia est sur un projet pour integrer  les cartes nvidia dans les noyaux linux. 

www.phoronix.com/scan.php?page=news_item&px=MTI4MTc ( anglais).

et sur les plantages,    je fais comment pour avoir un log actif  juste avant le plantage  à envoyer parce que la plupart du temps je suis obligé de relancer via un reset.
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#8
Pour OpenCL si tu veux l'activer, tu n'as pas d'autres choix que de réinstaller les pilotes propriétaires Nvidia.

Après, te dire pourquoi ça plante, j'en sais strictement rien.
Déjà "Linux Mint plante", je sais pas du tout ce que ça veux dire. Est-ce que l'ordinateur redémarre tout seul ? Est-ce que l'affichage reste figé ? As-tu accès aux différents TTY, aux Magic SysRq key ? Est-ce que "le plantage" est juste temporaire ? À quel moment "ça plante" ? Quel évènement provoque "le plantage" ? Une action spécifique ? Un logiciel spécifique ? À part Linux Mint as-tu essayé d'autres distros ? Quels paramètres as-tu modifié dans ta distro ? etc.
Bref tant qu'on est pas devant ton ordinateur pour voir exactement ce qu'il se passe, personne ne pourra t'aider et moi à l'autre bout de la France encore moins.
Répondre
#9
lorsque ca plante, le pointeur souris ne bouge plus. ou alors disparait. egalement y la souris qui part dans tous les sens. ou se deplace irregulierement.

j'ai installé trois distributions, linux mint 19 19.3 et actuellement lmde4
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre
#10
bonjour à tous...

j'ai réussi à  installer opencl sur lmde4 en  installant  un  tres gros paquet.

Code :
sudo apt-get install nvidia-cuda-toolkit
sudo  apt-get install mesa-utils clinfo 


et bien sur faire un timeshift  en cas de gros probleme pendant    les manips.
hp compaq  - 4 go ram ssd 275 GO
linux mint 19 tara
appareil D5100 - objectif nikkor 18-55G 1:3.5-5.6 VR
objectif samyang  AE 14mm 1:2.8
-----

sedateck gamer, 
1TO disque dur,   240 GO SSD
8 GO de ram
carte nvidia gtx 1060

raspberry pi 4  2GO

darktable 3.0.1







Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)