Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Vos problèmes avec le dépôt OBS !
#1
Bonjour,

Ancien titre modifié "Dépôt OBS en panne aujourd'hui ?"

Je constate une interruption du dépôt OBS aujourd'hui ? https://software.opensuse.org/download.h...=darktable

Uniquement chez moi ?

[Image: 1605718066.png]

Cordialement.
[Image: Capture-d-cran-de-2021-01-12-12-31-37.png]
Répondre
#2
Idem pour moi
Répondre
#3
Itou.
Répondre
#4
Bonsoir,

Je viens de lancer le "Gestionnaire de mises à jour" résultat rien.
J'ai ensuite lancé la mise à jour par le terminal, la mise à jour git~2092 ne c'est pas installée ?
Par contre ce matin sous Manjaro tout c'est bien passé en git~2099, alors un problème avec le dépôt OBS ?

Code :
caille@caille-N76VB:~$ sudo apt update
[sudo] Mot de passe de caille :
Ign :1 http://liveusb.info/multisystem/depot all InRelease
Atteint :2 http://liveusb.info/multisystem/depot all Release                  
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal InRelease                
Atteint :4 http://ppa.launchpad.net/dhor/myway/ubuntu focal InRelease         
Atteint :5 http://security.ubuntu.com/ubuntu focal-security InRelease         
Atteint :6 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease        
Atteint :7 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease      
Atteint :8 http://download.opensuse.org/repositories/graphics:/darktable:/master/xUbuntu_20.04  InRelease
Atteint :9 https://linux.teamviewer.com/deb stable InRelease                  
Atteint :10 http://ppa.launchpad.net/libreoffice/libreoffice-7-0/ubuntu focal InRelease
Atteint :12 https://dl.winehq.org/wine-builds/ubuntu focal InRelease          
Atteint :13 http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease
Atteint :14 http://ppa.launchpad.net/yannubuntu/boot-repair/ubuntu focal InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@caille-N76VB:~$ apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2092.cbcebc57b amd64 [pouvant être mis à jour depuis : 3.3.0~git2084.a89402a4f]
N: Il y a des versions supplémentaires 3. Veuillez utiliser l'opérande « -a » pour les voir.
caille@caille-N76VB:~$ sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libayatana-appindicator3-1 libayatana-indicator3-7
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
caille@caille-N76VB:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libayatana-appindicator3-1 libayatana-indicator3-7
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
caille@caille-N76VB:~$ apt list --upgradable -a
En train de lister... Fait
darktable/inconnu 3.3.0~git2092.cbcebc57b amd64 [pouvant être mis à jour depuis : 3.3.0~git2084.a89402a4f]
darktable/now 3.3.0~git2084.a89402a4f amd64 [installé, pouvant être mis à jour vers : 3.3.0~git2092.cbcebc57b]
darktable/focal 3.0.1-0ubuntu1 amd64
darktable/focal 3.0.1-0dhor~focal amd64

caille@caille-N76VB:~$

Le terminal indique bien une mise à jour, mais il est indiqué darktable/inconnu et la mise à jour ne c'est pas faite, une idée ?

Code :
darktable/inconnu 3.3.0~git2092.cbcebc57b amd64 [pouvant être mis à jour depuis : 3.3.0~git2084.a89402a4f]
[Image: Capture-d-cran-de-2021-01-12-12-31-37.png]
Répondre
#5
Bonjour,

J'ai désinstallé Darktable avec Synaptic, depuis impossible de le réinstaller ?

Code :
caille@caille-N76VB:~$ sudo apt install darktable
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
darktable : Dépend: libexiv2-27 (>= 0.27.3) mais 0.27.2-8ubuntu2 devra être installé
             Dépend: libilmbase25 (>= 2.5.3) mais il n'est pas installable
             Dépend: libjson-glib-1.0-0 (>= 1.5.2) mais 1.4.4-2ubuntu2 devra être installé
             Dépend: libopenexr25 (>= 2.5.3) mais il n'est pas installable
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».
caille@caille-N76VB:~$

Que c'est-il donc passé avec ma version Ubuntu de darktable, maintenant il manque des dépendances ?
[Image: Capture-d-cran-de-2021-01-12-12-31-37.png]
Répondre
#6
Bonjour,

Même problème avec Linux-Mint 20, qui est assemblé à partir de Ubuntu 20.04
Le dépôt OBS semble poser des problèmes avec ces deux distributions, tout au moins chez moi, le git~2075 fonctionne toujours pour l'instant.

Code :
caille@caille-N76VB:~$ sudo apt update
[sudo] Mot de passe de caille :         
Atteint :1 http://mirrors.ircam.fr/pub/ubuntu/archive focal InRelease
Atteint :2 http://archive.canonical.com/ubuntu focal InRelease                
Ign :3 http://mirror6.layerjet.com/linuxmint/packages ulyana InRelease        
Atteint :4 http://mirrors.ircam.fr/pub/ubuntu/archive focal-updates InRelease 
Atteint :5 http://mirror6.layerjet.com/linuxmint/packages ulyana Release      
Atteint :6 http://ppa.launchpad.net/ubuntuhandbook1/gimp/ubuntu focal InRelease
Réception de :7 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Atteint :8 http://mirrors.ircam.fr/pub/ubuntu/archive focal-backports InRelease
Atteint :9 http://download.opensuse.org/repositories/graphics:/darktable:/master/xUbuntu_20.04  InRelease
Atteint :10 http://ppa.launchpad.net/xalt7x/chromium-deb-vaapi/ubuntu focal InRelease
Réception de :12 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,3 kB]
Réception de :13 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [56,5 kB]
190 ko réceptionnés en 2s (96,5 ko/s)        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@caille-N76VB:~$ apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@caille-N76VB:~$ apt list --upgradable -a
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
darktable/now 3.3.0~git2075.c06b55abd amd64 [installé, pouvant être mis à jour vers : 3.3.0~git2103.0c237c9e2]
darktable/focal 3.0.1-0ubuntu1 amd64

caille@caille-N76VB:~$ sudo apt upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.4.0-48 linux-headers-5.4.0-48-generic
  linux-image-5.4.0-48-generic linux-modules-5.4.0-48-generic
  linux-modules-extra-5.4.0-48-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
caille@caille-N76VB:~$

De plus maintenant j'ai désinstallé Darktable sur ma distribution Ubuntu et il manque des dépendances lors de l'installation ?

Code :
caille@debian:~$ sudo apt update
[sudo] Mot de passe de caille :
Atteint :1 http://deb.debian.org/debian unstable InRelease
Atteint :2 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@debian:~$ sudo apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2101.8f936ba7f]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@debian:~$ sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libboost-filesystem1.71.0 libboost-iostreams1.71.0 libgit2-1.0 libjsoncpp1
  libplymouth4
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  darktable
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 5 136 ko dans les archives.
Après cette opération, 5 120 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  darktable 3.3.0~git2103.0c237c9e2 [5 136 kB]
5 136 ko réceptionnés en 4s (1 466 ko/s)   
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 195421 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../darktable_3.3.0~git2103.0c237c9e2_amd64.deb ..
.
Dépaquetage de darktable (3.3.0~git2103.0c237c9e2) sur (3.3.0~git2101.8f936ba7f)
...
Paramétrage de darktable (3.3.0~git2103.0c237c9e2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
Traitement des actions différées (« triggers ») pour mailcap (3.67) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1)
 ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
caille@debian:~$

Sous Debian SID, la mise à jour passe bien...
[Image: Capture-d-cran-de-2021-01-12-12-31-37.png]
Répondre
#7
(14-12-20, 16:38)Caille a écrit : Bonjour,

Même problème avec Linux-Mint 20, qui est assemblé à partir de Ubuntu 20.04
Le dépôt OBS semble poser des problèmes avec ces deux distributions, tout au moins chez moi, le git~2075 fonctionne toujours pour l'instant.

Code :
caille@caille-N76VB:~$ sudo apt update
[sudo] Mot de passe de caille :         
Atteint :1 http://mirrors.ircam.fr/pub/ubuntu/archive focal InRelease
Atteint :2 http://archive.canonical.com/ubuntu focal InRelease                
Ign :3 http://mirror6.layerjet.com/linuxmint/packages ulyana InRelease        
Atteint :4 http://mirrors.ircam.fr/pub/ubuntu/archive focal-updates InRelease 
Atteint :5 http://mirror6.layerjet.com/linuxmint/packages ulyana Release      
Atteint :6 http://ppa.launchpad.net/ubuntuhandbook1/gimp/ubuntu focal InRelease
Réception de :7 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Atteint :8 http://mirrors.ircam.fr/pub/ubuntu/archive focal-backports InRelease
Atteint :9 http://download.opensuse.org/repositories/graphics:/darktable:/master/xUbuntu_20.04  InRelease
Atteint :10 http://ppa.launchpad.net/xalt7x/chromium-deb-vaapi/ubuntu focal InRelease
Réception de :12 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,3 kB]
Réception de :13 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [56,5 kB]
190 ko réceptionnés en 2s (96,5 ko/s)        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@caille-N76VB:~$ apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@caille-N76VB:~$ apt list --upgradable -a
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
darktable/now 3.3.0~git2075.c06b55abd amd64 [installé, pouvant être mis à jour vers : 3.3.0~git2103.0c237c9e2]
darktable/focal 3.0.1-0ubuntu1 amd64

caille@caille-N76VB:~$ sudo apt upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.4.0-48 linux-headers-5.4.0-48-generic
  linux-image-5.4.0-48-generic linux-modules-5.4.0-48-generic
  linux-modules-extra-5.4.0-48-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
caille@caille-N76VB:~$

De plus maintenant j'ai désinstallé Darktable sur ma distribution Ubuntu et il manque des dépendances lors de l'installation ?

Code :
caille@debian:~$ sudo apt update
[sudo] Mot de passe de caille :
Atteint :1 http://deb.debian.org/debian unstable InRelease
Atteint :2 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@debian:~$ sudo apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2101.8f936ba7f]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@debian:~$ sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libboost-filesystem1.71.0 libboost-iostreams1.71.0 libgit2-1.0 libjsoncpp1
  libplymouth4
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  darktable
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 5 136 ko dans les archives.
Après cette opération, 5 120 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  darktable 3.3.0~git2103.0c237c9e2 [5 136 kB]
5 136 ko réceptionnés en 4s (1 466 ko/s)  
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 195421 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../darktable_3.3.0~git2103.0c237c9e2_amd64.deb ..
.
Dépaquetage de darktable (3.3.0~git2103.0c237c9e2) sur (3.3.0~git2101.8f936ba7f)
...
Paramétrage de darktable (3.3.0~git2103.0c237c9e2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
Traitement des actions différées (« triggers ») pour mailcap (3.67) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1)
 ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
caille@debian:~$

Sous Debian SID, la mise à jour passe bien...

Je suis sous Ubuntu 20.04 et je suis aussi dans le même problème impossible d'installer darktable il manque des dépendances. 

Caille, tu sais regarder si dans ton dossier /var/cache/apt/archives si tu as les anciens paquets .deb de darktable? 

Si tu as les anciens, je veux bien une copie pour réinstaller une version antérieure de DT. 

Pour toi il suffit de reprendre un .deb de la version précédente au problème et de l'installer manuellement pour récupérer DT en attendant que e soit réparé. 
sudo apt install "le fichier.deb"

Si quelqu'un peu me passer un darktable .deb de la version master pour Ubuntu 20.04 des archives apt car moi j'ai malheureusement effacé le cache apt avec Bleachbit.
Luc Viatour Photographe 
Website
Répondre
#8
Voir : https://forums.darktable.fr/showthread.php?tid=5463
Répondre
#9
(15-12-20, 14:11)LViatour a écrit :
(14-12-20, 16:38)Caille a écrit : Bonjour,

Même problème avec Linux-Mint 20, qui est assemblé à partir de Ubuntu 20.04
Le dépôt OBS semble poser des problèmes avec ces deux distributions, tout au moins chez moi, le git~2075 fonctionne toujours pour l'instant.

Code :
caille@caille-N76VB:~$ sudo apt update
[sudo] Mot de passe de caille :         
Atteint :1 http://mirrors.ircam.fr/pub/ubuntu/archive focal InRelease
Atteint :2 http://archive.canonical.com/ubuntu focal InRelease                
Ign :3 http://mirror6.layerjet.com/linuxmint/packages ulyana InRelease        
Atteint :4 http://mirrors.ircam.fr/pub/ubuntu/archive focal-updates InRelease 
Atteint :5 http://mirror6.layerjet.com/linuxmint/packages ulyana Release      
Atteint :6 http://ppa.launchpad.net/ubuntuhandbook1/gimp/ubuntu focal InRelease
Réception de :7 http://security.ubuntu.com/ubuntu focal-security InRelease [109 kB]
Atteint :8 http://mirrors.ircam.fr/pub/ubuntu/archive focal-backports InRelease
Atteint :9 http://download.opensuse.org/repositories/graphics:/darktable:/master/xUbuntu_20.04  InRelease
Atteint :10 http://ppa.launchpad.net/xalt7x/chromium-deb-vaapi/ubuntu focal InRelease
Réception de :12 http://security.ubuntu.com/ubuntu focal-security/main amd64 DEP-11 Metadata [24,3 kB]
Réception de :13 http://security.ubuntu.com/ubuntu focal-security/universe amd64 DEP-11 Metadata [56,5 kB]
190 ko réceptionnés en 2s (96,5 ko/s)        
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@caille-N76VB:~$ apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@caille-N76VB:~$ apt list --upgradable -a
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2075.c06b55abd]
darktable/now 3.3.0~git2075.c06b55abd amd64 [installé, pouvant être mis à jour vers : 3.3.0~git2103.0c237c9e2]
darktable/focal 3.0.1-0ubuntu1 amd64

caille@caille-N76VB:~$ sudo apt upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade -a
E: L'option « a » de la ligne de commande [-a] n'est pas reconnue quand elle est utilisée avec d'autres options.
caille@caille-N76VB:~$ sudo apt full-upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  linux-headers-5.4.0-48 linux-headers-5.4.0-48-generic
  linux-image-5.4.0-48-generic linux-modules-5.4.0-48-generic
  linux-modules-extra-5.4.0-48-generic
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
caille@caille-N76VB:~$

De plus maintenant j'ai désinstallé Darktable sur ma distribution Ubuntu et il manque des dépendances lors de l'installation ?

Code :
caille@debian:~$ sudo apt update
[sudo] Mot de passe de caille :
Atteint :1 http://deb.debian.org/debian unstable InRelease
Atteint :2 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  InRelease
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
caille@debian:~$ sudo apt list --upgradable
En train de lister... Fait
darktable/inconnu 3.3.0~git2103.0c237c9e2 amd64 [pouvant être mis à jour depuis : 3.3.0~git2101.8f936ba7f]
N: Il y a des versions supplémentaires 2. Veuillez utiliser l'opérande « -a » pour les voir.
caille@debian:~$ sudo apt upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances      
Lecture des informations d'état... Fait
Calcul de la mise à jour... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libboost-filesystem1.71.0 libboost-iostreams1.71.0 libgit2-1.0 libjsoncpp1
  libplymouth4
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront mis à jour :
  darktable
1 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
Il est nécessaire de prendre 5 136 ko dans les archives.
Après cette opération, 5 120 o d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://download.opensuse.org/repositories/graphics:/darktable:/master/Debian_Unstable  darktable 3.3.0~git2103.0c237c9e2 [5 136 kB]
5 136 ko réceptionnés en 4s (1 466 ko/s)  
Lecture des fichiers de modifications (« changelog »)... Terminé
(Lecture de la base de données... 195421 fichiers et répertoires déjà installés.
)
Préparation du dépaquetage de .../darktable_3.3.0~git2103.0c237c9e2_amd64.deb ..
.
Dépaquetage de darktable (3.3.0~git2103.0c237c9e2) sur (3.3.0~git2101.8f936ba7f)
...
Paramétrage de darktable (3.3.0~git2103.0c237c9e2) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.3-2) ...
Traitement des actions différées (« triggers ») pour mailcap (3.67) ...
Traitement des actions différées (« triggers ») pour desktop-file-utils (0.26-1)
 ...
Traitement des actions différées (« triggers ») pour hicolor-icon-theme (0.17-2)
 ...
Traitement des actions différées (« triggers ») pour gnome-menus (3.36.0-1) ...
caille@debian:~$

Sous Debian SID, la mise à jour passe bien...

Je suis sous Ubuntu 20.04 et je suis aussi dans le même problème impossible d'installer darktable il manque des dépendances. 

Caille, tu sais regarder si dans ton dossier /var/cache/apt/archives si tu as les anciens paquets .deb de darktable? 

Si tu as les anciens, je veux bien une copie pour réinstaller une version antérieure de DT. 

Pour toi il suffit de reprendre un .deb de la version précédente au problème et de l'installer manuellement pour récupérer DT en attendant que e soit réparé. 
sudo apt install "le fichier.deb"

Si quelqu'un peu me passer un darktable .deb de la version master pour Ubuntu 20.04 des archives apt car moi j'ai malheureusement effacé le cache apt avec Bleachbit.

Bonsoir Luc,
Je te l'envoi : http://dl.free.fr/kENYOgFja mon Darktable 2084 fonctionne à nouveau.
[Image: Capture-d-cran-de-2021-01-12-12-31-37.png]
Répondre
#10
j'ai compilé une version cette après-midi pour travailler. En deux ans c'est la première fois que je suis bloqué ave une version de développement, au final pas trop de raison de râler Wink

J'utilise donc cette version compilée en attendant que ce soit résolu sur le dépôt master.
Luc Viatour Photographe 
Website
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)