Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
Vos problèmes avec le dépôt OBS !
#11
Bonsoir,
Je viens de lire ce topic, je suis aussi sous Ubuntu 20.04 et utilise le dépôt Opensuse. J'ai paramétré les Mise à Jour sur tous les jours et immédiat pour autres MàJ.
La dernière qui m'a été proposée est la git 2085 le 13/12/2020 à 11h13 et elle fonctionne correctement. A priori j'ai échappé au dysfonctionnement.
Par contre quand je vous lis sur le manque de dépendances, je me pose des questions sur cette version 20.04 qui me semble mal ficelée par rapport à la 18.04. Par exemple, tous les 10/15 lancements elle passe par le Grub au lieu de se lancer directement pourquoi?, je ne suis pas en double boot et je n'ai que cette version. autre exemple, cela fait 3 semaines que je suis obligé de lancer manuellement pulseaudio par le terminal etc etc... D'ici à ce qu'une mise à jour systémique ait foutu la zizanie dans les dépendances cela ne m'étonnerai pas et expliquerai pourquoi DT ne trouve plus les bonnes versions des dépendances.
Pour le moment j'ai aussi désactivé le dépôt en attendant des jours meilleurs.
Répondre
#12
Bonsoir,

Lorsque j'ai fait la mise à jour depuis Ubuntu, j'étais en version 2084 pour aller en 2092, alors que la 2085 fonctionne est tout à fait possible, mais pas la 2092, par contre sous Debian SID même dépôt et sous Manjaro "construction AUR" aucun problème.
J'espère que ce sera corrigé rapidement, mais si le problème vient. d'Ubuntu, il faudrait peut-être réinstaller les dépendances utilisé lors de la compilation pour voir si le dépôt ne fonctionnerait pas à nouveau, vu que Luc a réussi sa compilation ?

Bonne nuit.
[Image: Screenshot-20210721-200105.png]
Répondre
#13
Bonjour,
N'étant pas un "velu" de linux, j'ai mis dans logiciel et mise à jour le dépôt opensuse, car je n'étais pas très à l'aise avec la compilation surtout si il y a un message d'erreur. Tous les jours ou presque je reçois une mise à jour version 3.3.0 git XXXX qui s'installe comme si c'était une version stable, dans /bin et non dans /opt comme quand je compilais.
Je me pose la question si ça peut avoir une incidence sur les dépendances

Incroyable!!
Je viens de regarder le lien opensuse software où on a les dépôts pour plein de distributions. Il n'y  plus de possibilité pour l'heure d'afficher les paquets expérimentaux pour Ubuntu 20.04, MAIS pour 18.04, 19.10, et 20.10 ainsi que Debian 10 il est proposé la les paquets 3.5.0 git 0
Étonnant non??
Répondre
#14
la compilation est passée sans problème je viens de faire une mise à jour ce matin et je suis en 3.3.0+2114
La compilation doit certainement intégrer ce qu'à besoin DT car la version sur le serveur OpenSuse ne marche toujours pas.

Probablement que sur le serveur il ont compilé avec des paquets Ubuntu plus récents qui ne sont pas dispos dans Ununtu 20.04.
Luc Viatour Photographe 
Website
Répondre
#15
Bonjour,
Oui, sauf qu'ils proposent pour la 18.04 et pour les versions supérieures à 20.04. La résolution du problème viendra je pense des mainteneurs de la 20.04, ne pas oublier que c'est une LTS.
Répondre
#16
(16-12-20, 10:58)mimi85 a écrit : Incroyable!!
Je viens de regarder le lien opensuse software où on a les dépôts pour plein de distributions. Il n'y  plus de possibilité pour l'heure d'afficher les paquets expérimentaux pour Ubuntu 20.04, MAIS pour 18.04, 19.10, et 20.10 ainsi que Debian 10 il est proposé la les paquets 3.5.0 git 0
Étonnant non??

Bonjour mimi85,

Le dépôt disponible actuellement pour la 20.04 ne serait pas par hasard celui de la nouvelle Ubuntu 20.10 ?
Je n'ai jamais vu cette option de paquets expérimentaux avec le lien OpenSuse et j'aime bien tout ce qui est expérimental, car j'expérimente beaucoup. Big Grin
Je viens de compiler à nouveau Darktable 3.5.0+3~ge3efd26b0 sur ma 20.04.1, aucun problème.
Serait-il possible s'installer le dépôt Debian sous Ubuntu, vu qu'il fonctionne sous Debian SID et Buster ?
J'ai été sur darktable dans Synaptic, j'ai fait propriété cela m'a donné une adresse e-mail pkg-phototools-devel@lists.alioth.debian.org
J'ai donc envoyé un mail à cette adresse, mais visiblement cela n'est pas l'adresse mail du mainteneur du dépôt ?
La version stable est toujours la version darktable 3.2.1-1.1 , la nouvelle 3.4 devrait arrivée avant Noël.
PS: Le dépôt de la version stable OpenSuse sur 20.04.1 fonctionne-t-il bien ?

Cordialement.
[Image: Screenshot-20210721-200105.png]
Répondre
#17
Bonjour,

Citation :Je n'ai jamais vu cette option de paquets expérimentaux avec le lien OpenSuse et j'aime bien tout ce qui est expérimental, car j'expérimente beaucoup

C'est sous ce lien:
https://software.opensuse.org/package/darktable


Citation :Le dépôt de la version stable OpenSuse sur 20.04.1 fonctionne-t-il bien ?
Je ne sais pas jamais utilisé.

Avec le lien ci- dessus, dans les paquets expérimentaux pour la 20.04, j'ai choisi installation par PPA, ce qui fait que tous les jours j'ai la dernière compilation master SAUF que depuis la 3.3.0 git 2085 plus de propositions, et j'ai vu que le lien sur les paquets expérimentaux est cassé.
Pour moi qui ne suis pas un pro de la compilation, ça me convenait plutôt bien, pas besoin de compiler. Je crois que Luc en fait de même.
Répondre
#18
(17-12-20, 16:15)mimi85 a écrit : Bonjour,

Citation :Je n'ai jamais vu cette option de paquets expérimentaux avec le lien OpenSuse et j'aime bien tout ce qui est expérimental, car j'expérimente beaucoup

C'est sous ce lien:
https://software.opensuse.org/package/darktable


Citation :Le dépôt de la version stable OpenSuse sur 20.04.1 fonctionne-t-il bien ?
Je ne sais pas jamais utilisé.

Avec le lien ci- dessus, dans les paquets expérimentaux pour la 20.04, j'ai choisi installation par PPA, ce qui fait que tous les jours j'ai la dernière compilation master SAUF que depuis la 3.3.0 git 2085 plus de propositions, et j'ai vu que le lien sur les paquets expérimentaux est cassé.
Pour moi qui ne suis pas un pro de la compilation, ça me convenait plutôt bien, pas besoin de compiler. Je crois que Luc en fait de même.

Suite...

Merci pour le lien !

Aujourd'hui j'ai installé Ubuntu 20.10 pour essayer darktable_master via le dépôt, j'ai reçu comme erreur que l'installateur avait planté, l'installateur serait bu
J'ai lancé un rapport de bug sur le lien qui ce trouve un bas de cette page : "Raport de Bugs"
https://software.opensuse.org/download.h...=darktable
Actuellement j'essaye un autre logiciel, plus simple d'approche, mais moins puissant que Darktable que je continu d'utiliser, c'est ART pour "Another-Raw-Therapee"
Par contre il est indispensable de compiler que ce soit la version master ou la version stable, il existe un ppa pour la version 1.2 déjà  ancienne !

Cordialement.
[Image: Screenshot-20210721-200105.png]
Répondre
#19
J'ai fait l'essai de compiler la 3.5.0 git3 et essai transformé, j'ai même réussi à faire un lanceur sur le bureau (repris et modifié de la 18.04).
Quant à ART, j'ai vu et vite abandonné, on retrouve des similarités avec DT, mais je ne suis pas convaincu et j'apprécie trop DT. Pour ne pas polluer ton install, et ne pas compiler, il existe une App image de ART, c'est comme cela que je l'ai découvert.
Répondre
#20
(17-12-20, 16:15)mimi85 a écrit : Pour moi qui ne suis pas un pro de la compilation, ça me convenait plutôt bien, pas besoin de compiler. Je crois que Luc en fait de même.

En effet mais comme le dépôt OpenSuse pour Ununtu 20.04 est cassé, j'ai fais une compilation pour passer en 3.5.

C'est au final vite fait j'ai suivi les infos ici:
https://darktable.fr/2020/02/travailler-...darktable/

Et pour la création d'un lanceur j'ai suivi ceci:
https://forum.ubuntu-fr.org/viewtopic.php?id=2051318

Attention de bien respecter les commandes et de ne pas les faire en root quand ce n'est pas utile.
Luc Viatour Photographe 
Website
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)