Note de ce sujet :
  • Moyenne : 0 (0 vote(s))
  • 1
  • 2
  • 3
  • 4
  • 5
problème après choix préférence "relatif à la scène" et "moderne" avec DT flathub 3.4
#1
Bonjour,




j'ai utilisé DT Flathub 3.4.0 pendant quelques mois, avec Linux Mint 19.3 Tricia, sans aucune difficulté majeure.



Pour suivre les indications données pas Aurelien Pierre dans un de ses tutoriels pour les nuls (ce qui est bien mon cas!):  dans les préférences j'ai choisi:



- relatif à la scène

- moderne



Avec cette nouvelle situation DT me pose des problèmes.



L'affichage dans "table lumineuses" fait apparaît ainsi:




[Image: Schermata-del-2021-01-01-12-27-01.png]




et lorsque je passe à la "chambre noire" et ouvre "Filmic" la courbe n’appariât pas de façon correcte.




[Image: Schermata-del-2021-01-01-12-35-59.png]




J'ai désinstallé et réinstallé DT sans réussir à résoudre.




Ensuite j'ai opté pour l'installation ex-novo de tout le SO  passant à Linux Mint 20 Ulyana Cinnamon 64 bit et de DT Flathub 3.4.0 avec symantic



Puis, très prudemment, j'ai ouvert les préférences sans changer quoique se soit, et ensuite je suis sorti de DT.



Au nouveau démarrage du programme la situation détériorée s'est à nouveau présentée!




J'ai fait les deux printscreen que je joins.



À ce point j'ai fait recours à une nouvelle réinstallation d'Ulyana et de DT flathub 3.4.0.





DT fonctionne mais je n'ose plus changer les réglages.



Deux questions:



  • ce qui semble un bug (du moins sur mon pc) pourra-t-il être corrigé? Est-ce un problème connu?
  • du point de vue de l'usage de DT, le fait de ne pas utiliser les fonctions qui détraquent le programme, est vraiment essentiel pour le traitement des images?


Je remercie qui pourra me donner ses impressions et d’éventuels conseils.




Bonne journée à tous. Smile
Si ça vous tente de jeter un coup d’œil à mon Flickr.
Répondre
#2
Bonjour,

Tout d'abord, je ne recommanderai pas le dépôt flathub, c'est un flatpak et le fonctionnement n'est pas optimal.

Ensuite, ici, l'aspect de l'interface (les traits noirs notamment autour des différents éléments/icônes) montre que le CSS n'est pas correctement appliqué, donc l'aspect de l'interface n'est correctement affiché. Comment est le premier onglet des préférences ? Y a-t-il des paramètres CSS et la case de modification du thème cochée ? Si oui, bien vérifier si les paramètres CSS utilisateurs sont bien (capture d'écran si besoin à montrer). Si pas de paramètres CSS dans l'éditeur du premier onglet, décocher la case juste au dessus de modification du thème si elle est décochée. Si le problème persiste, même après avoir fait cela et sélectionner un thème à nouveau, il y a un problème sur les liens, peut-être lié à flathub.

Dans ce cas, ça va être plus compliqué et je n'ai jamais utilisé les paquets flatpak (trop de problème sur ce système de paquets à mon goût) et l'idéal serait de passer par un paquet classique, via le dépôt Opensuse et récupérer le paquet Ubuntu associé à cette distribution Mint. Attention, il faudra gérer le transfert du dossier de configuration, flatpak ne gérant pas ces dossiers au même endroit qu'un paquet deb classique.

Liens d'infos complémentaires sur flatpak et les problèmes potentiels associés :

https://forums.darktable.fr/showthread.p...ht=flatpak
https://forums.darktable.fr/showthread.p...ht=flatpak

Et un lien vers le dépôt Opensuse :

https://forums.darktable.fr/showthread.p...9#pid45639
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre
#3
Bonjour nicoauffray et merci pour l'aide,

je ne vais pas m'entêter sur flathub mais quand même j'aimerais bien comprendre un peu se qui se passe.
Peux-tu me dire, s'il te plait, ce que signifie "paramètres CSS"? Je ne connais pas cet acronyme...

Mon DT est installé avec italien, qui est la langue que j'utilise jour par jour bien que le français soit aussi ma langue maternelle, mais je viens de changer ce paramètre et passer au français pour faciliter la compréhension pendant cette conversation.
Suite au changement de langue le problème que j'ai exposé dans le message précédant s'est représenté.

Je suis donc allé chercher la case "modifier le thème via les ajustements CSS ci-dessous" .
La trouvant cochée je l'ai décochée et tout semble être rentré dans l'ordre.
Je ne dois pas, semble-t-il, sauvegarder et appliquer car si je le fais, en relançant le logiciel le problème se représente... tandis que si je ne sauvegarde et n'applique pas tout à l'air de fonctionner à merveille.

Dans la fenêtre sous "modifier le thème via les ajustements CSS ci-dessous" je trouve ce texte

/* Inserisci le modifiche al CSS qui /*

qui, curieusement est en italien.
Y-a-t-il une raison pour cela?

En conclusion, vu que maintenant tout est ok, je me rends compte d'avoir fait un tas de travail d'installation et de réinstallation pour bien peu de chose...
Bon j'y ai gagné le passage de Tricia 19.3 a Ulyana 20... mais ça aurait pu attendre.
Ah! la connaissance ça aide bien tandis que l'ignorance.... fait des ravages. Rolleyes Big Grin 

En tous cas merci infiniment pour l'aide, la docu et les liens fournis.
À plus Smile
Si ça vous tente de jeter un coup d’œil à mon Flickr.
Répondre
#4
Tu pourrais mettre le .cr2 sur un site de téléchargement ?
Répondre
#5
Quel site me conseilles-tu? Imgur ne semble pas accepter les files RAW Cr2
Si ça vous tente de jeter un coup d’œil à mon Flickr.
Répondre
#6
https://framadrop.org/lufi/ ou http://dl.free.fr/
Répondre
#7
Je suppose que ça a fonctionné... c'est du jamais fait pour moi donc tu me diras...

https://www.swisstransfer.com/d/8535dba1...7227213525
Si ça vous tente de jeter un coup d’œil à mon Flickr.
Répondre
#8
Je viens de télécharger sans problème et je viens de l'ouvrir avec darktable (version de développement master) réglé :
[Image: image.png]
et voilà ce que j'obtiens à l'ouverture :
[Image: image.png]
J'ai le même résultat avec darktable 3.4.
Répondre
#9
Bien alors, merci pour ce contrôle.
Ici aussi tout va pour le mieux et si je pense à combien j'ai peiné ces derniers jours... ça me met en boule! Cool 
Pour finir ta requête m'as permis de découvrir une fa"on de partager les files lourds depuis un site que j'utilisais déjà mais avec d'autres finalités.

Question rapide sort du sentier: je vois que tu as mis deux links vers flickr dans tes messages.
Comment faut-t-il faire pour y parvenir?
Pour le moment j'ai mi mon lien dans "site web" mais il me semble un peu caché...

Ohps! Je pense avoir trouvé le truc... en ajoutant le link comme signature
Si ça vous tente de jeter un coup d’œil à mon Flickr.
Répondre
#10
(04-01-21, 13:43)Jean-Marc a écrit : Bonjour nicoauffray et merci pour l'aide,

je ne vais pas m'entêter sur flathub mais quand même j'aimerais bien comprendre un peu se qui se passe.
Peux-tu me dire, s'il te plait, ce que signifie "paramètres CSS"? Je ne connais pas cet acronyme...

Mon DT est installé avec italien, qui est la langue que j'utilise jour par jour bien que le français soit aussi ma langue maternelle, mais je viens de changer ce paramètre et passer au français pour faciliter la compréhension pendant cette conversation.
Suite au changement de langue le problème que j'ai exposé dans le message précédant s'est représenté.

Je suis donc allé chercher la case "modifier le thème via les ajustements CSS ci-dessous" .
La trouvant cochée je l'ai décochée et tout semble être rentré dans l'ordre.
Je ne dois pas, semble-t-il, sauvegarder et appliquer car si je le fais, en relançant le logiciel le problème se représente... tandis que si je ne sauvegarde et n'applique pas tout à l'air de fonctionner à merveille.

Dans la fenêtre sous "modifier le thème via les ajustements CSS ci-dessous" je trouve ce texte

/* Inserisci le modifiche al CSS qui /*

qui, curieusement est en italien.
Y-a-t-il une raison pour cela?

En conclusion, vu que maintenant tout est ok, je me rends compte d'avoir fait un tas de travail d'installation et de réinstallation pour bien peu de chose...
Bon j'y ai gagné le passage de Tricia 19.3 a Ulyana 20... mais ça aurait pu attendre.
Ah! la connaissance ça aide bien tandis que l'ignorance.... fait des ravages. Rolleyes Big Grin 

En tous cas merci infiniment pour l'aide, la docu et les liens fournis.
À plus Smile

Le CSS est un langage qui permet de définir l'affichage des éléments de l'interface (il est utilisé aussi pour les pages web, en lien avec le langage HTML). Il permet de définir les marges, couleurs, tailles, position, etc. de chaque élément de l'interface. J'en suis le spécialiste pour darktable.

Le texte en italien est juste un commentaire, resté en italien parce que tu étais en italien pour l'interface sur le dernier enregistrement. Mais lui il peut rester. Attention, le bouton "Sauvegarder et appliquer" ne s'applique que pour l'éditeur texte (là où tu as le commentaire en italien). Donc si tu laisse cet éditeur par défaut et que tu n'ajoutes jamais aucune personnalisation CSS (ce qui semble probable vu que tu ne connais pas), ne clique jamais sur ce bouton. Pour tous les autres paramètres des préférences, ils sont automatiquement sauvegardés dès que tu les modifies. "Sauvegarder et appliquer" ne permet donc que de sauvegarder les ajouts personnels CSS et de les appliquer (donc cocher la case qui te pose problème). C'est d'ailleurs pour ça qu'elle est positionné uniquement dans l'éditeur texte et pas ailleurs.

En tout cas, il semble que tu viens de montrer un bug spécifique au paquets flatpak puisque normalement la case "modifier le thème via les ajustements CSS" même cochée et si aucun code CSS dans l'éditeur dessous, ne devrait pas poser problème à l'affichage. Et c'est certain qu'il n'y a pas de problème, j'utilise l'éditeur régulièrement pour des corrections/évolutions à tester. Bref, ça montre une fois de plus que les paquets flatpak, bah c'est pas l'idéal.
Aussi appelé Nilvus !
Ubuntu 20.04 LTS - darktable master
Répondre


Atteindre :


Utilisateur(s) parcourant ce sujet : 1 visiteur(s)